No Clock Update on KDE Dr46Onized

On my fresh install of KDE Dr46Onized gaming edition on new hardware, I found that Garuda was using the hardware clock value to set the system time on boot. The hardware clock understandably had an erroneous value as it was fresh off the production line. Consequently, the system clock would acquire a false value by default after every reboot, even if updated beforehand via the "ntpd -q -g" command or something similar.

Obviously, the solution to this issue is to update the system clock and use its value to correct the hardware clock via the "sudo hwclock --systohc" command.

Is this intended behavior? The standard procedure mentioned in System time - ArchWiki is to use the hardware clock value initially, update the system clock from the default servers and then update the hardware clock on shutdown. Since the system clock never updated automatically and the erroneous value persisted through reboots, the standard procedure obviously was not happening.

I used pamac to uninstall a bunch of end user applications like some of the included games before noticing the time issue. That's potentially the cause of this. I also changed the plasma themes from the settings application. That seems unlikely to be the cause of this problem.

inxi -Faz

System:    Kernel: 5.14.7-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
           root=UUID=1a97faf6-7ba2-49ec-b1a6-c220ce0c965e rw rootflags[email protected] quiet splash
           rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1
           resume=UUID=d43e6abc-bb07-448e-b1d2-f3876bf057a9 loglevel=3
           Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
           Distro: Garuda Linux base: Arch Linux
Machine:   Type: Desktop System: ASUS product: N/A v: N/A serial: <filter>
           Mobo: ASUSTeK model: ROG STRIX B550-F GAMING v: Rev X.0x serial: <filter>
           UEFI: American Megatrends v: 1401 date: 12/03/2020
CPU:       Info: 6-Core model: AMD Ryzen 5 5600X bits: 64 type: MT MCP arch: Zen 3
           family: 19 (25) model-id: 21 (33) stepping: 0 microcode: A201009 cache: L2: 3 MiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 88793
           Speed: 3597 MHz min/max: 2200/3700 MHz boost: enabled Core speeds (MHz): 1: 3597
           2: 3636 3: 4014 4: 3598 5: 3596 6: 3595 7: 3608 8: 3599 9: 3601 10: 3595 11: 3598
           12: 3591
           Vulnerabilities: Type: itlb_multihit status: Not affected
           Type: l1tf status: Not affected
           Type: mds status: Not affected
           Type: meltdown status: Not affected
           Type: spec_store_bypass
           mitigation: Speculative Store Bypass disabled via prctl and seccomp
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, STIBP:
           always-on, RSB filling
           Type: srbds status: Not affected
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: NVIDIA GM204 [GeForce GTX 970] vendor: eVga.com. driver: nvidia v: 470.74
           alternate: nouveau,nvidia_drm bus-ID: 06:00.0 chip-ID: 10de:13c2 class-ID: 0300
           Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: nvidia
           display-ID: :0 screens: 1
           Screen-1: 0 s-res: 1920x1080 s-dpi: 95 s-size: 513x292mm (20.2x11.5")
           s-diag: 590mm (23.2")
           Monitor-1: DVI-D-0 res: 1920x1080 hz: 60 dpi: 96 size: 509x286mm (20.0x11.3")
           diag: 584mm (23")
           OpenGL: renderer: NVIDIA GeForce GTX 970/PCIe/SSE2 v: 4.6.0 NVIDIA 470.74
           direct render: Yes
Audio:     Device-1: NVIDIA GM204 High Definition Audio vendor: eVga.com. driver: snd_hda_intel
           v: kernel bus-ID: 06:00.1 chip-ID: 10de:0fbb class-ID: 0403
           Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK driver: snd_hda_intel
           v: kernel bus-ID: 08:00.4 chip-ID: 1022:1487 class-ID: 0403
           Device-3: C-Media Blue Snowball type: USB driver: hid-generic,snd-usb-audio,usbhid
           bus-ID: 1-9:4 chip-ID: 0d8c:0005 class-ID: 0300 serial: <filter>
           Sound Server-1: ALSA v: k5.14.7-zen1-1-zen running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: yes
           Sound Server-4: PipeWire v: 0.3.37 running: yes
Network:   Device-1: Intel Ethernet I225-V vendor: ASUSTeK driver: igc v: kernel port: N/A
           bus-ID: 05:00.0 chip-ID: 8086:15f3 class-ID: 0200
           IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
           IF-ID-1: anbox0 state: down mac: <filter>
Drives:    Local Storage: total: 1.9 TiB used: 37.39 GiB (1.9%)
           SMART Message: Unable to run smartctl. Root privileges required.
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Sabrent model: Rocket 4.0 1TB
           size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s lanes: 4
           type: SSD serial: <filter> rev: RKT401.3 temp: 47.9 C scheme: GPT
           ID-2: /dev/nvme1n1 maj-min: 259:1 vendor: Addlink model: M.2 PCIE G3x4 NVMe
           size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4
           type: SSD serial: <filter> rev: ECFM32.1 temp: 28.9 C
           ID-3: /dev/sda maj-min: 8:0 type: USB vendor: SanDisk model: USB 3.2Gen1
           size: 57.3 GiB block-size: physical: 512 B logical: 512 B type: N/A serial: <filter>
           rev: 1.00 scheme: MBR
           SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition: ID-1: / raw-size: 896.87 GiB size: 896.87 GiB (100.00%) used: 37.39 GiB (4.2%)
           fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:3
           ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 562 KiB (0.2%)
           fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:2
           ID-3: /home raw-size: 896.87 GiB size: 896.87 GiB (100.00%) used: 37.39 GiB (4.2%)
           fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:3
           ID-4: /var/log raw-size: 896.87 GiB size: 896.87 GiB (100.00%) used: 37.39 GiB (4.2%)
           fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:3
           ID-5: /var/tmp raw-size: 896.87 GiB size: 896.87 GiB (100.00%) used: 37.39 GiB (4.2%)
           fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:3
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
           ID-1: swap-1 type: partition size: 34.38 GiB used: 0 KiB (0.0%) priority: -2
           dev: /dev/nvme0n1p3 maj-min: 259:4
           ID-2: swap-2 type: zram size: 31.26 GiB used: 0 KiB (0.0%) priority: 100
           dev: /dev/zram0
Sensors:   System Temperatures: cpu: 43.1 C mobo: N/A gpu: nvidia temp: 61 C
           Fan Speeds (RPM): N/A gpu: nvidia fan: 3%
Info:      Processes: 318 Uptime: 9m wakeups: 0 Memory: 31.26 GiB used: 2.65 GiB (8.5%)
           Init: systemd v: 249 tool: systemctl Compilers: gcc: 11.1.0 Packages: pacman: 1714
           lib: 509 Shell: fish v: 3.3.1 running-in: alacritty inxi: 3.3.06

Other possibly useful facts:
I tried to fix this issue with " timedatectl set-local-rtc 1 before seeing a scary warning message and reverting the change to 0.

"timedatectl" showed:
System clock synchronized: no
NTP service: active
RTC in local TZ: no

"systemctl status systemd-timesyncd systemd-networkd" showed active and running statuses for both services.

Interesting edge-case.

Yes - how would the system know to set the hardware clock unless you tell it to?

However, this should be happening during the installation process. Did you choose to sync the system clock? If not then you'll end up with the realtime clock value anyway.

3 Likes

I honestly can't remember coming across a clock sync option in the installation process.

I guess my question should have been, is it intended for Dragonized to not verify the hardware clock value with a time server check, or did I miss a setting for that choice during installation?

Is this the same issue as mine, where when I select "Set date and time automatically" in the Date & Time System Settings Module, it doesn't respect my time zone?

Because I've been having to set my clock manually. Not sure if it's the same thing, but there seems to be some kind of issue with clock synchronization.

Dual boot?

Dual boot?

Nope!

EDIT: I did leave the boot USB stick plugged in after installing if uhh, that counts.

This seems like a leading question. Why would someone not configure their system correctly in the first place?

"Is it intended that a car doesn't run if the first owner doesn't put any fuel in the tank?"

Technically the car not running isn't intended, but this is not a fault of the car designers.

1 Like

This seems like a leading question. Why would someone not configure their system correctly in the first place?

If your assumption here is that this clock behavior is obviously incorrect and any question about it must have an ulterior motive, think again.

There are valid reasons for an OS to not verify the hardware clock with a server check. For example, the name resolution servers in some geographic locations could hypothetically be untrustworthy or malicious. Given the lengths that software developers historically have gone to in the name of security, that concern isn't a ridiculous possibility.

"Is it intended that a car doesn't run if the first owner doesn't put any fuel in the tank?"
Technically the car not running isn't intended, but this is not a fault of the car designers.

If you bought a new car and found no fuel in the tank, wouldn't you question whether that was intentional or not? Granted, the clocks in new cars are usually wrong. That's usually not the case, however, among new OS installs.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.