No bluetooth adapters found error

Just installed KDE Dr460nised edition. All services are seems working fine except bluetooth. I have a HP-450 Notebook , which was running kde lite version,and also was running bluetooth fine. Today I have switched to the Dr460nised edition. But when I try to turn on bluetooth , nothing happenens and as you can see it says "No bluetooth adapters found". I have tried rfkill whitelist, updating the system , rebooting. Still no luck.

Attaching one screenshot here

Change the kernel to linux-lts

3 Likes

can you pls post your hardware specs

Ok i will try

I'm outside now, will post after reach home

It means devices, I guess. Do what it is suggested:
Add New Device

This should start scanning...

It's an issue on the kernel 5.10 itself. On a quick research, appears to be a problem with the module related to Qualcomm Atheros devices. The bug are reported here:
https://bugs.archlinux.org/task/69110
And there is a patch (which demands recompiling the kernel) - maybe there is some sort of solution better than just "rollback to lts". Good luck, devs!

1 Like

All the info I've read is that they do not intend to correct this issue on the newer kernels. So you'll either need to run an old kernel, compile your own kernel (applying the patch), or buy a new wifi adapter if you don't want to run an old kernel or compile your own.

3 Likes