No Audio Over Hdmi Nvidia + Intel Laptop

So, some time earlier this year I started using Garuda Linux and sometimes used a external monitor with a vga to hdmi adapter since my GPU doesn't have a vga output. The thing is when I connected this adapter it showed to me the GPU's audio output and even changed the audio device I was using. After some time using it I stopped using the monitor because It was having some faults, so I was not using a external monitor for some time now. Today my new tv/monitor arrived and I connected to see if the image worked fine and it worked but when I've put a movie to watch on the external monitor it didn't have sound, I search the forum and the arch wiki and all solutions seem outdated, and looked via pavucontrol to see if it could detect my gpu's audio and it didn't I'll let my inxi -Fxxxxa so you guys can help me along with some info.

System:    Host: inspiron-gaming Kernel: 5.10.41-1-lts x86_64 bits: 64 compiler: gcc v: 11.1.0 
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts 
           root=UUID=30f871dd-7d1e-48fd-8a77-9fcbb44a5f1a rw [email protected] quiet splash 
           rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 
           loglevel=3 
           Console: tty pts/1 wm: kwin_x11 DM: SDDM Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Laptop System: Dell product: Inspiron 15 7000 Gaming v: N/A serial: B7SCQM2 Chassis: 
           type: 10 serial: B7SCQM2 
           Mobo: Dell model: 0P84C9 v: A01 serial: /B7SCQM2/CNCMC007AV047F/ UEFI: Dell v: 1.12.1 
           date: 06/19/2020 
CPU:       Info: Quad Core model: Intel Core i7-7700HQ socket: U3E1 bits: 64 type: MT MCP 
           arch: Kaby Lake family: 6 model-id: 9E (158) stepping: 9 microcode: DE cache: L1: 256 KiB 
           L2: 6 MiB L3: 6 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 44798 
           Speed: 3527 MHz min/max: 800/3800 MHz base/boost: 2700/2800 volts: 0.9 V 
           ext-clock: 100 MHz Core speeds (MHz): 1: 3527 2: 3753 3: 3698 4: 3518 5: 3628 6: 3625 
           7: 3602 8: 3759 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass 
           mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: 
           conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel HD Graphics 630 vendor: Dell driver: i915 v: kernel bus-ID: 00:02.0 
           chip-ID: 8086:591b class-ID: 0300 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] vendor: Dell driver: nvidia v: 460.67 
           alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1c8c class-ID: 0300 
           Device-3: Realtek Integrated Webcam type: USB driver: uvcvideo bus-ID: 1-12:6 
           chip-ID: 0bda:568a class-ID: 0e02 serial: 0x0001 
           Display: server: X.Org 1.20.11 compositor: kwin_x11 driver: loaded: modesetting,nvidia 
           alternate: fbdev,intel,nouveau,nv,vesa display-ID: :0 screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 506x285mm (19.9x11.2") 
           s-diag: 581mm (22.9") 
           Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x193mm (13.5x7.6") 
           diag: 394mm (15.5") 
           OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 21.1.1 
           direct render: Yes 
Audio:     Device-1: Intel CM238 HD Audio vendor: Dell driver: snd_hda_intel v: kernel 
           bus-ID: 00:1f.3 chip-ID: 8086:a171 class-ID: 0403 
           Sound Server-1: ALSA v: k5.10.41-1-lts running: yes 
           Sound Server-2: JACK v: 0.125.0 running: no 
           Sound Server-3: PulseAudio v: 14.2 running: yes 
           Sound Server-4: PipeWire v: 0.3.28 running: yes 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Dell 
           driver: r8169 v: kernel port: d000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200 
           IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: 8c:ec:4b:0a:fc:a4 
           Device-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter vendor: Dell 
           driver: ath10k_pci v: kernel port: d000 bus-ID: 03:00.0 chip-ID: 168c:003e class-ID: 0280 
           IF: wlp3s0 state: down mac: d6:b8:59:d1:77:5e 
           IF-ID-1: docker0 state: down mac: 02:42:22:bd:f6:ef 
           IF-ID-2: vboxnet0 state: down mac: 0a:00:27:00:00:00 
Bluetooth: Device-1: Qualcomm Atheros type: USB driver: btusb v: 0.8 bus-ID: 1-4:4 chip-ID: 0cf3:e007 
           class-ID: e001 
           Report: bt-adapter ID: hci0 rfk-id: 1 state: down bt-service: enabled,running rfk-block: 
           hardware: no software: yes address: D4:6A:6A:FE:24:66 
Drives:    Local Storage: total: 1.82 TiB used: 473.3 GiB (25.4%) 
           ID-1: /dev/sda maj-min: 8:0 vendor: KingDian model: NGFF 2280 1TB SSD size: 931.51 GiB 
           block-size: physical: 512 B logical: 512 B sata: 3.2 speed: 6.0 Gb/s rotation: SSD 
           serial: 2020091600013 rev: 9A0 temp: 40 C scheme: GPT 
           SMART: yes state: enabled health: PASSED on: 112d 11h cycles: 165 read: 40.5 MiB 
           written: 62.8 MiB 
           ID-2: /dev/sdb maj-min: 8:16 vendor: Toshiba model: MQ01ABD100 family: 2.5" HDD MQ01ABD... 
           size: 931.51 GiB block-size: physical: 4096 B logical: 512 B sata: 3.0 speed: 6.0 Gb/s 
           rotation: 5400 rpm serial: Y7BKTALYT rev: 3D temp: 37 C scheme: GPT 
           SMART: yes state: enabled health: PASSED on: 2y 61d 13h cycles: 1364 read: 11.76 TiB 
           written: 10.75 TiB Old-Age: g-sense error rate: 2037 
Partition: ID-1: / raw-size: 100.59 GiB size: 100.59 GiB (100.00%) used: 66.32 GiB (65.9%) fs: btrfs 
           block-size: 4096 B dev: /dev/sda3 maj-min: 8:3 
           ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 560 KiB (0.2%) fs: vfat 
           block-size: 512 B dev: /dev/sda1 maj-min: 8:1 
           ID-3: /home raw-size: 830.63 GiB size: 830.63 GiB (100.00%) used: 229.75 GiB (27.7%) 
           fs: btrfs block-size: 4096 B dev: /dev/sda2 maj-min: 8:2 
           ID-4: /var/log raw-size: 100.59 GiB size: 100.59 GiB (100.00%) used: 66.32 GiB (65.9%) 
           fs: btrfs block-size: 4096 B dev: /dev/sda3 maj-min: 8:3 
           ID-5: /var/tmp raw-size: 100.59 GiB size: 100.59 GiB (100.00%) used: 66.32 GiB (65.9%) 
           fs: btrfs block-size: 4096 B dev: /dev/sda3 maj-min: 8:3 
Swap:      Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100) 
           ID-1: swap-1 type: zram size: 2.92 GiB used: 512 KiB (0.0%) priority: 32767 
           dev: /dev/zram0 
           ID-2: swap-2 type: zram size: 2.92 GiB used: 512 KiB (0.0%) priority: 32767 
           dev: /dev/zram1 
           ID-3: swap-3 type: zram size: 2.92 GiB used: 512 KiB (0.0%) priority: 32767 
           dev: /dev/zram2 
           ID-4: swap-4 type: zram size: 2.92 GiB used: 512 KiB (0.0%) priority: 32767 
           dev: /dev/zram3 
           ID-5: swap-5 type: zram size: 2.92 GiB used: 512 KiB (0.0%) priority: 32767 
           dev: /dev/zram4 
           ID-6: swap-6 type: zram size: 2.92 GiB used: 256 KiB (0.0%) priority: 32767 
           dev: /dev/zram5 
           ID-7: swap-7 type: zram size: 2.92 GiB used: 256 KiB (0.0%) priority: 32767 
           dev: /dev/zram6 
           ID-8: swap-8 type: zram size: 2.92 GiB used: 256 KiB (0.0%) priority: 32767 
           dev: /dev/zram7 
Sensors:   System Temperatures: cpu: 54.0 C mobo: 45.0 C sodimm: SODIMM C 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 318 Uptime: 10h 51m wakeups: 15 Memory: 23.35 GiB used: 6.36 GiB (27.2%) 
           Init: systemd v: 248 tool: systemctl Compilers: gcc: 11.1.0 clang: 11.1.0 Packages: 1975 
           pacman: 1964 lib: 548 flatpak: 6 snap: 5 Shell: Zsh (sudo) v: 5.8 default: Bash v: 5.1.8 
           running-in: konsole inxi: 3.3.04 

1 Like

I found this thread but I don't know if it applies to me [SOLVED] NVIDIA Driver 460 No Sound Over HDMI - Linux Mint Forums

aplay -l                                                                                            ─╯
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC3246 Analog [ALC3246 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0


lspci

00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v6/7th Gen Core Processor Host Bridge/DRAM Registers (rev 05)
00:01.0 PCI bridge: Intel Corporation 6th-9th Gen Core Processor PCIe Controller (x16) (rev 05)
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 630 (rev 04)
00:04.0 Signal processing controller: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem (rev 05)
00:14.0 USB controller: Intel Corporation 100 Series/C230 Series Chipset Family USB 3.0 xHCI Controller (rev 31)
00:14.2 Signal processing controller: Intel Corporation 100 Series/C230 Series Chipset Family Thermal Subsystem (rev 31)
00:15.0 Signal processing controller: Intel Corporation 100 Series/C230 Series Chipset Family Serial IO I2C Controller #0 (rev 31)
00:15.1 Signal processing controller: Intel Corporation 100 Series/C230 Series Chipset Family Serial IO I2C Controller #1 (rev 31)
00:16.0 Communication controller: Intel Corporation 100 Series/C230 Series Chipset Family MEI Controller #1 (rev 31)
00:17.0 SATA controller: Intel Corporation HM170/QM170 Chipset SATA Controller [AHCI Mode] (rev 31)
00:1c.0 PCI bridge: Intel Corporation 100 Series/C230 Series Chipset Family PCI Express Root Port #5 (rev f1)
00:1c.5 PCI bridge: Intel Corporation 100 Series/C230 Series Chipset Family PCI Express Root Port #6 (rev f1)
00:1f.0 ISA bridge: Intel Corporation HM175 Chipset LPC/eSPI Controller (rev 31)
00:1f.2 Memory controller: Intel Corporation 100 Series/C230 Series Chipset Family Power Management Controller (rev 31)
00:1f.3 Audio device: Intel Corporation CM238 HD Audio Controller (rev 31)
00:1f.4 SMBus: Intel Corporation 100 Series/C230 Series Chipset Family SMBus (rev 31)
01:00.0 VGA compatible controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Ti Mobile] (rev a1)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
03:00.0 Network controller: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter (rev 32)

pacman -Q nvidia                                                                                    ─╯
chaotic-nvidia-dkms-tkg 460.67-1

should I try to change the driver to lts ? since I'm using a lts kernel

How could you run both of them at a time? :thinking:
I think you didn't replace PulseAudio properly.

Could you link to me how to replace them ?

In Garuda Assistant only one of them should be ticked. Try switching to the other one and switching back. The changes get apply on the next reboot. After rebooting execute the same command to check if PipeWire is "Yes" and PulseAudio is "No".

Okay, only pulse is ticked


I ticked pipewire should I reboot ?

Now it shows this on inxi:

System:    Host: inspiron-gaming Kernel: 5.10.41-1-lts x86_64 bits: 64 compiler: gcc v: 11.1.0 
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts 
           root=UUID=30f871dd-7d1e-48fd-8a77-9fcbb44a5f1a rw [email protected] quiet splash 
           rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 
           loglevel=3 
           Console: tty pts/0 wm: kwin_x11 DM: SDDM Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Laptop System: Dell product: Inspiron 15 7000 Gaming v: N/A serial: B7SCQM2 Chassis: 
           type: 10 serial: B7SCQM2 
           Mobo: Dell model: 0P84C9 v: A01 serial: /B7SCQM2/CNCMC007AV047F/ UEFI: Dell v: 1.12.1 
           date: 06/19/2020 
CPU:       Info: Quad Core model: Intel Core i7-7700HQ socket: U3E1 bits: 64 type: MT MCP 
           arch: Kaby Lake family: 6 model-id: 9E (158) stepping: 9 microcode: DE cache: L1: 256 KiB 
           L2: 6 MiB L3: 6 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 44798 
           Speed: 3610 MHz min/max: 800/3800 MHz base/boost: 2700/2800 volts: 0.9 V 
           ext-clock: 100 MHz Core speeds (MHz): 1: 3610 2: 3625 3: 3549 4: 3644 5: 3779 6: 3497 
           7: 3687 8: 3530 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass 
           mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: 
           conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel HD Graphics 630 vendor: Dell driver: i915 v: kernel bus-ID: 00:02.0 
           chip-ID: 8086:591b class-ID: 0300 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] vendor: Dell driver: nvidia v: 460.67 
           alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1c8c class-ID: 0300 
           Device-3: Realtek Integrated Webcam type: USB driver: uvcvideo bus-ID: 1-12:6 
           chip-ID: 0bda:568a class-ID: 0e02 serial: 0x0001 
           Display: server: X.Org 1.20.11 compositor: kwin_x11 driver: loaded: modesetting,nvidia 
           alternate: fbdev,intel,nouveau,nv,vesa display-ID: :0 screens: 1 
           Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1013x285mm (39.9x11.2") 
           s-diag: 1052mm (41.4") 
           Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x193mm (13.5x7.6") 
           diag: 394mm (15.5") 
           Monitor-2: HDMI-1-0 res: 1920x1080 hz: 60 dpi: 30 size: 1600x900mm (63.0x35.4") 
           diag: 1836mm (72.3") 
           OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 21.1.1 
           direct render: Yes 
Audio:     Device-1: Intel CM238 HD Audio vendor: Dell driver: snd_hda_intel v: kernel 
           bus-ID: 00:1f.3 chip-ID: 8086:a171 class-ID: 0403 
           Sound Server-1: ALSA v: k5.10.41-1-lts running: yes 
           Sound Server-2: JACK v: 0.125.0 running: no 
           Sound Server-3: PulseAudio v: 14.2 running: no 
           Sound Server-4: PipeWire v: 0.3.28 running: yes 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Dell 
           driver: r8169 v: kernel port: d000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200 
           IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: 8c:ec:4b:0a:fc:a4 
           Device-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter vendor: Dell 
           driver: ath10k_pci v: kernel port: d000 bus-ID: 03:00.0 chip-ID: 168c:003e class-ID: 0280 
           IF: wlp3s0 state: down mac: 3a:22:96:96:84:34 
           IF-ID-1: docker0 state: down mac: 02:42:43:2b:ac:9f 
Bluetooth: Device-1: Qualcomm Atheros type: USB driver: btusb v: 0.8 bus-ID: 1-4:4 chip-ID: 0cf3:e007 
           class-ID: e001 
           Report: bt-adapter ID: hci0 rfk-id: 0 state: down bt-service: enabled,running rfk-block: 
           hardware: no software: yes address: D4:6A:6A:FE:24:66 
Drives:    Local Storage: total: 1.82 TiB used: 291.5 GiB (15.6%) 
           ID-1: /dev/sda maj-min: 8:0 vendor: KingDian model: NGFF 2280 1TB SSD size: 931.51 GiB 
           block-size: physical: 512 B logical: 512 B sata: 3.2 speed: 6.0 Gb/s rotation: SSD 
           serial: 2020091600013 rev: 9A0 temp: 40 C scheme: GPT 
           SMART: yes state: enabled health: PASSED on: 112d 12h cycles: 166 read: 40.7 MiB 
           written: 62.9 MiB 
           ID-2: /dev/sdb maj-min: 8:16 vendor: Toshiba model: MQ01ABD100 family: 2.5" HDD MQ01ABD... 
           size: 931.51 GiB block-size: physical: 4096 B logical: 512 B sata: 3.0 speed: 6.0 Gb/s 
           rotation: 5400 rpm serial: Y7BKTALYT rev: 3D temp: 35 C scheme: GPT 
           SMART: yes state: enabled health: PASSED on: 2y 61d 14h cycles: 1365 read: 11.76 TiB 
           written: 10.75 TiB Old-Age: g-sense error rate: 2037 
Partition: ID-1: / raw-size: 100.59 GiB size: 100.59 GiB (100.00%) used: 61.76 GiB (61.4%) fs: btrfs 
           block-size: 4096 B dev: /dev/sda3 maj-min: 8:3 
           ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 560 KiB (0.2%) fs: vfat 
           block-size: 512 B dev: /dev/sda1 maj-min: 8:1 
           ID-3: /home raw-size: 830.63 GiB size: 830.63 GiB (100.00%) used: 229.74 GiB (27.7%) 
           fs: btrfs block-size: 4096 B dev: /dev/sda2 maj-min: 8:2 
           ID-4: /var/log raw-size: 100.59 GiB size: 100.59 GiB (100.00%) used: 61.76 GiB (61.4%) 
           fs: btrfs block-size: 4096 B dev: /dev/sda3 maj-min: 8:3 
           ID-5: /var/tmp raw-size: 100.59 GiB size: 100.59 GiB (100.00%) used: 61.76 GiB (61.4%) 
           fs: btrfs block-size: 4096 B dev: /dev/sda3 maj-min: 8:3 
Swap:      Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100) 
           ID-1: swap-1 type: zram size: 2.92 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0 
           ID-2: swap-2 type: zram size: 2.92 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1 
           ID-3: swap-3 type: zram size: 2.92 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2 
           ID-4: swap-4 type: zram size: 2.92 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3 
           ID-5: swap-5 type: zram size: 2.92 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram4 
           ID-6: swap-6 type: zram size: 2.92 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram5 
           ID-7: swap-7 type: zram size: 2.92 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram6 
           ID-8: swap-8 type: zram size: 2.92 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram7 
Sensors:   System Temperatures: cpu: 58.0 C mobo: 45.0 C sodimm: SODIMM C 
           Fan Speeds (RPM): cpu: 2270 
Info:      Processes: 324 Uptime: 3m wakeups: 2 Memory: 23.35 GiB used: 3.99 GiB (17.1%) 
           Init: systemd v: 248 tool: systemctl Compilers: gcc: 11.1.0 clang: 11.1.0 Packages: 1976 
           pacman: 1965 lib: 548 flatpak: 6 snap: 5 Shell: Zsh (sudo) v: 5.8 default: Bash v: 5.1.8 
           running-in: konsole inxi: 3.3.04 

Also I don't have sounds anymore

Is Audio working fine with inbuilt speaker now (without HDMI connected)? If working, what else you can try:

  1. Update the system: upd
  2. Check if the issue is with the hardware (TV, cable or adapter)
  3. Try screening with Garuda live USB by booting with proprietary open source driver.

No need for any of that, I found out the problem was alsa not saving the levels and the setting to use my headphones nor my speakers. I made it work by looking into the arch wiki and some forum answers about it and they recommended to uses alsactl storeand alsactl restore after boot, but alsamixer was not saving the settings on the default location so I started saving the config on a file inside ~/.config/ with alsactl --file [location] store and sleep 5 && alsactl --file [location] restore on a .desktop init file for kde.
About the HDMI output audio device, the change didn't help me with it, actually it didn't change anything about the devices alsa showed but showed me a "easier" way of controlling my audio and microphone (now I'm looking for noise canceling on the mic).

Although your suggestion of changing to pipewire was not at all useless, I found my answer elsewhere.

What I found is that mhwd actually disables the gpu's audio source on the rules for whatever reason. I found it while looking for the same problem with ubuntu users on this :sound - NVidia 460 update disables HDMI audio output - Ask Ubuntu that also linked to this: No HDMI Audio on Nvidia 1660 Super (Driver 460) & Ubuntu 20.10 - #5 by duffleda - Linux - NVIDIA Developer Forums where I found what I was going to have to look for, but instead of it being under /lib/udev/rule.d it was on /etc/udev/rules.d/90-mhwd-prime-powermanagement.rules where the second line was uncommented

# Remove NVIDIA Audio devices, if present
#ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x040300", ATTR{remove}="1"

when I commented and restarted the laptop the hdmi output worked and shows on the inxi!

System:    Host: inspiron-gaming Kernel: 5.10.41-1-lts x86_64 bits: 64 compiler: gcc v: 11.1.0 
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts 
           root=UUID=30f871dd-7d1e-48fd-8a77-9fcbb44a5f1a rw [email protected] quiet splash 
           rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 
           loglevel=3 
           Console: tty pts/0 wm: kwin_x11 DM: SDDM Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Laptop System: Dell product: Inspiron 15 7000 Gaming v: N/A serial: B7SCQM2 Chassis: 
           type: 10 serial: B7SCQM2 
           Mobo: Dell model: 0P84C9 v: A01 serial: /B7SCQM2/CNCMC007AV047F/ UEFI: Dell v: 1.12.1 
           date: 06/19/2020 
CPU:       Info: Quad Core model: Intel Core i7-7700HQ socket: U3E1 bits: 64 type: MT MCP 
           arch: Kaby Lake family: 6 model-id: 9E (158) stepping: 9 microcode: DE cache: L1: 256 KiB 
           L2: 6 MiB L3: 6 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 44798 
           Speed: 2769 MHz min/max: 800/3800 MHz base/boost: 2700/2800 volts: 0.9 V 
           ext-clock: 100 MHz Core speeds (MHz): 1: 2769 2: 3612 3: 3430 4: 3168 5: 3305 6: 3506 
           7: 3422 8: 3481 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass 
           mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: 
           conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel HD Graphics 630 vendor: Dell driver: i915 v: kernel bus-ID: 00:02.0 
           chip-ID: 8086:591b class-ID: 0300 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] vendor: Dell driver: nvidia v: 460.67 
           alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1c8c class-ID: 0300 
           Device-3: Realtek Integrated Webcam type: USB driver: uvcvideo bus-ID: 1-12:6 
           chip-ID: 0bda:568a class-ID: 0e02 serial: 0x0001 
           Display: server: X.Org 1.20.11 compositor: kwin_x11 driver: loaded: modesetting,nvidia 
           alternate: fbdev,intel,nouveau,nv,vesa display-ID: :0 screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
           s-diag: 582mm (22.9") 
           Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x193mm (13.5x7.6") 
           diag: 394mm (15.5") 
           OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 21.1.1 
           direct render: Yes 
Audio:     Device-1: Intel CM238 HD Audio vendor: Dell driver: snd_hda_intel v: kernel 
           bus-ID: 00:1f.3 chip-ID: 8086:a171 class-ID: 0403 
           Device-2: NVIDIA GP107GL High Definition Audio driver: snd_hda_intel v: kernel 
           bus-ID: 01:00.1 chip-ID: 10de:0fb9 class-ID: 0403 
           Sound Server-1: ALSA v: k5.10.41-1-lts running: yes 
           Sound Server-2: JACK v: 0.125.0 running: no 
           Sound Server-3: PulseAudio v: 14.2 running: no 
           Sound Server-4: PipeWire v: 0.3.28 running: yes 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Dell 
           driver: r8169 v: kernel port: d000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200 
           IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: 8c:ec:4b:0a:fc:a4 
           Device-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter vendor: Dell 
           driver: ath10k_pci v: kernel port: d000 bus-ID: 03:00.0 chip-ID: 168c:003e class-ID: 0280 
           IF: wlp3s0 state: down mac: b2:a5:21:98:e0:a9 
           IF-ID-1: docker0 state: down mac: 02:42:ca:3b:a3:d3 
Bluetooth: Device-1: Qualcomm Atheros type: USB driver: btusb v: 0.8 bus-ID: 1-4:4 chip-ID: 0cf3:e007 
           class-ID: e001 
           Report: bt-adapter ID: hci0 rfk-id: 0 state: down bt-service: enabled,running rfk-block: 
           hardware: no software: yes address: D4:6A:6A:FE:24:66 
Drives:    Local Storage: total: 1.82 TiB used: 291.04 GiB (15.6%) 
           ID-1: /dev/sda maj-min: 8:0 vendor: KingDian model: NGFF 2280 1TB SSD size: 931.51 GiB 
           block-size: physical: 512 B logical: 512 B sata: 3.2 speed: 6.0 Gb/s rotation: SSD 
           serial: 2020091600013 rev: 9A0 temp: 40 C scheme: GPT 
           SMART: yes state: enabled health: PASSED on: 112d 15h cycles: 167 read: 41.1 MiB 
           written: 63 MiB 
           ID-2: /dev/sdb maj-min: 8:16 vendor: Toshiba model: MQ01ABD100 family: 2.5" HDD MQ01ABD... 
           size: 931.51 GiB block-size: physical: 4096 B logical: 512 B sata: 3.0 speed: 6.0 Gb/s 
           rotation: 5400 rpm serial: Y7BKTALYT rev: 3D temp: 33 C scheme: GPT 
           SMART: yes state: enabled health: PASSED on: 2y 61d 17h cycles: 1366 read: 11.76 TiB 
           written: 10.75 TiB Old-Age: g-sense error rate: 2037 
Partition: ID-1: / raw-size: 100.59 GiB size: 100.59 GiB (100.00%) used: 61.31 GiB (61.0%) fs: btrfs 
           block-size: 4096 B dev: /dev/sda3 maj-min: 8:3 
           ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 560 KiB (0.2%) fs: vfat 
           block-size: 512 B dev: /dev/sda1 maj-min: 8:1 
           ID-3: /home raw-size: 830.63 GiB size: 830.63 GiB (100.00%) used: 229.73 GiB (27.7%) 
           fs: btrfs block-size: 4096 B dev: /dev/sda2 maj-min: 8:2 
           ID-4: /var/log raw-size: 100.59 GiB size: 100.59 GiB (100.00%) used: 61.31 GiB (61.0%) 
           fs: btrfs block-size: 4096 B dev: /dev/sda3 maj-min: 8:3 
           ID-5: /var/tmp raw-size: 100.59 GiB size: 100.59 GiB (100.00%) used: 61.31 GiB (61.0%) 
           fs: btrfs block-size: 4096 B dev: /dev/sda3 maj-min: 8:3 
Swap:      Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100) 
           ID-1: swap-1 type: zram size: 2.92 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0 
           ID-2: swap-2 type: zram size: 2.92 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1 
           ID-3: swap-3 type: zram size: 2.92 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2 
           ID-4: swap-4 type: zram size: 2.92 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3 
           ID-5: swap-5 type: zram size: 2.92 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram4 
           ID-6: swap-6 type: zram size: 2.92 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram5 
           ID-7: swap-7 type: zram size: 2.92 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram6 
           ID-8: swap-8 type: zram size: 2.92 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram7 
Sensors:   System Temperatures: cpu: 55.0 C mobo: 42.0 C sodimm: SODIMM C 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 311 Uptime: 22m wakeups: 4 Memory: 23.35 GiB used: 4.56 GiB (19.5%) 
           Init: systemd v: 248 tool: systemctl Compilers: gcc: 11.1.0 clang: 11.1.0 Packages: 1975 
           pacman: 1964 lib: 548 flatpak: 6 snap: 5 Shell: Zsh (sudo) v: 5.8 default: Bash v: 5.1.8 
           running-in: konsole inxi: 3.3.04 

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.