No audio on hp envy x360

no matter what i do the audio just will not play on my install, i tried reinstalling but it still doesn't. i went through and searched the arch wikis and they said stuff about drivers that i didn't understand. i tried following their instructions but it didn't work. i just want to be able to use the built in speakers in my laptop and would really appreciate any help, thanks!

garuda-inxi gives:
System:
Kernel: 5.18.15-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=cfcb03a3-a209-484c-a743-5f5e0d1a2c6b rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.25.3 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Convertible System: HP product: HP ENVY x360 2-in-1 Laptop 15-ey0xxx
v: Type1ProductConfigId serial: <superuser required> Chassis: type: 31
serial: <superuser required>
Mobo: HP model: 8A31 v: 26.29 serial: <superuser required> UEFI: Insyde
v: F.05 date: 04/07/2022
Battery:
ID-1: BAT1 charge: 13.3 Wh (25.4%) condition: 52.3/51.0 Wh (102.6%)
volts: 11.1 min: 11.6 model: Hewlett-Packard PABAS0241231 type: Li-ion
serial: <filter> status: discharging
Device-1: hid-0018:04F3:402B.0001-battery model: ELAN2513:00 04F3:402B
serial: N/A charge: N/A status: N/A
CPU:
Info: model: AMD Ryzen 7 5825U with Radeon Graphics bits: 64 type: MT MCP
arch: Zen 3 gen: 4 built: 2021-22 process: TSMC n7 (7nm) family: 0x19 (25)
model-id: 0x50 (80) stepping: 0 microcode: 0xA50000C
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
L3: 16 MiB desc: 1x16 MiB
Speed (MHz): avg: 1422 high: 1619 min/max: 1600/4547 boost: enabled
scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1377 2: 1391
3: 1383 4: 1417 5: 1619 6: 1611 7: 1394 8: 1406 9: 1401 10: 1465 11: 1380
12: 1377 13: 1385 14: 1384 15: 1403 16: 1365 bogomips: 63876
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: always-on, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Barcelo vendor: Hewlett-Packard driver: amdgpu v: kernel
arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm) built: 2020-22 pcie:
gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s ports:
active: eDP-1 empty: DP-1,DP-2,HDMI-A-1 bus-ID: 04:00.0
chip-ID: 1002:15e7 class-ID: 0300
Device-2: Chicony HP True Vision 5MP Camera type: USB driver: uvcvideo
bus-ID: 1-4:4 chip-ID: 04f2:b767 class-ID: fe01 serial: <filter>
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 mapped: eDP model: BOE Display 0x08a8 built: 2019
res: 1920x1080 hz: 60 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
diag: 395mm (15.5") ratio: 16:9 modes: max: 1920x1080 min: 640x480
OpenGL: renderer: AMD RENOIR (LLVM 14.0.6 DRM 3.46 5.18.15-zen1-1-zen)
v: 4.6 Mesa 22.1.4 direct render: Yes
Audio:
Device-1: AMD Renoir Radeon High Definition Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
link-max: gen: 4 speed: 16 GT/s bus-ID: 04:00.1 chip-ID: 1002:1637
class-ID: 0403
Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Hewlett-Packard
driver: snd_rn_pci_acp3x v: kernel
alternate: snd_pci_acp3x,snd_pci_acp5x,snd_pci_acp6x,snd_acp_pci,snd_sof_amd_renoir
pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s
bus-ID: 04:00.5 chip-ID: 1022:15e2 class-ID: 0480
Device-3: AMD Family 17h/19h HD Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
link-max: gen: 4 speed: 16 GT/s bus-ID: 04:00.6 chip-ID: 1022:15e3
class-ID: 0403
Sound Server-1: ALSA v: k5.18.15-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.56 running: yes
Network:
Device-1: MEDIATEK MT7922 802.11ax PCI Express Wireless Network Adapter
vendor: Foxconn driver: mt7921e v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 link-max: gen: 2 speed: 5 GT/s bus-ID: 01:00.0
chip-ID: 14c3:0616 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Bluetooth:
Device-1: Foxconn / Hon Hai Wireless_Device type: USB driver: btusb v: 0.8
bus-ID: 1-3:3 chip-ID: 0489:e0e0 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: N/A
Drives:
Local Storage: total: 476.94 GiB used: 9.21 GiB (1.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
model: MZVLQ512HBLU-00BH1 size: 476.94 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: HPS1NFAV temp: 25.9 C scheme: GPT
Partition:
ID-1: / raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 9.21 GiB
(1.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 608 KiB
(0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 9.21
GiB (1.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 9.21
GiB (1.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 9.21
GiB (1.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 11.03 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 48.1 C mobo: N/A gpu: amdgpu temp: 40.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 341 Uptime: 31m wakeups: 1182 Memory: 11.03 GiB used: 2.63 GiB
(23.9%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.1.0 Packages: pacman: 1207 lib: 305 Shell: fish v: 3.5.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.20
Garuda (2.6.5-1):
System install date:     2022-07-31
Last full system update: 2022-07-31
Is partially upgraded:   Yes
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:

Such as?

Which ones?

In what way?

i don't have the link anymore so its all gonna be from memory but they said something like i needed a different driver then what i had? and the instructions were supposed to be to download it but there was an options command that just gave a command-not-found error when i tried it.
the forum had someone else who had a similar issue and with the same laptop as me
@jonathon

i've tried speaker-test -c2 and that doesn't play any sound either.
aplay -l gives
**** List of PLAYBACK Hardware Devices ****
card 0: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Generic [HD-Audio Generic], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: Generic_1 [HD-Audio Generic], device 0: ALC245 Analog [ALC245 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
and i think the issue has to do with the fact that the sound cards seem to be hdmi for some reason

It looks like there are several possible drivers for this audio chipset.

You can unload and load them in turn to see if one of the others works, e.g.

sudo modprobe -r snd_rn_pci_acp3x
sudo modprobe snd_pci_acp3x

and repeat for the others. If one works then it can be made permanent later on.

1 Like

after sudo modprobe -r snd_rn_pci_acp3x
it raises the error
modprobe: ERROR: could not remove 'snd_rn_pci_acp3x': Device or resource busy

any ideas?

Another thing you could do is to try checking in the Arch wiki.
I haven't found there (nor in our forum) your exact model, anyway, you could give a look at the list here, with an eye where the Audio column has an *:
https://wiki.archlinux.org/title/Laptop/HP
E.g., there is a dedicated page for a similar (?) model, with audio problems and suggestions:
https://wiki.archlinux.org/title/HP_Spectre_x360_-_13-ap0xxxx#Audio
Or, for ENVY 13-ad140ng, the note says hdajackretask should be used to enable the top speaker 0x14 override to Internal Speaker, 0x17 override to Internal Speaker Back
...

Edit: I just noticed this is a brand new model, isn't it? So kernel support could be coming a bit late.
See e.g. this new (still unconfirmed) kernel bug:
https://bugzilla.kernel.org/show_bug.cgi?id=216311
And maybe keep an eye every now and then here:

3 Likes

i've been going through the arch wiki and several forums with no luck so far, but i'll keep trying thanks!

Could also be worth trying linux-mainline to see if driver support has improved in the latest kernel release.

3 Likes