No audio input or output after sleep or suspend

Hi,
after i wake my laptop from suspend or sleep state my audio drivers aren't working. I have to manually reset my audio driver every time.
I use this command

systemctl --user restart pipewire pipewire-pulse
systemctl --user daemon-reload

I am looking for more of a permanent solution and automatic one.

My system info

pipewire: 0.3.40
Gnome version: 41.2
kernal version: 5.15.7.hardened1-1
cpu: ryzen 4600h
gpu: nvidia 1660ti mobile

PS. I posted it here because i am not sure if it's related to gnome or garuda.

inxi -Faz

System:    Kernel: 5.15.6-zen2-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=2cb817f1-62dd-48cc-b94b-84c237d9c509 rw
           [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
           systemd.unified_cgroup_hierarchy=1 resume=UUID=a78efde3-a998-44ee-bd36-e7f1a08d17a2 loglevel=3
           Desktop: GNOME 41.1 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 41.0 Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: HP product: OMEN Laptop 15-en0xxx v: N/A serial: <superuser required> Chassis: type: 10
           serial: <superuser required>
           Mobo: HP model: 8786 v: 22.58 serial: <superuser required> UEFI: AMI v: F.13 date: 03/04/2021
Battery:   ID-1: BAT0 charge: 59.1 Wh (92.9%) condition: 63.6/63.6 Wh (100.0%) volts: 12.4 min: 11.6
           model: Hewlett-Packard Primary type: Li-ion serial: N/A status: Discharging cycles: 572
CPU:       Info: 6-Core model: AMD Ryzen 5 4600H with Radeon Graphics bits: 64 type: MT MCP arch: Zen 2 family: 17 (23)
           model-id: 60 (96) stepping: 1 microcode: 8600106 cache: L1: 384 KiB L2: 3 MiB L3: 8 MiB
           flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 71868
           Speed: 1521 MHz min/max: 1400/3000 MHz boost: enabled Core speeds (MHz): 1: 1484 2: 1519 3: 1595 4: 1805 5: 2178
           6: 2244 7: 2041 8: 2074 9: 1965 10: 1383 11: 1832 12: 2270
           Vulnerabilities: Type: itlb_multihit status: Not affected
           Type: l1tf status: Not affected
           Type: mds status: Not affected
           Type: meltdown status: Not affected
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
           Type: srbds status: Not affected
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: NVIDIA TU116M [GeForce GTX 1660 Ti Mobile] vendor: Hewlett-Packard driver: nvidia v: 495.44
           alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:2191 class-ID: 0300
           Device-2: Advanced Micro Devices [AMD/ATI] Renoir vendor: Hewlett-Packard driver: amdgpu v: kernel bus-ID: 06:00.0
           chip-ID: 1002:1636 class-ID: 0300
           Device-3: Luxvisions Innotech Limited HP Wide Vision HD Camera type: USB driver: uvcvideo bus-ID: 3-3:3
           chip-ID: 30c9:000e class-ID: 0e02
           Display: x11 server: X.Org 1.21.1.1 compositor: gnome-shell driver: loaded: modesetting,nvidia display-ID: :1
           screens: 1
           Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x286mm (40.0x11.3") s-diag: 1055mm (41.6")
           Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6") diag: 395mm (15.5")
           Monitor-2: HDMI-1-0 res: 1920x1080 hz: 144 dpi: 93 size: 527x296mm (20.7x11.7") diag: 604mm (23.8")
           Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:     Device-1: NVIDIA TU116 High Definition Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel
           bus-ID: 01:00.1 chip-ID: 10de:1aeb class-ID: 0403
           Device-2: Advanced Micro Devices [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Hewlett-Packard
           driver: snd_rn_pci_acp3x v: kernel alternate: snd_pci_acp3x,snd_pci_acp5x bus-ID: 06:00.5 chip-ID: 1022:15e2
           class-ID: 0480
           Device-3: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel
           bus-ID: 06:00.6 chip-ID: 1022:15e3 class-ID: 0403
           Sound Server-1: ALSA v: k5.15.6-zen2-1-zen running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: no
           Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard driver: r8169 v: kernel
           port: e000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
           IF: eno1 state: down mac: <filter>
           Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 03:00.0 chip-ID: 8086:2723 class-ID: 0280
           IF: wlo1 state: up mac: <filter>
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 3-4:5 chip-ID: 8087:0029 class-ID: e001
           Report: bt-adapter ID: hci0 rfk-id: 0 state: down bt-service: enabled,running rfk-block: hardware: no software: yes
           address: <filter>
Drives:    Local Storage: total: 476.94 GiB used: 337.82 GiB (70.8%)
           SMART Message: Required tool smartctl not installed. Check --recommends
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: MZVLB512HBJQ-000H1 size: 476.94 GiB block-size:
           physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: HPS0NEXF temp: 38.9 C
           scheme: GPT
Partition: ID-1: / raw-size: 30 GiB size: 30 GiB (100.00%) used: 16.77 GiB (55.9%) fs: btrfs dev: /dev/nvme0n1p5
           maj-min: 259:5
           ID-2: /boot/efi raw-size: 501 MiB size: 500 MiB (99.80%) used: 576 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p7
           maj-min: 259:7
           ID-3: /home raw-size: 80.95 GiB size: 80.95 GiB (100.00%) used: 32.22 GiB (39.8%) fs: btrfs dev: /dev/nvme0n1p8
           maj-min: 259:8
           ID-4: /var/log raw-size: 30 GiB size: 30 GiB (100.00%) used: 16.77 GiB (55.9%) fs: btrfs dev: /dev/nvme0n1p5
           maj-min: 259:5
           ID-5: /var/tmp raw-size: 30 GiB size: 30 GiB (100.00%) used: 16.77 GiB (55.9%) fs: btrfs dev: /dev/nvme0n1p5
           maj-min: 259:5
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
           ID-1: swap-1 type: partition size: 4 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme0n1p6 maj-min: 259:6
           ID-2: swap-2 type: zram size: 15.06 GiB used: 1.81 GiB (12.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 47.0 C mobo: N/A gpu: amdgpu temp: 45.0 C
           Fan Speeds (RPM): N/A
Info:      Processes: 417 Uptime: 11h 52m wakeups: 1 Memory: 15.06 GiB used: 10.35 GiB (68.7%) Init: systemd v: 249
           tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1227 lib: 346 Shell: fish v: 3.3.1
           default: Bash v: 5.1.12 running-in: gnome-terminal inxi: 3.3.09

Hi there, welcome.
Please add to your post your inxi -Faz, since this can include other useful information.

3 Likes

I would swear that I saw a post just like this within the past few days. Have you Searched the forum? Also, please do as filo asked. It's there for a purpose.

4 Likes

This is kinda common, or it used to be. Normally if it happens you have to write a little trigger script upon waking to do what you were doing manually. However my knowledge of this was always debian/Ubuntu based and most those things don't even work on debian/Ubuntu anymore. (Dey always changin' crap!)

Do some hunting on running scripts on shutdown/boot/sleep/wake and just make it run the systemctl commands when appropriate. It's not optimal but it happens when some hardware just doesn't respond in time or in sequence.

1 Like

@ nPHYN1T3 i have already written a bash script i will just run it manually after i realized my audio is gone. I wanted to know if there is anything i have to change in settings to not do that.

I searched there is something called no audio over HDMI. but may be i am wrong i will search the forums once again

There is no setting perse to change the timing at which things "wake" to fix it. It's a rather low level thing and once upon a time it was often a misunderstood Intel USB spec thing heh. Just get the system to run the script on wake and you can forget about it. heh.

4 Likes

This isn't a no audio issue, it's an "on wake" power management issue :slight_smile:

2 Likes

I haven't thought about that. Gnome has two options for me balance and power saver mode. I am going to try on both mode and update this or else i simply have to run the script on wake up.

Those won't change the sleep/wake behavior/timing. Those just schedule things like autobrightness and CPU governors to save or use battery.

Check your Bios for a setting.

@c00ter is correct, this is often a bios issue. Try setting different sleep states in your bios. Also be sure your bios is up to date.

The other most common thing in these types of cases is the kernel itselself. Be sure to test a bunch of different kernels to see if you can find one that fixes this issue. I would suggest testing at least linux-lts, linux-mainline, and linux.

These would be the best solutions (if you can find an alteration that works) rather than scripting an audio restart after a suspend/resume.

2 Likes

I'd be surprised if the BIOS allows any settings to be touched. HP, Laptop...HP...

Even if the sleep states can be changed they should all work in the end which is why I say in time if the parts are common enough driver and kernel updates should eventually tweak the bit that's causing it to hit the snooze button while the rest of the machine already has its pants on. :wink:

I can't speak to whether HP laptops include alterable sleep states (as I do not own his or any other HP laptop). What I can say is changing sleep states, updating the bios, or switching kernels is often the solution for these types of post suspend issues.

I am just giving the standard fixes for this type of issue which are preferential to scripting a workaround. If any of them will work can't be predicted. The user needs to test my suggestions to see if any of them will correct his problem.

1 Like

Yeah I get it's standard fare but most HP and Dell are very locked down. There are some exceptions in the corp or developer models but most times you can select boot devices, enable/disable quiet boot and change the datetime and that's about it. Even the Desktops are pretty locked down but the mobile are normally more so because if the user can change the big bits their claims on battery and performance bla bla. (excuses to keep you from "owning" what is yours)

i dont have that problem with my ryzen 5 4500 u . i think the different is that i installed a package that disables c6 sleep states. i searched ryzen in pamac and found this, before i installed a few stability packages i was experiencing random bugs, i eventually compiled the zen 2 kernel on my machine and ive had great results since.

I get this is marked as solved, but the actual location of the script wasn't mentioned.
It should work by putting the script in:

/usr/lib/systemd/system-sleep/

The script will be run when putting the system to sleep and when waking it.
I've had to do it for fancontrol to work on wake.
E2A my script for newbs-semi newbs to work from:

#!/bin/bash
systemctl restart fancontrol.service

I named as fanControl.sh
Remember to set it as executable

2 Likes

Thanks for this!

I happened to encounter the same issue this week (also on an HP machine). After waking up my laptop everything seemed to work fine, until a colleague tried to video call me, and both my mic and head phones had stopped functioning.

Sadly this stuff is common. I had the same issue on my workstation where my NIC would never wake after suspend/sleep under Ubuntu.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.