No Audio In Minecraft Since Recent Update

Kernel: 6.4.12-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=4c53965d-52cb-489d-aab3-ae07a0ff2075 rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
Desktop: KDE Plasma v: 5.27.7 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop System: Micro-Star product: MS-7B51 v: 1.0
serial: <superuser required>
Mobo: Micro-Star model: MPG Z390 GAMING PLUS (MS-7B51) v: 1.0
serial: <superuser required> UEFI: American Megatrends v: 1.80
date: 12/26/2019
Device-1: hidpp_battery_0 model: Logitech M585/M590 Multi-Device Mouse
serial: <filter> charge: 55% (should be ignored) rechargeable: yes
status: discharging
Info: model: Intel Core i5-9600KF bits: 64 type: MCP arch: Coffee Lake
gen: core 9 level: v3 note: check built: 2018 process: Intel 14nm family: 6
model-id: 0x9E (158) stepping: 0xD (13) microcode: 0xFA
Topology: cpus: 1x cores: 6 smt: <unsupported> cache: L1: 384 KiB
desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB L3: 9 MiB
desc: 1x9 MiB
Speed (MHz): avg: 4400 min/max: 800/4700 scaling: driver: intel_pstate
governor: performance cores: 1: 4400 2: 4400 3: 4400 4: 4400 5: 4400 6: 4400
bogomips: 44398
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: NVIDIA TU116 [GeForce GTX 1660 Ti] vendor: Micro-Star MSI
driver: nvidia v: 535.104.05 alternate: nouveau,nvidia_drm non-free: 535.xx+
status: current (as of 2023-08) arch: Turing code: TUxxx
process: TSMC 12nm FF built: 2018-22 pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.0 chip-ID: 10de:2182 class-ID: 0300
Device-2: Logitech Webcam C270 driver: snd-usb-audio,uvcvideo type: USB
rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-2:3 chip-ID: 046d:0825
class-ID: 0102 serial: <filter>
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.2.0
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia
alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 3440x1440 s-dpi: 110 s-size: 794x333mm (31.26x13.11")
s-diag: 861mm (33.9")
Monitor-1: HDMI-0 pos: primary res: 3440x1440 dpi: 110
size: 797x333mm (31.38x13.11") diag: 864mm (34.01") modes: N/A
Monitor-2: None-1-1 size-res: N/A modes: N/A
API: OpenGL v: 4.6.0 NVIDIA 535.104.05 renderer: NVIDIA GeForce GTX 1660
Ti/PCIe/SSE2 direct-render: Yes
Device-1: Intel Cannon Lake PCH cAVS vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl
bus-ID: 00:1f.3 chip-ID: 8086:a348 class-ID: 0403
Device-2: NVIDIA TU116 High Definition Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:1aeb class-ID: 0403
Device-3: C-Media Blue Snowball driver: hid-generic,snd-usb-audio,usbhid
type: USB rev: 1.1 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-1:2
chip-ID: 0d8c:0005 class-ID: 0300 serial: <filter>
Device-4: Logitech Webcam C270 driver: snd-usb-audio,uvcvideo type: USB
rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-2:3 chip-ID: 046d:0825
class-ID: 0102 serial: <filter>
API: ALSA v: k6.4.12-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.78 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Ethernet I219-V vendor: Micro-Star MSI driver: e1000e
v: kernel port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15bc class-ID: 0200
IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Local Storage: total: 3.64 TiB used: 3.2 TiB (87.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:2 vendor: Crucial model: CT1000P2SSD8
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: P2CR033 temp: 35.9 C
scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Crucial model: CT1000P1SSD8
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: P3CR013 temp: 32.9 C
scheme: GPT
ID-3: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD10EZRX-00L4HB0 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 5400 serial: <filter>
fw-rev: 1A01 scheme: MBR
ID-4: /dev/sdb maj-min: 8:16 vendor: Toshiba model: HDWD110
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: HDD rpm: 7200 serial: <filter> fw-rev: A8J0 scheme: MBR
ID-1: / raw-size: 46.57 GiB size: 46.57 GiB (100.00%)
used: 42.64 GiB (91.6%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:6
ID-2: /boot/efi raw-size: 619 MiB size: 617.8 MiB (99.80%)
used: 222.3 MiB (36.0%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:3
ID-3: /home raw-size: 46.57 GiB size: 46.57 GiB (100.00%)
used: 42.64 GiB (91.6%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:6
ID-4: /var/log raw-size: 46.57 GiB size: 46.57 GiB (100.00%)
used: 42.64 GiB (91.6%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:6
ID-5: /var/tmp raw-size: 46.57 GiB size: 46.57 GiB (100.00%)
used: 42.64 GiB (91.6%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:6
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 31.28 GiB used: 512 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 6 dev: /dev/zram0
ID-2: swap-2 type: partition size: 3.91 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sda3 maj-min: 8:3
System Temperatures: cpu: 38.0 C pch: 43.0 C mobo: 28.0 C gpu: nvidia
temp: 35 C
Fan Speeds (rpm): fan-1: 0 fan-2: 1033 fan-3: 1015 fan-4: 751 fan-5: 773
fan-6: 810 fan-7: 0 gpu: nvidia fan: 47%
Processes: 319 Uptime: 0m wakeups: 2 Memory: total: 32 GiB
available: 31.28 GiB used: 7.81 GiB (25.0%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 15.0.7
Packages: pm: pacman pkgs: 2226 libs: 558 tools: octopi,paru Shell: fish
v: 3.6.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.29
Garuda (2.6.16-1):
System install date:     2023-08-07
Last full system update: 2023-08-26
Is partially upgraded:   No
Relevant software:       snapper NetworkManager mkinitcpio nvidia-dkms
Windows dual boot:       No/Undetected
Failed units:

Hi All,

Following a "garuda-update" today, I no longer have any audio within Minecraft. Looking at the latest Minecraft log, this appears to be the relevant section:

[ALSOFT] (EE) Failed to connect output port "alsoft:channel_1" to "Built-in Audio Analog Stereo:playback_FL"

[ALSOFT] (EE) Failed to connect output port "alsoft:channel_2" to "Built-in Audio Analog Stereo:playback_FR"

[10:46:48] [Render thread/INFO]: OpenAL initialized on device JACK Default

[10:46:48] [Render thread/INFO]: Sound engine started

My Google-fu must be failing me today, as I'm unable to find anything useful relating to that message.

Rolling back to the snapshot from before the update, and everything works as expected.

Here are the packages updated today:

[2023-08-26T00:50:55+0100] [ALPM] upgraded alsa-card-profiles (1:0.3.77-2 -> 1:0.3.78-1)
[2023-08-26T00:50:55+0100] [ALPM] upgraded json-c (0.16-1 -> 0.17-1)
[2023-08-26T00:50:55+0100] [ALPM] upgraded ananicy-cpp (1.1.0-2 -> 1.1.1-1)
[2023-08-26T00:50:55+0100] [ALPM] upgraded gtk-update-icon-cache (1:4.12.0-2 -> 1:4.12.1-1)
[2023-08-26T00:50:55+0100] [ALPM] upgraded libinput (1.23.0-1 -> 1.24.0-1)
[2023-08-26T00:50:55+0100] [ALPM] upgraded xf86-input-libinput (1.3.0-1 -> 1.4.0-1)
[2023-08-26T00:50:56+0100] [ALPM] upgraded brave-bin (1:1.57.47-1 -> 1:1.57.53-1)
[2023-08-26T00:50:56+0100] [ALPM] upgraded fastfetch (2.0.3-1 -> 2.0.4-1)
[2023-08-26T00:50:56+0100] [ALPM] upgraded libpipewire (1:0.3.77-2 -> 1:0.3.78-1)
[2023-08-26T00:50:56+0100] [ALPM] upgraded pipewire (1:0.3.77-2 -> 1:0.3.78-1)
[2023-08-26T00:50:56+0100] [ALPM] upgraded gst-plugin-pipewire (1:0.3.77-2 -> 1:0.3.78-1)
[2023-08-26T00:50:56+0100] [ALPM] upgraded gtk4 (1:4.12.0-2 -> 1:4.12.1-1)
[2023-08-26T00:50:56+0100] [ALPM] upgraded lib32-libpipewire (1:0.3.77-2 -> 1:0.3.78-1)
[2023-08-26T00:50:56+0100] [ALPM] upgraded lib32-pipewire (1:0.3.77-2 -> 1:0.3.78-1)
[2023-08-26T00:50:56+0100] [ALPM] upgraded pipewire-audio (1:0.3.77-2 -> 1:0.3.78-1)
[2023-08-26T00:50:56+0100] [ALPM] upgraded pipewire-jack (1:0.3.77-2 -> 1:0.3.78-1)
[2023-08-26T00:50:56+0100] [ALPM] upgraded lib32-pipewire-jack (1:0.3.77-2 -> 1:0.3.78-1)
[2023-08-26T00:50:56+0100] [ALPM] upgraded libsynctex (2023.66984-15 -> 2023.66984-16)
[2023-08-26T00:50:57+0100] [ALPM] upgraded linux-zen (6.4.11.zen2-1 -> 6.4.12.zen1-1)
[2023-08-26T00:50:59+0100] [ALPM] upgraded linux-zen-headers (6.4.11.zen2-1 -> 6.4.12.zen1-1)
[2023-08-26T00:50:59+0100] [ALPM] upgraded pcsx2-git (1.7.4940.r0.gb8cfd83d3-1 -> 1.7.4943.r0.g5f348a8ea-1)
[2023-08-26T00:50:59+0100] [ALPM] upgraded pipewire-alsa (1:0.3.77-2 -> 1:0.3.78-1)
[2023-08-26T00:50:59+0100] [ALPM] upgraded pipewire-pulse (1:0.3.77-2 -> 1:0.3.78-1)
[2023-08-26T00:50:59+0100] [ALPM] upgraded pipewire-v4l2 (1:0.3.77-2 -> 1:0.3.78-1)
[2023-08-26T00:51:00+0100] [ALPM] upgraded pipewire-x11-bell (1:0.3.77-2 -> 1:0.3.78-1)
[2023-08-26T00:51:00+0100] [ALPM] upgraded pipewire-zeroconf (1:0.3.77-2 -> 1:0.3.78-1)
[2023-08-26T00:51:00+0100] [ALPM] upgraded python-sphinxcontrib-serializinghtml (1.1.8-1 -> 1.1.9-1)
[2023-08-26T00:51:00+0100] [ALPM] upgraded python-sphinx (7.2.2-1 -> 7.2.3-1)
[2023-08-26T00:51:00+0100] [ALPM] upgraded texlive-bin (2023.66984-15 -> 2023.66984-16)

There are a few "ALSA" and "Pipewire" related packages there - could one of them be at fault?

Other applications (VLC, Steam games) work correctly

Which version of Minecraft?
Which launcher?
Modded? If so, which pack?
What version of Java?
Does it work with a different audio output device?

Anarcraft, thanks for your questions.

  1. Any Minecraft version (I tried 1.19 and 1.20)
  2. I use Prism Launcher
  3. Modded with my own pack, but by using different Minecraft versions (and thus different Fabric and mod versions) I don't believe the mods are causing the problem - this is confirmed by rolling the Garuda updates back (keeping Minecraft the same) brings the sound back.
  4. Java: OpenJDK 64-Bit Server VM (build, mixed mode)
  5. Under "Configure Audio Devices" I have two output devices - Headphones (that I use) and HDMI - I don't have any speakers on this monitor, so can't use HDMI audio. There are mulitple Profiles available (Analogue Duplex, Analogue Output, etc), but changing these (and restarting the Minecraft launcher between each change) doesn't affect the result

I tried using the vanilla launcher and a freshly-installed vanilla game - the same result :frowning:

1 Like

I have tried using the LTS kernel (as recommended on another thread about audio not working) - no change.

I have also tried changing the Audio Support options in Garuda Assistant to each option, all without change.

My current set-up, is using the working snapshot, but then upgrading packages individually, testing each time. I am now down to one of the following packages causing the problem, because if I allow a full upgrade from here, I lose the audio in Minecraft:

:: Starting full system upgrade...
warning: python-inputs: local (0.5.0-1.6) is newer than chaotic-aur (0.5-3)
resolving dependencies...
looking for conflicting packages...

Package (9)                   Old Version  New Version  Net Change

extra/alsa-card-profiles      1:0.3.77-2   1:0.3.78-1     0.00 MiB
multilib/lib32-libpipewire    1:0.3.77-2   1:0.3.78-1     0.00 MiB
multilib/lib32-pipewire       1:0.3.77-2   1:0.3.78-1     0.00 MiB
multilib/lib32-pipewire-jack  1:0.3.77-2   1:0.3.78-1     0.00 MiB
extra/libpipewire             1:0.3.77-2   1:0.3.78-1     0.00 MiB
extra/pipewire                1:0.3.77-2   1:0.3.78-1     0.00 MiB
extra/pipewire-audio          1:0.3.77-2   1:0.3.78-1     0.00 MiB
extra/pipewire-jack           1:0.3.77-2   1:0.3.78-1     0.00 MiB
extra/pipewire-pulse          1:0.3.77-2   1:0.3.78-1     0.00 MiB

All of these packages seem to be Pipewire related, so I want to upgrade them all at the same time (unless anyone can see a package that would be "safe" to upgrade?)

I thought it might have been an issue with the newest pipewire update not recognising java, but I tried Project Zomboid and it works fine, so this is definitely something between minecraft and this pipewire update. I tried with both vanilla launcher and FTB Desktop App, same result, no sound.

I reverted the update with snapper to get the audio back. I wonder about checking what changed in the alsa-card-profiles files.

I've found a solution, from the Prism Launcher Discord server:

Create the file /etc/openal/alsoft.conf (I also had to create the openal folder). Insert the following line into the newly-created file:


Apply the system updates (if not done so already), then run Minecraft as normal. Sound should now be restored! :slight_smile:


This worked for me as well. Good find.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.