Nix subsystem help

Hello everyone :),

Hey I am trying to use the garuda nix subsystem, but the instillation is failing. It says complete, but it never installed and I can not see the option to boot into it. I am following this guide. I tried to update it to fix it and got the following errors.

… while calling the 'head' builtin

at /tmp/tmp.0JfOgU16wY/nix/store/4fgs7yzsy2dqnjw8j42qlp9i1vgarzy0-source/lib/attrsets.nix:936:11:

935|         || pred here (elemAt values 1) (head values) then
936|           head values
|           ^
937|         else

… while evaluating the attribute 'value'

at /tmp/tmp.0JfOgU16wY/nix/store/4fgs7yzsy2dqnjw8j42qlp9i1vgarzy0-source/lib/modules.nix:809:9:

808|     in warnDeprecation opt //
809|       { value = builtins.addErrorContext "while evaluating the option `${showOption loc}':" value;
|         ^
810|         inherit (res.defsFinal') highestPrio;

(stack trace truncated; use '--show-trace' to show the full trace)

error: A definition for option `networking.hostName' is not of type `string matching the pattern ^$|^[[:alnum:]]([[:alnum:]_-]{0,61}[[:alnum:]])?$'. Definition values:
- In `/tmp/tmp.0JfOgU16wY/nix/store/kvczim5v3xnk9li1pbfvwal2sh66793s-source/internal/modules/base/managed': "neon-"
Kernel: 6.6.6-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=16418167-4e2f-45d3-ad11-0999ce42a0f8 rw rootflags=subvol=@
quiet rd.luks.uuid=412f8dfb-b329-4435-af90-33c36e8f7552
resume=/dev/mapper/luks-acde1cd1-513c-4b66-a1c1-ef7d203fb179 loglevel=3
Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.11 wm: kwin_wayland vt: 1
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Detachable System: ASUSTeK product: ROG Flow Z13 GZ301ZC_GZ301ZC
v: 1.0 serial: <superuser required>
Mobo: ASUSTeK model: GZ301ZC v: 1.0 serial: <superuser required>
UEFI: American Megatrends LLC. v: GZ301ZC.317 date: 05/18/2023
ID-1: BAT0 charge: 48.2 Wh (100.0%) condition: 48.2/56.0 Wh (86.0%)
volts: 16.0 min: 16.0 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A
status: not charging cycles: 154
Device-1: hid-0018:04F3:2ED7.000A-battery model: ELAN9008:00 04F3:2ED7
serial: N/A charge: N/A status: N/A
Info: model: 12th Gen Intel Core i7-12700H bits: 64 type: MST AMCP
arch: Alder Lake gen: core 12 level: v3 note: check built: 2021+
process: Intel 7 (10nm ESF) family: 6 model-id: 0x9A (154) stepping: 3
microcode: 0x430
Topology: cpus: 1x cores: 14 mt: 6 tpc: 2 st: 8 threads: 20 smt: enabled
cache: L1: 1.2 MiB desc: d-8x32 KiB, 6x48 KiB; i-6x32 KiB, 8x64 KiB
L2: 11.5 MiB desc: 6x1.2 MiB, 2x2 MiB L3: 24 MiB desc: 1x24 MiB
Speed (MHz): avg: 498 high: 998 min/max: 400/4600:4700:3500 scaling:
driver: intel_pstate governor: powersave cores: 1: 400 2: 400 3: 400 4: 400
5: 670 6: 400 7: 400 8: 898 9: 664 10: 400 11: 604 12: 400 13: 400 14: 998
15: 400 16: 400 17: 530 18: 400 19: 400 20: 400 bogomips: 107520
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel Alder Lake-P GT2 [Iris Xe Graphics] vendor: ASUSTeK
driver: i915 v: kernel arch: Gen-12.2 process: Intel 10nm built: 2021-22+
ports: active: eDP-2 empty: DP-2,DP-3 bus-ID: 0000:00:02.0
chip-ID: 8086:46a6 class-ID: 0300
Device-2: NVIDIA GA107M [GeForce RTX 3050 Mobile] vendor: ASUSTeK
driver: nvidia v: 545.29.06 alternate: nouveau,nvidia_drm non-free: 545.xx+
status: current (as of 2023-10; EOL~2026-12-xx) arch: Ampere code: GAxxx
process: TSMC n7 (7nm) built: 2020-2023 ports: active: none
empty: DP-1,eDP-1 bus-ID: 0000:01:00.0 chip-ID: 10de:25a2 class-ID: 0300
Device-3: USB C Video Adaptor driver: N/A type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-1.4.2:34 chip-ID: 25a4:9311
class-ID: 1100 serial: <filter>
Device-4: Microdia USB 2.0 Camera driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-3:5 chip-ID: 0c45:636d
class-ID: 0e02 serial: <filter>
Device-5: IMC Networks USB2.0 HD UVC WebCam driver: uvcvideo type: USB
rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-8:11
chip-ID: 13d3:5492 class-ID: fe01 serial: <filter>
Display: wayland server: v: with: Xwayland v: 23.2.2
compositor: kwin_wayland driver: X: loaded: modesetting,nvidia
unloaded: nouveau alternate: fbdev,intel,nv,vesa dri: iris
gpu: i915,nvidia display-ID: 0
Monitor-1: eDP-2 res: 1536x960 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: intel iris drv: nvidia platforms: device: 0
drv: nvidia device: 1 drv: iris device: 3 drv: swrast gbm: drv: nvidia
surfaceless: drv: nvidia wayland: drv: iris x11: drv: iris
inactive: device-2
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 23.2.1-arch1.2
glx-v: 1.4 direct-render: yes renderer: Mesa Intel Graphics (ADL GT2)
device-ID: 8086:46a6 memory: 14.95 GiB unified: yes display-ID: :1.0
API: Vulkan v: 1.3.269 layers: 4 device: 0 type: integrated-gpu name: Intel
Graphics (ADL GT2) driver: mesa intel v: 23.2.1-arch1.2
device-ID: 8086:46a6 surfaces: xcb,xlib,wayland device: 1
type: discrete-gpu name: NVIDIA GeForce RTX 3050 Laptop GPU driver: nvidia
v: 545.29.06 device-ID: 10de:25a2 surfaces: xcb,xlib,wayland device: 2
type: cpu name: llvmpipe (LLVM 16.0.6 256 bits) driver: mesa llvmpipe
v: 23.2.1-arch1.2 (LLVM 16.0.6) device-ID: 10005:0000
surfaces: xcb,xlib,wayland
Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_tgl
bus-ID: 0000:00:1f.3 chip-ID: 8086:51c8 class-ID: 0403
Device-2: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel
bus-ID: 0000:01:00.1 chip-ID: 10de:2291 class-ID: 0403
API: ALSA v: k6.6.6-zen1-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 0000:00:14.3 chip-ID: 8086:51f0 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-2: ASIX AX88179 Gigabit Ethernet driver: cdc_ncm type: USB rev: 3.2
speed: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 bus-ID: 4-1.4:39 chip-ID: 0b95:1790
class-ID: 0a00 serial: <filter>
IF: enp0s20f0u1u4c2 state: down mac: <filter>
Device-1: Intel AX211 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-10:14 chip-ID: 8087:0033
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 2 state: down bt-service: enabled,running
rfk-block: hardware: no software: no address: <filter> bt-v: 5.3 lmp-v: 12
status: discoverable: no pairing: no
Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:467f rev: class-ID: 0104
Local Storage: total: 491.38 GiB used: 12.23 GiB (2.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: WD PC
SN735 SDBPTHH-512G-1002 size: 476.94 GiB block-size: physical: 512 B
logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 70626000 temp: 27.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 model: USB DISK 3.0 size: 14.44 GiB
block-size: physical: 512 B logical: 512 B type: USB rev: 2.1 spd: 480 Mb/s
lanes: 1 mode: 2.0 tech: N/A serial: <filter> fw-rev: PMAP scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
ID-1: / raw-size: 459.79 GiB size: 459.79 GiB (100.00%)
used: 12.22 GiB (2.7%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-412f8dfb-b329-4435-af90-33c36e8f7552
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 720 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 459.79 GiB size: 459.79 GiB (100.00%)
used: 12.22 GiB (2.7%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-412f8dfb-b329-4435-af90-33c36e8f7552
ID-4: /var/log raw-size: 459.79 GiB size: 459.79 GiB (100.00%)
used: 12.22 GiB (2.7%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-412f8dfb-b329-4435-af90-33c36e8f7552
ID-5: /var/tmp raw-size: 459.79 GiB size: 459.79 GiB (100.00%)
used: 12.22 GiB (2.7%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-412f8dfb-b329-4435-af90-33c36e8f7552
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: partition size: 16.85 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/dm-1 maj-min: 254:1
mapped: luks-acde1cd1-513c-4b66-a1c1-ef7d203fb179
ID-2: swap-2 type: zram size: 15.31 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 20 dev: /dev/zram0
Use of uninitialized value in pattern match (m//) at /usr/bin/inxi line 26495.
Use of uninitialized value in pattern match (m//) at /usr/bin/inxi line 26499.
Use of uninitialized value in pattern match (m//) at /usr/bin/inxi line 26506.
Use of uninitialized value in pattern match (m//) at /usr/bin/inxi line 26525.
Src: /sys System Temperatures: cpu: 49.0 C mobo: N/A
Fan Speeds (rpm): cpu: 0
Processes: 442 Uptime: 12h 53m wakeups: 1 Memory: total: 16 GiB note: est.
available: 15.31 GiB used: 5.51 GiB (36.0%) Init: systemd v: 255
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: nix-default pkgs: 0 pm: nix-sys pkgs: 0 pm: nix-usr pkgs: 0 pm: pacman
pkgs: 1463 libs: 394 tools: octopi,paru Shell: fish v: 3.6.4
running-in: konsole inxi: 3.3.31
Garuda (2.6.19-2):
System install date:     2023-12-13
Last full system update: 2023-12-13
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       No/Undetected
Failed units:
1 Like

Hi @Neongreensniper , so from what you shared , networking.hostName is causing the errors
→ edit/etc/nixos/configuration.nix , look for the networking.hostName option and ensure that its value is a string that follows the pattern ^[[:alnum:]]([[:alnum:]_-]{0,61}[[:alnum:]])?$ , it looks like that the value is set to “neon-”, which can be the issue, so change it to something you like , like “straight123” or smth like that .

And run this just in case

sudo pacman -Syu nix
sudo garuda-update

and please share nixos-rebuild switch --show-trace


Because it did not install correctly there is no nix install to motify the /etc/nixos/configuration.nix the only nix related thing is /etc/nix/nix.conf/ I tried adding the stated option anyway and it failed.

So the whole installation is corrupted , revert to a previous backup and install it again if there is no possible solution for now , that’s what i would do

1 Like

Ok thank you

1 Like

What’s your hostname on Garuda?

1 Like

Neon sir

What is the output of cat /etc/hostname; hostname

1 Like


Going and changing to just neon does not seem to update the installer

The reason you are having issues here is that you have a dash after your hostname. Edit the /etc/hostname file and delete the “-” at the end of your current hostname, edit your /etc/hosts file as well and make the same change and then give your system a reboot to make sure services such as network manager have picked up on the change.

Next, go into “BTRFS Assistant” on your standard Garuda installation and delete the volume @nix-subsystem. After this, you should be able to execute garuda-nix-subsystem install to restart the installation procedure from scratch.


Thank you for your help I made some modifications to what you said here is the final how to.

  1. Go into a snapshot from before the nix install otherwise BTRFS Assistant will say @nix-subsystem is busy
  2. Restore it
  3. Use BTRFS assistant and delete both @nix and @nix-subsystem
    4.Do sudo rm -rf "/etc/nix" "/nix" "/root/.nix-profile" "/root/.nix-defexpr" "/root/.nix-channels" "/root/.local/state/nix" "/root/.cache/nix" "/root/.nix-profile" "/root/.nix-defexpr" "/root/.nix-channels" "/root/.local/state/nix" "/root/.cache/nix" - Takin form nix wiki
  4. Check to make sure nix has no reminates left
    7.Sudo pacman -S garuda-nix-subsystem
  5. garuda-nix-subsytem install

Seems a little overkill. Simply unmounting or restarting should have fixed the @nix-subsystem is busy error. Deleting @nix is also quite unnecessary. Following the instructions I sent after a reboot (or after an unmount) (without running any garuda-nix-subsystem commands) should work perfectly.

1 Like

It wouldn’t let me unmount it thats why i went for the nuclear option.

I am going to change the solution mark to my message because I can not in good faith, as the developer of GNS, recommend restoring a snapshot and running some commands that don’t make much sense in this context (like removing nix with rm -rf commands after restoring a snapshot). Again, I suggest unmounting or simply rebooting so the @nix-subsystem subvolume is available to be deleted, deleting it and then running the install command again. I hope that’s okay with you :blush:


Yep totally fine :+1:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.