New Printer setup

New install of the latest dragonized kde version. No CUPS management software is installed, and Pamac won't install anything further than the barebones client libraries. Ideas?

1 Like




1 Like

I recently had the same issue with Garuda "Lite". No printer support. I fixed it by installing CUPS from terminal using pacman, then enabling CUPS service, then starting CUPS service. This sounds like a lot of work but it really only took a couple of minutes. After that the CUPS web interface GUI worked fine and I installed both of my WiFi printer/scanners without incident. I can post the exact terminal commands I used if you want. Merry Christmas.

1 Like

Yes, please do post the command. I know how to do this via the shell in Debian with apt, but the Arch system is a whole new world for the moment...

sudo pacman -S printer-support

Hmmm. "Target not found"

From terminal:

sudo pacman -S cups
sudo systemctl enable cups
sudo systemctl start cups

After that, use the printers GUI to install your printer. If it doesn't work, open a web browser and navigate to the CUPS interface at Click on the "administration" tab and add your printer. If the CUPS interface offers you 2 or 3 instances of your printer, try each one in-turn until you find one that will let you print a test page. Once you get the printer working, you can use the normal printers GUI for administration. This sounds like a lot of bother but it only takes a few minutes and Garuda is absolutely worth it! Cheers.


I am lazy.
Lazy people sometimes have brilliant ideas :wink:

I use --now to save one line :slight_smile:
I use no sudo, if systemctl needed sudo, it will ask about it.

systemctl enable --now cups

Is not really my idea but that I am lazy is right. :smiley:


We might be on two different (but related) subjects. Do you mean the actual print settings GUI is missing? If that's the case, it is called "system-config-printer" and is searchable in pamac. You can also install it from terminal using "sudo pacman -S system-config-printer". After you install this GUI it may still be necessary to install, enable & start CUPS as outlined earlier.

No, you had it right the first time. Nothing printer related would install. I tried just installing CUPS, and then the hplip package (which requires CUPS). Both complained of conflicts/missing requirements. Then I tried what you suggested, it wasn't available. I had just done a general update refresh, with no new updates found. So I walked away fro a couple of hours, came back after lunch, and tried installing the Deepin-print package. It ultimately silently failed, but after yet another reboot, I tried hplip again, and Viola! It worked. So I'm clueless as to which one finally pulled in whatever was needed, but it's working now.

Thanks for the help.

1 Like

Confirm your /etc/pacman.d/chaotic-mirrorlist servers are in this order:

## By: GarudaLinux and Fosshost
Server =$repo/$arch

# Germany
## By: ParanoidBangL
Server =$repo/$arch

# Netherlands
## By: Var Bhat and LiteServer
Server =$arch

# others may follow bellow this point

Not all servers include Garuda related packages.


Thanks for the tip.

Please do not necrobump old threads.

You can simply give a like if you appreciate a post.