New installed apps slow to launch

Hello guys.
recently i updated two of my apps:
visual studio code(code v1.65) and google chrome(google-chrome v99)

when i tried to lunch them it took 2 mins! i never had issues like this before and it's unlikely to be hardware issue because every other apps that i have works just fine.

i suspected that it might be a problem occurring to new apps so i tested this:
i lunched one of my light apps(noisetorch) it worked well. i removed it using octopi(i use octopi for installing and uninstalling packages allways) then i installed it again and it got the same issue. it took about 2 mins to lunch.

i have no idea what to try or where to start...

System:
Kernel: 5.15.12-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=c8f869ce-554b-4598-b90a-a257e270b783 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: CDM product: CDM-001 v: N/A
serial: <superuser required>
Mobo: AAEON model: LIQ77A v: Rev X.0x serial: <superuser required>
UEFI: American Megatrends v: 9901 date: 07/23/2013
CPU:
Info: model: Intel Core i5-2500 bits: 64 type: MCP arch: Sandy Bridge
family: 6 model-id: 0x2A (42) stepping: 7 microcode: 0x2F
Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
desc: 1x6 MiB
Speed (MHz): avg: 3592 high: 3689 min/max: 1600/3700 scaling:
driver: intel_cpufreq governor: schedutil cores: 1: 3511 2: 3592 3: 3689
4: 3578 bogomips: 26340
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled
Type: mds mitigation: Clear CPU buffers; SMT disabled
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Baffin [Radeon RX 460/560D / Pro
450/455/460/555/555X/560/560X]
vendor: Gigabyte driver: amdgpu v: kernel bus-ID: 01:00.0
chip-ID: 1002:67ef class-ID: 0300
Display: x11 server: X.Org 1.21.1.2 compositor: kwin_x11 driver:
loaded: amdgpu,ati unloaded: fbdev,modesetting,vesa display-ID: :0
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
s-diag: 582mm (22.9")
Monitor-1: HDMI-A-0 res: 1920x1080 hz: 60 dpi: 69
size: 708x398mm (27.9x15.7") diag: 812mm (32")
OpenGL: renderer: AMD Radeon RX 460 Graphics (POLARIS11 DRM 3.42.0
5.15.12-zen1-1-zen LLVM 13.0.0)
v: 4.6 Mesa 21.3.2 direct render: Yes
Audio:
Device-1: Intel 7 Series/C216 Family High Definition Audio
vendor: ASUSTeK P8Z77-V LX driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
chip-ID: 8086:1e20 class-ID: 0403
Device-2: AMD Baffin HDMI/DP Audio [Radeon RX 550 640SP / RX 560/560X]
vendor: Gigabyte driver: snd_hda_intel v: kernel bus-ID: 01:00.1
chip-ID: 1002:aae0 class-ID: 0403
Sound Server-1: ALSA v: k5.15.12-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.42 running: yes
Network:
Device-1: Intel 82579LM Gigabit Network vendor: ASUSTeK driver: e1000e
v: kernel port: f040 bus-ID: 00:19.0 chip-ID: 8086:1502 class-ID: 0200
IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:
Local Storage: total: 1.2 TiB used: 211.85 GiB (17.2%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 EVO 500GB
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 2B6Q scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST3500413AS
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: JC4B scheme: GPT
ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital
model: WD3200AVJS-63B6A0 size: 298.09 GiB block-size: physical: 512 B
logical: 512 B speed: 3.0 Gb/s type: N/A serial: <filter> rev: 3A02
scheme: GPT
Partition:
ID-1: / raw-size: 72.53 GiB size: 72.53 GiB (100.00%)
used: 35.55 GiB (49.0%) fs: btrfs dev: /dev/sda4 maj-min: 8:4
ID-2: /boot/efi raw-size: 100 MiB size: 98.4 MiB (98.42%)
used: 27.4 MiB (27.9%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 72.53 GiB size: 72.53 GiB (100.00%)
used: 35.55 GiB (49.0%) fs: btrfs dev: /dev/sda4 maj-min: 8:4
ID-4: /var/log raw-size: 72.53 GiB size: 72.53 GiB (100.00%)
used: 35.55 GiB (49.0%) fs: btrfs dev: /dev/sda4 maj-min: 8:4
ID-5: /var/tmp raw-size: 72.53 GiB size: 72.53 GiB (100.00%)
used: 35.55 GiB (49.0%) fs: btrfs dev: /dev/sda4 maj-min: 8:4
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.69 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0

Try opening these apps from terminal and post the output as text here.

Google chrome is working fine here, btw.

4 Likes

This Kernel version is very old.
Not sure this can have an effect on your issue, but I definitely think you should update your system fully.

7 Likes

And be sure to restart afterwards.

4 Likes

i ran them through terminal. for vscode there was nothing and for chrome there was this:

(google-chrome:3772): GVFS-WARNING **: 21:39:21.707: Error creating proxy: Error calling StartServiceByName for org.gtk.vfs.Daemon: Timeout was reached (g-io-error-quark, 24)


(google-chrome:3772): Gtk-WARNING **: 21:39:21.719: Theme parsing error: gtk-dark.css:5822:26: '-shadow' is not a valid color name

(google-chrome:3772): Gtk-WARNING **: 21:39:21.719: Theme parsing error: gtk-dark.css:5825:14: not a number

(google-chrome:3772): Gtk-WARNING **: 21:39:21.720: Theme parsing error: gtk-dark.css:5826:13: not a number

(google-chrome:3772): Gtk-WARNING **: 21:39:21.720: Theme parsing error: gtk-dark.css:5827:11: Expected a length
[3925:3925:0310/213921.927904:ERROR:sandbox_linux.cc(377)] InitializeSandbox() called with multiple threads inprocess gpu-process.

i tried to update kernel but octopi says:

Partial updates are not supported!

i have 800 outdated packeges and i have a feeling that everything is in conflict and the system doesn't preform as before. its been few month now that i didn't updated anything.

i think i should fully update then see whats happen.

From the terminal.

update

And let's see how It goes...

3 Likes

i found the solution!

i was about to fully update the system (as @filo ) also said. but download size was 6gb and my connection was poor so i decided to do it later.

as i was working with vscode and tried to open a terminal it said

The terminal process failed to launch: A native exception occurred during launch (/usr/lib/libc.so.6: version `GLIBC_2.34' not found .

i also tried lunching noisetorch also in terminal as @Naman said and it said the same.
so i updated this tow packages and it fixed the problem:
glibc
lib32-glibc

but there are few things i still wish to ask!( i really dont know if i need to create a new topic :frowning: )

when does exactly octopi start to showing the partial updates are not supported message? because there is so many updates in short periods and i am really annoyed being always up to date(its time consuming and decreases the lifespan of ssd's)!
so i just don't want to be always fully updated and still being able to update some particular packages !
this time even when i tried to update those 2 packages i got the error from octopi and i had to use yaourt to do the thing.
there might be people like me and still doesn't knowing about yaourt or any other helpers. im not sure even how far i can go with 800 outdated packages :grinning_face_with_smiling_eyes: but its just a suggestion :slight_smile: . is there any place where i can report this?
and there is one more thing :grinning_face_with_smiling_eyes: can anyone give me documentation or explanation about those 2 packages and why they being out dated cause this problems? im a bit curious :slight_smile:

thank you all.

This is a recipe for disaster.

Your system is now in a partially upgraded state. You should update the rest of the packages immediately.

It's quite possible that the new glibc version will mean all other applications are broken; if this is the case you can use pacman-static to update your system.

7 Likes

seriously, Arch is a rolling release - if you don't update on even a vaguely regular basis, you're just making trouble for yourself 'cause it will break (updating packages that will have already been updated already but weren't etc). If you cannot keep up, then seriously consider a static release (debian based etc)

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.