New Install failure Grub loader

Hi.

New to Garuda and have been trying different distros over the years with a dual boot to Windows on my laptop

This week I have tried Kubuntu and Opensuse Tumbleweed KDE and had no install issues

Was going through the install process for this one and near the end, I got an error message that it could not create a Grub load file (I can't remember exact wording and can try again and take a photo)

When I reboot now it goes straight to a grub prompt

I have to restart and press F9 to get the boot options menu and log into Windows

Grateful for your advice as to how I can get past this issue as I was really looking forward to using this... Very beautiful elegant distro!

Hope you can assist

Cheers
R

just post the text, no picture needed.

Try

sudo update-grub

in Garuda Linux.

BTW, dual boot is not supported by Garuda.

Thats normal on grub.

2 Likes

First of all, Welcome to Garuda!

Then, I would suggest reading our wiki and tutorials, which are more than useful for a successful Garuda experience.
Also,

but there are several users that do it nevertheless, so there are countless topics with similar problems. Do spend some of your valuable time to read through as many as possible. You will discover the most advice that we could give you for this specific issue, and you will gain a lot of useful knowledge about Linux and... Grub!
Usually it's a proper BIOS setting, a WinOS interference, or a bad BIOS/UEFI firmware that create the problems.
Most of them are solved using chroot after booting to your USB installer.
In any case, provide your system info, after you have read a lot of what is suggested above.
Before you ask "what info", do the reading and you"ll see what others do and relevant advice.

Good luck!

4 Likes

It also runs wonderfully in dual boot for me.
M$ 10 was already included with the laptop.
Out of habit I don't throw anything away and I've left it on the laptop.

Where, I start M$ only to remind me again how terrible it is.
I've also noticed that the only program I'm supposed to need M$ for works just as well under wine.

1 Like

Welcome Webheadjunky!

Thanks for the advice everyone.
I re-ran the installer and it worked fine, so I am in!
We can close this thread
Next task is to get my docked external monitor recognised so will research that now
Cheers
R

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.