NetworkManager cannot find any WiFi connection after suspend phase and only solution to it is to restart computer

Hello Garuda users.

I have issue with WiFi connection. After suspension Network Manager cannot find any connection.
I tried:
Manjaro(KDE)
artix(KDE)
Pop_OS!,
Garuda(cinnamon)
and I didn't have any problems with WiFi after suspension on those distros.

I also tried Garuda KDE Dragonized(I am using gaming version of it) and I had the same problem there.

Before I changed my problematic WiFi driver, this helped me for a while, but it didn't work consistently and i still had to restart my computer in order to get connection back. Now 2 lines in this script needs to be changed in order for it to work and I am not sure with what.
btw I used this which solved WiFi drops on zen kernel.

Thank you in advance.

System:
Kernel: 5.18.14-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=26c9cf0e-2a45-4920-bdf2-0049acb7afeb rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 pci=noaer
Console: pty pts/0 wm: kwin_x11 DM: SDDM Distro: Garuda Linux
base: Arch Linux
Machine:
Type: Laptop System: ASUSTeK product: ASUS TUF Gaming A17 FA706II_FA706II
v: 1.0 serial: <filter>
Mobo: ASUSTeK model: FA706II v: 1.0 serial: <filter>
UEFI: American Megatrends v: FA706II.316 date: 03/12/2021
Battery:
ID-1: BAT1 charge: 38.5 Wh (100.0%) condition: 38.5/48.1 Wh (80.1%)
volts: 12.6 min: 11.7 model: ASUS A32-K55 type: Li-ion serial: N/A
status: full
Device-1: sony_controller_battery_a4:ae:12:a7:31:ef model: N/A
serial: N/A charge: N/A status: full
CPU:
Info: model: AMD Ryzen 5 4600H with Radeon Graphics socket: FP6 bits: 64
type: MT MCP arch: Zen 2 gen: 3 built: 2020-22 process: TSMC n7 (7nm)
family: 0x17 (23) model-id: 0x60 (96) stepping: 1 microcode: 0x8600104
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 8 MiB desc: 2x4 MiB
Speed (MHz): avg: 3000 min/max: 1400/3000 boost: enabled
base/boost: 3000/4000 scaling: driver: acpi-cpufreq governor: performance
volts: 1.2 V ext-clock: 100 MHz cores: 1: 3000 2: 3000 3: 3000 4: 3000
5: 3000 6: 3000 7: 3000 8: 3000 9: 3000 10: 3000 11: 3000 12: 3000
bogomips: 71868
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed
mitigation: untrained return thunk; SMT enabled with STIBP protection
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: always-on, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA TU117M [GeForce GTX 1650 Ti Mobile] vendor: ASUSTeK
driver: nvidia v: 515.57 alternate: nouveau,nvidia_drm non-free: 515.xx+
status: current (as of 2022-06) arch: Turing process: TSMC 12nm
built: 2018-22 pcie: gen: 1 speed: 2.5 GT/s lanes: 8 link-max: gen: 3
speed: 8 GT/s lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:1f95 class-ID: 0300
Device-2: AMD Renoir vendor: ASUSTeK driver: amdgpu v: kernel
arch: GCN 5.1 process: TSMC n7 (7nm) built: 2018-21 pcie: gen: 4
speed: 16 GT/s lanes: 16 ports: active: eDP-1 off: HDMI-A-1 empty: none
bus-ID: 05:00.0 chip-ID: 1002:1636 class-ID: 0300
Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo
bus-ID: 1-4:3 chip-ID: 13d3:56a2 class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: amdgpu,nvidia
unloaded: modesetting,nouveau alternate: fbdev,nv,vesa gpu: amdgpu
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 506x285mm (19.92x11.22")
s-diag: 581mm (22.86")
Monitor-1: HDMI-A-1 mapped: HDMI-A-0 note: disabled
model: Samsung C27F390 serial: <filter> built: 2021 res: N/A dpi: 82
gamma: 1.2 size: 598x336mm (23.54x13.23") diag: 686mm (27") ratio: 16:9
modes: max: 1920x1080 min: 720x400
Monitor-2: eDP-1 mapped: eDP pos: primary model: AU Optronics 0x479d
built: 2019 res: 1920x1080 hz: 120 dpi: 128 gamma: 1.2
size: 382x215mm (15.04x8.46") diag: 438mm (17.3") ratio: 16:9 modes:
max: 1920x1080 min: 640x480
OpenGL: renderer: AMD RENOIR (LLVM 14.0.6 DRM 3.46 5.18.14-zen1-1-zen)
v: 4.6 Mesa 22.1.3 direct render: Yes
Audio:
Device-1: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel
bus-ID: 1-2:2 chip-ID: 054c:09cc pcie: class-ID: 0300 gen: 1
speed: 2.5 GT/s lanes: 8 link-max: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:10fa class-ID: 0403
Device-2: AMD Renoir Radeon High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 05:00.1 chip-ID: 1002:1637 class-ID: 0403
Device-3: AMD ACP/ACP3X/ACP6x Audio Coprocessor
vendor: DekTec Digital Video B.V. driver: N/A alternate: snd_pci_acp3x,
snd_rn_pci_acp3x, snd_pci_acp5x, snd_pci_acp6x, snd_acp_pci,
snd_sof_amd_renoir
pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 05:00.5 chip-ID: 1022:15e2
class-ID: 0480
Device-4: AMD Family 17h/19h HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 05:00.6 chip-ID: 1022:15e3 class-ID: 0403
Device-5: Sony DualShock 4 [CUH-ZCT2x] type: USB
driver: snd-usb-audio,sony,usbhid
Sound Server-1: ALSA v: k5.18.14-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.56 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: e000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp2s0 state: down mac: <filter>
Device-2: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter
vendor: AzureWave driver: rtw_8822ce v: kernel modules: rtw88_8822ce pcie:
gen: 1 speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 03:00.0
chip-ID: 10ec:c822 class-ID: 0280
IF: wlp3s0 state: up mac: <filter>
Bluetooth:
Device-1: IMC Networks Bluetooth Radio type: USB driver: btusb v: 0.8
bus-ID: 3-1:2 chip-ID: 13d3:3548 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 1.39 TiB used: 208.58 GiB (14.7%)
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Micron
model: 2210 MTFDHBA512QFD size: 476.94 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: P6MA001 temp: 40.9 C scheme: GPT
SMART: yes health: PASSED on: 185d 19h cycles: 1,249
read-units: 18,326,838 [9.38 TB] written-units: 32,550,231 [16.6 TB]
ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM035-1RK172
family: Mobile HDD size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B sata: 3.1 speed: 6.0 Gb/s type: HDD rpm: 5400
serial: <filter> rev: 0001 temp: 35 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 185d 1h cycles: 1231
read: 4.03 TiB written: 7.57 TiB Old-Age: g-sense error rate: 486 Pre-Fail:
attribute: Spin_Retry_Count value: 100 worst: 100 threshold: 97
ID-3: /dev/sdb maj-min: 8:16 type: USB vendor: Generic model: Flash Disk
size: 14.65 GiB block-size: physical: 512 B logical: 512 B type: SSD
serial: <filter> rev: 8.07 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 154.09 GiB (32.3%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 608 KiB (0.2%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
maj-min: 259:1
ID-3: /home raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 154.09 GiB (32.3%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
ID-4: /var/log raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 154.09 GiB (32.3%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
ID-5: /var/tmp raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 154.09 GiB (32.3%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 30.78 GiB used: 2 MiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 44.0 C
Fan Speeds (RPM): cpu: 2400
Info:
Processes: 301 Uptime: 9m wakeups: 2 Memory: 30.78 GiB
used: 2.89 GiB (9.4%) Init: systemd v: 251 default: graphical
tool: systemctl Compilers: gcc: 12.1.0 clang: 14.0.6 Packages: pacman: 1842
lib: 522 Shell: garuda-inxi (sudo) default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.19
Garuda (2.6.5-1):
System install date:     2022-07-24
Last full system update: 2022-07-26
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:

if you have KDE there is a setting for wifi energy save
mode, ref. system-settings
image

Ty for reply. Tried it but didn't work

Did you search on KDE for the problem?

Just out of curiosity.
If it works on so many OS OOTB, why does it have to be Garuda KDE gaming?
You can also install gaming on Garuda Cinnamon.
Or just use the other OS.
Do you want to work with the OS or what is your intention?

But it could also be the kernel. Just try them all.
It could be that the other OSs are not up to date in this respect.

I just like KDE version and if it is possible to resolve this problem on this OS I would prefer it, but if not obviously I need to chanage it.

Could you please clarify what you mean here? Which lines and how you know that?
What is not clear to me is that in the second link there is

blacklist rtw88_8822ce

But in the first link script

ExecStart=-/usr/bin/modprobe -r rtw88_8822ce
ExecStop=/usr/bin/sleep 5
ExecStop=-/usr/bin/modprobe rtw88_8822ce

So maybe the script doesn't work?
But in the inxi I see

So the module is not blacklisted.

1 Like

Imo those lines
ExecStart=-/usr/bin/modprobe -r rtw88_8822ce
ExecStart=-/usr/bin/modprobe -r rtw88_8822ce
, because I replaced original driver with rtw88-dkms-git and blacklisted it in
/etc/modprobe.d/rtl8822ce.conf

edit: In order for me to not feel even more stupid I triple checked it and restarted like 3-4 times to get back and service in fact doesn't work right now and thats why I think that I need to change those lines in order for it to work

this is how /etc/modprobe.d/rtl8822ce.conf looks like

options rtw_pci disable_aspm=1
blacklist rtw88_8822ce
1 Like

Try rtw_8822ce there

6 Likes

THANK YOU :heart: :heart: :heart:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.