Network priority application

Hello, I'm looking for an application similar to that limiter mainly though I need the application priority section of the application.

I'm looking for something with a gooey I have gone around the internet to try some other options and they don't really work too well or they are just firewalls that just completely ignore the priority section that I actually need.
My bandwidth upload rates and download rates are pretty low it's the only ISP in the area so I have no ability to change it.

I was wondering if anybody here knew of an option that yes has a GUI. And yes I do need a GUI. Command line is far too inefficient for the little time I have.

you need to be more specific to cover your home or just your computer?

1 Like

Just the PC itself. I tried it with routers and it does not work efficiently. Voice calls often drop unless it's at the application level on the machine.

From reading your reply I take it you looking for a way to use of QoS traffic prioritization on your PC?

I see you looking for an app with a GUI that is not an easy request. As there aren't really great GUI alternative apps for this function.

GitHub - cryzed/TrafficToll: NetLimiter-like bandwidth limiting and QoS for Linux - CLI only
GitHub - sigmaSd/Eltrafico: NetLimiter-like traffic shaping for Linux - With a GUI ontop of TrafficToll

3 Likes

Can you provide your

garuda-inxi

it may help in diagnosing the problem?

1 Like
System:
Kernel: 5.17.4-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=6232c792-106f-494c-94cd-8233430432c2 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma v: 5.24.4 tk: Qt v: 5.15.3 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: ASUSTeK model: PRIME X570-PRO v: Rev X.0x
serial: <superuser required> UEFI: American Megatrends v: 4021
date: 08/09/2021
Battery:
Device-1: sony_controller_battery_90:fb:a6:d3:7c:ab model: N/A serial: N/A
charge: N/A status: full
CPU:
Info: model: AMD Ryzen 7 3700X bits: 64 type: MT MCP arch: Zen 2
family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
L3: 32 MiB desc: 2x16 MiB
Speed (MHz): avg: 3689 high: 4149 min/max: 2200/4630 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3584 2: 3491
3: 3466 4: 3829 5: 3597 6: 4149 7: 3732 8: 3857 9: 3836 10: 3532 11: 3507
12: 3647 13: 4120 14: 3555 15: 3599 16: 3534 bogomips: 115195
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Retpolines, IBPB: conditional, STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA GM204 [GeForce GTX 980] vendor: Gigabyte driver: nvidia
v: 510.60.02 alternate: nouveau,nvidia_drm pcie: gen: 3 speed: 8 GT/s
lanes: 16 bus-ID: 09:00.0 chip-ID: 10de:13c0 class-ID: 0300
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 3440x1440 s-dpi: 109 s-size: 802x333mm (31.57x13.11")
s-diag: 868mm (34.19")
Monitor-1: DP-2 res: 3440x1440 dpi: 109 size: 800x335mm (31.5x13.19")
diag: 867mm (34.15") modes: N/A
OpenGL: renderer: NVIDIA GeForce GTX 980/PCIe/SSE2
v: 4.6.0 NVIDIA 510.60.02 direct render: Yes
Audio:
Device-1: NVIDIA GM204 High Definition Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 09:00.1 chip-ID: 10de:0fbb class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 0b:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-3: Texas Instruments PCM2900C Audio CODEC type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 5-2:2 chip-ID: 08bb:29c0
class-ID: 0300
Sound Server-1: ALSA v: k5.17.4-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.50 running: yes
Network:
Device-1: Intel Wireless 7260 driver: iwlwifi v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 bus-ID: 04:00.0 chip-ID: 8086:08b1 class-ID: 0280
IF: wlp4s0 state: down mac: <filter>
Device-2: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 05:00.0
chip-ID: 8086:1539 class-ID: 0200
IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
bus-ID: 3-6:5 chip-ID: 8087:07dc class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 2.86 TiB used: 1.82 TiB (63.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: HP model: SSD EX920 1TB
size: 953.87 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 32A0T2IA
temp: 45.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: OCZ model: VERTEX3 size: 111.79 GiB
block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD
serial: <filter> rev: 2.22 scheme: GPT
ID-3: /dev/sdb maj-min: 8:16 vendor: Western Digital
model: WD20EZAZ-00L9GB0 size: 1.82 TiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
rev: 0A80 scheme: GPT
Partition:
ID-1: / raw-size: 222.04 GiB size: 222.04 GiB (100.00%)
used: 116.55 GiB (52.5%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-2: /boot/efi raw-size: 498 MiB size: 497 MiB (99.80%)
used: 317.8 MiB (63.9%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 222.04 GiB size: 222.04 GiB (100.00%)
used: 116.55 GiB (52.5%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-4: /var/log raw-size: 222.04 GiB size: 222.04 GiB (100.00%)
used: 116.55 GiB (52.5%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-5: /var/tmp raw-size: 222.04 GiB size: 222.04 GiB (100.00%)
used: 116.55 GiB (52.5%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 9.79 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p4 maj-min: 259:4
ID-2: swap-2 type: zram size: 15.59 GiB used: 2.5 MiB (0.0%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 48.0 C mobo: 42.0 C gpu: nvidia temp: 45 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 25%
Info:
Processes: 423 Uptime: 4m wakeups: 1 Memory: 15.6 GiB
used: 4.58 GiB (29.4%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 2115 lib: 578 flatpak: 0
Shell: fish v: 3.4.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.15
Garuda (2.6.2-1):
System install date:     2021-10-29
Last full system update: 2022-04-27 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:

there's no real system issue it all is working fine this happens no matter the OS/computer. its just a network one sadly.

The linux world is dark in this regard, but definitely thank you! :slightly_smiling_face:

What is your upload and download speeds?

1 Like

25Mbits down 2 up on a good day but its not stable at that sadly most of the time it's less mind you i'm paying for 100 down an up. but ya bad isp but the only one.

I,m a little confused and surprised as you are running garuda, garuda does not do any background tasks on the internet unless started? Qos is not normally required.
if you say calls are being dropped, i would check your network traffic and see what is causing it?

2 Likes

It comes down to apps such as discord or team speak, zoom or anything of that nature, not taking priority over, say when a browser is open or running another application that is using data as well.

The application netlimiter I used for Windows or I think it was called Network conditioner for Mac OS.

I would give applications like that the highest priority and everything else basically normal to low depending on what it was.

Basically when when speaking the voice goes robotic on their end. Or can not I hear me at all. But when using software like that while it does happen every once in a great while if uploading something at the same time other than that it works generally flawlessly.

Since I've been slowly migrating over to Linux again I was hoping there be a new application for it but it's looking like not much has changed. But that's fine as well if necessary it'll just be the mac's for work.

1 Like

I think for a whole home solution i would try pfsense if you have spare hardware as it has a very good Qos/ limiters wizards forjust the things that you require.

2 Likes

It would be nice if it worked well enough but it just doesn't quite come up to snuff. I did test it a while back when I had my old PC still for it. But it did not alleviate the issue. Personally I don't really understand why I don't understand why I can't fix it on the router level either.

But I just blame bad packet priority with the apps themselves. Haha

But, Thank you very much for all your help!

I do honestly appreciate it. I get about 10 hours a week of "free" time so I don't really get a lot of time to spend on the issues.

1 Like

Give the latest version ago if you get chance was using it last week at a lan with 15 people and only a connection speed of 16 down and 1.5 up. And all seemed good

2 Likes

Will definitely give it a go when I get the chance!

1 Like

I know that my solution is not garuda related however I had similar issues with my network.

I have 50Mbps down / 5Mbps up. It is a solid connection. I bought an asus router (RT-AC68U) that is compatible with AsusMerlin. The QOS is fantastic! There are over 25 device attached and no problems. We can use 2 concurrent google DUO's and watch a 4k movie on Disney+, while my son watched netflix in the other room.

They have a great community forum, with lots of people helping. Unfortunately it is not as nice as garuda's forum that uses discorse. :wink:

EDIT: I also serve some web pages and email to about 10 people on this connection.

1 Like

I agree with waeking, your best bet it to configure in the admin portal for your router. Most modern routers include some basic settings for QoS configuration, and it'll be a web-based GUI so perfect for your requirement. An added benefit is your QoS settings will not be tied in down by your computer--any connected device will use the settings you choose.

1 Like

i thank you both for that option but they don't work. I do have a asus router with merlin installed. And its set up correctly but, It's basically happening on the machine side when any upload of any data occurs. This took me about a year to diagnose on the windows/OSX to get somewhat stable side so I'm willing to wait for a client side solution to one day pop up even if its paid.
Again thank you for the suggestions! :slightly_smiling_face:

You should ask more about QOS on the asus merlin firmware forum. Use FlexQOS! and set your up and down manually with about 10% less than your max. Then run a few speed tests and adjust accordingly.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.