Network Manager in a connect - disconnect loop

that’s weird. I took that directly from the man page

huh restarting the service worked when I tinkered with the config

So no more connectivity issues? Did you really not once restart your computer after posting this issue? It’s been a week!

1 Like

I don’t think that is intended behavior. I suspect that my bug correlates with either the restart itself or the log functionality.

As I have elaborated on, this issue happened in the past, and I remember using systemctl restart NetworkManager with no success.

But I cannot remember it bugging my existing, and working WiFi connections back then.
Could be just bad memory, though.

I am sure, this is how its supposed to happen.

No, its been a day.
And yes, I did not restart it.
I usually have my laptop configured to shut down the display, when I close the lid.
I paid attention, that it had always a power source. :slightly_smiling_face:

OK, I seem to have another issue.
I just wanted to verify, that now, as the issue is gone, I can simply add that log config and restart NetworkManager. The result was the same:

I do now a couple of experiments with restarting that service, with either no configs around logging, or them being enabled.

Edit: I can confirm:

The issue has nothing to do with the log setting.
My particular setup does not restart NetworkManager properly.

That means:

A fresh reboot gives me a perfectly working internet connection.
systemctl restart NetworkManager just kills it.

I am on the current test ISO, updated system, Wayland.

Kernel: 6.5.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=4836c503-d2d0-481e-a632-f9ac2f82aebc rw rootflags=subvol=@
quiet loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.8 tk: Qt v: 5.15.11 wm: kwin_wayland vt: 1
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Laptop System: HP product: HP EliteBook 820 G3 v: N/A
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: HP model: 807C v: KBC Version 85.61 serial: <superuser required>
UEFI: HP v: N75 Ver. 01.05 date: 03/22/2016
ID-1: BAT0 charge: 36.0 Wh (100.0%) condition: 36.0/36.0 Wh (100.0%)
volts: 12.8 min: 11.4 model: Hewlett-Packard Primary type: Li-ion
serial: <filter> status: full
Info: model: Intel Core i5-6200U bits: 64 type: MT MCP arch: Skylake
gen: core 6 level: v3 note: check built: 2015 process: Intel 14nm family: 6
model-id: 0x4E (78) stepping: 3 microcode: 0xF0
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 500 min/max: 400/2800 scaling: driver: intel_pstate
governor: powersave cores: 1: 500 2: 500 3: 500 4: 500 bogomips: 19200
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Hewlett-Packard
driver: i915 v: kernel arch: Gen-9 process: Intel 14n built: 2015-16 ports:
active: eDP-1 empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0
chip-ID: 8086:1916 class-ID: 0300
Device-2: Cheng Uei Precision Industry (Foxlink) HP HD Camera
driver: uvcvideo type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0
bus-ID: 1-9:4 chip-ID: 05c8:0383 class-ID: 0e02
Display: wayland server: v: with: Xwayland v: 23.2.1
compositor: kwin_wayland driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: 0
Monitor-1: eDP-1 res: 1366x768 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
device: 1 drv: swrast surfaceless: drv: iris wayland: drv: iris x11:
drv: iris inactive: gbm
API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.2.1-arch1.2
glx-v: 1.4 direct-render: yes renderer: Mesa Intel HD Graphics 520 (SKL GT2)
device-ID: 8086:1916 memory: 7.25 GiB unified: yes display-ID: :1.0
API: Vulkan v: 1.3.264 layers: 3 device: 0 type: integrated-gpu name: Intel
HD Graphics 520 (SKL GT2) driver: mesa intel v: 23.2.1-arch1.2
device-ID: 8086:1916 surfaces: xcb,xlib,wayland device: 1 type: cpu
name: llvmpipe (LLVM 16.0.6 256 bits) driver: mesa llvmpipe
v: 23.2.1-arch1.2 (LLVM 16.0.6) device-ID: 10005:0000
surfaces: xcb,xlib,wayland
Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_soc_avs
bus-ID: 00:1f.3 chip-ID: 8086:9d70 class-ID: 0403
API: ALSA v: k6.5.7-zen1-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 0.3.81 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Ethernet I219-V vendor: Hewlett-Packard driver: e1000e
v: kernel port: N/A bus-ID: 00:1f.6 chip-ID: 8086:1570 class-ID: 0200
IF: enp0s31f6 state: down mac: <filter>
Device-2: Intel Wireless 8260 driver: iwlwifi v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 8086:24f3 class-ID: 0280
IF: wlp2s0 state: up mac: <filter>
Device-3: HP HP lt4120 Snapdragon X5 LTE driver: cdc_ether type: USB
rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-3:7 chip-ID: 03f0:9d1d
class-ID: 0a00 serial: <filter>
IF: enp0s20f0u3i1 state: up speed: 425 Mbps duplex: half mac: <filter>
Device-1: Intel Bluetooth wireless interface driver: btusb v: 0.8 type: USB
rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-7:2 chip-ID: 8087:0a2b
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
rfk-block: hardware: no software: yes address: <filter> bt-v: 4.2 lmp-v: 8
status: discoverable: no pairing: no
Local Storage: total: 894.26 GiB used: 22.2 GiB (2.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Patriot model: M.2 P310 480GB
size: 447.13 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: EDFM90.0 temp: 29.9 C
scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37480G
size: 447.13 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 1103 scheme: GPT
ID-1: / raw-size: 446.83 GiB size: 446.83 GiB (100.00%)
used: 22.19 GiB (5.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 446.83 GiB size: 446.83 GiB (100.00%)
used: 22.19 GiB (5.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 446.83 GiB size: 446.83 GiB (100.00%)
used: 22.19 GiB (5.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 446.83 GiB size: 446.83 GiB (100.00%)
used: 22.19 GiB (5.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 7.42 GiB used: 3.97 GiB (53.5%)
priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4
dev: /dev/zram0
System Temperatures: cpu: 64.0 C pch: 53.0 C mobo: N/A
Fan Speeds (rpm): N/A
Processes: 239 Uptime: 15h 43m wakeups: 5 Memory: total: 8 GiB note: est.
available: 7.42 GiB used: 5.43 GiB (73.1%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 1490 libs: 377 tools: octopi,paru Shell: fish v: 3.6.1
running-in: yakuake inxi: 3.3.30
Garuda (2.6.17-1):
System install date:     2023-10-05
Last full system update: 2023-10-13 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       No/Undetected
Failed units:

Without your inxi I had no idea which network adapters your system had. The reason I asked for you to do a complete power down and reboot was in case you had an Intel Ethernet card. I recalled a bug from way back with Intel ethernet cards that required that or there was connectivity problems. This bug with Intel cards has a habit of resurfacing sometimes years later. Your fix may have been unrelated to the reboot, but there’s a good chance that’s what helped.

This is one of the reasons we always want a garuda-inxi output on help requests. Especially with connectivity problems, knowing the adapter make and model is of paramount importance. Please, always provide an inxi whenever opening a help request.


Don’t worry too much about that, NM has always worked that way on my machine as well. Including the Limited Connectivity you had which required a reboot.
Any time I have a connectivity problem (most of the time it’s when I wake up. Not me, my machine), I don’t even bother anymore trying to restart services or kill stuff or whatever, it never works and keeps me disconnected, so I reboot straight away.

1 Like

“This bug with Intel cards has a habit of resurfacing sometimes years later.”
So you recommend to just don’t use it or what? I’ve just installed Garuda on my HP Omen 15 laptop, I thought that I’ll be able to have it done before midnight and go to sleep and I can’t even connect it to the network.
I’ve spent hours on trying to at least find something that will let me explain what’s wrong and honestly I’m so exhausted that I’m not even able to get myself together and find a way to copy the garuda-inxi from my laptop to my phone without having a free USB port.

(long story short: it’s connecting, saying that it has limited access, then no access, disconnecting, having problem with some IP settings and I don’t know why because all wi-fis in my block have been detected and the signal is strong and it’s the first time that something has a problem with connecting to it)

I don’t even care anymore but can you please explain to me why would it install the drivers for my on-board Ethernet (RTL8111/8168/8411) and Wi-Fi card (Intel Wi-Fi 6 AX200), since it wasn’t able to do the same for the Alfa AWUS036ACS adapter that is recommended everywhere as an out-of-the-box working on Kali Linux?
Why Garuda Linux running on a quite powerful laptop can’t do what a Debian distro on a thin client was able to do without any issues?

And hello everybody by the way and good night… or good morning already.

1 Like

Completely different network components @CoreyFalken . Your Ethernet card is a Realtek adapter, your WiFi models are also very different, (although both are Intel).

Use USB phone tethering for a working internet connection.

I would suggest installing and testing the linux-lts and linux-mainline kernels.

If that does not help, you should really open a separate help request thread of your own.

Welcome to the Garuda forum Corey. :wave:


Can you rephrase that maybe a little?
Does Garuda use different drivers or just a different version?

For the last case, do as @tbg said, installing an LTS kernel could fix this.

Or do you say, that these distros use a completely different driver, and you wonder, how you could install that one?

Actually, restarting NetworkManager used to work quite well, although on KaOS, and a few years back.

Recently, and certainly since I have adopted Garuda, was it simply not needed anymore, since the network connection just worked.

Potentially because I don’t use Realtek and similar chips, which most often require non-free or reverse-engineered drivers.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.