Network Issues

Kernel: 6.2.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=aeed0525-beaa-4f84-9165-c04fb9af3432 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=58877725-3f84-4e5b-8ce2-0cf00a037c13 loglevel=3
Desktop: KDE Plasma v: 5.27.3 tk: Qt v: 5.15.8 wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Type: Desktop Mobo: ASUSTeK model: TUF GAMING X570-PLUS v: Rev X.0x
serial: <superuser required> UEFI: American Megatrends v: 2607
date: 08/14/2020
Info: model: AMD Ryzen 7 2700X bits: 64 type: MT MCP arch: Zen+ gen: 2
level: v3 note: check built: 2018-21 process: GF 12nm family: 0x17 (23)
model-id: 8 stepping: 2 microcode: 0x800820D
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 768 KiB desc: d-8x32 KiB; i-8x64 KiB L2: 4 MiB desc: 8x512 KiB
L3: 16 MiB desc: 2x8 MiB
Speed (MHz): avg: 3467 high: 4254 min/max: 2200/3700 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3700 2: 3700
3: 3700 4: 3700 5: 4254 6: 3700 7: 2748 8: 3700 9: 2539 10: 2456 11: 3700
12: 3700 13: 3700 14: 3700 15: 3700 16: 2789 bogomips: 118178
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Device-1: NVIDIA GA104 [GeForce RTX 3070] vendor: Micro-Star MSI
driver: nvidia v: 530.41.03 alternate: nouveau,nvidia_drm non-free: 530.xx+
status: current (as of 2023-03) arch: Ampere code: GAxxx
process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 3 speed: 8 GT/s lanes: 16
link-max: gen: 4 speed: 16 GT/s bus-ID: 07:00.0 chip-ID: 10de:2484
class-ID: 0300
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1
compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting,nouveau
alternate: fbdev,nv,vesa gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 5560x1920 s-dpi: 107 s-size: 1320x456mm (51.97x17.95")
s-diag: 1397mm (54.98")
Monitor-1: DP-0 pos: left res: 1080x1920 hz: 60 dpi: 92
size: 297x527mm (11.69x20.75") diag: 605mm (23.82") modes: N/A
Monitor-2: DP-4 pos: primary,center res: 2560x1440 hz: 165 dpi: 109
size: 597x336mm (23.5x13.23") diag: 685mm (26.97") modes: N/A
Monitor-3: HDMI-0 pos: right res: 1920x1080 hz: 60 dpi: 92
size: 531x298mm (20.91x11.73") diag: 609mm (23.97") modes: N/A
API: OpenGL v: 4.6.0 NVIDIA 530.41.03 renderer: NVIDIA GeForce RTX
3070/PCIe/SSE2 direct-render: Yes
Device-1: NVIDIA GA104 High Definition Audio vendor: Micro-Star MSI
driver: snd_hda_intel bus-ID: 3-2:3 v: kernel pcie: chip-ID: 33ae:0001
gen: 3 class-ID: 0300 serial: <filter> speed: 8 GT/s lanes: 16 link-max:
gen: 4 speed: 16 GT/s bus-ID: 07:00.1 chip-ID: 10de:228b class-ID: 0403
Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 09:00.3
chip-ID: 1022:1457 class-ID: 0403
Device-3: BEACN Mic type: USB driver: snd-usb-audio
Device-4: Licensed by Sony Entertainment America Rocksmith Guitar Adapter
type: USB driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-3:4
chip-ID: 12ba:00ff class-ID: 0300
API: ALSA v: k6.2.9-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.67 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: f000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
IF-ID-1: enp8s0f3u1 state: up speed: 425 Mbps duplex: half mac: <filter>
Local Storage: total: 1.55 TiB used: 58.17 GiB (3.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 model: SATA SSD size: 894.25 GiB block-size:
physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter>
rev: 7A0 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital
model: WD5000AZLX-75K2TA0 size: 465.76 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter>
rev: 1A01 scheme: GPT
ID-3: /dev/sdc maj-min: 8:32 vendor: Patriot model: Blast size: 223.57 GiB
block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD
serial: <filter> rev: 12.2 scheme: GPT
ID-1: / raw-size: 859.58 GiB size: 859.58 GiB (100.00%)
used: 58.17 GiB (6.8%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 608 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 859.58 GiB size: 859.58 GiB (100.00%)
used: 58.17 GiB (6.8%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 859.58 GiB size: 859.58 GiB (100.00%)
used: 58.17 GiB (6.8%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 859.58 GiB size: 859.58 GiB (100.00%)
used: 58.17 GiB (6.8%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.25 GiB used: 1024 KiB (0.0%)
priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 34.38 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sda3 maj-min: 8:3
System Temperatures: cpu: 37.9 C mobo: N/A gpu: nvidia temp: 47 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 30%
Processes: 350 Uptime: 10m wakeups: 0 Memory: 31.25 GiB
used: 3.91 GiB (12.5%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 12.2.1 Packages: pm: pacman pkgs: 1816
libs: 520 tools: octopi,paru Shell: fish v: 3.6.1 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.26
Garuda (2.6.16-1):
System install date:     2023-04-02
Last full system update: 2023-04-03 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       No/Undetected
Failed units:            Storage.mount NetworkManager-wait-online.service

Network connection does not work with router, but will function while USB Tethering. It will howerver, work in a snapshot but eventually will fail again.

Soltuions I have attempted:

Note: I am on a wired connection.

disabling ipv4 and 6 separately also setting to link local, tried static ipv4 configuration

restarting Network manager, and Network-manager-wait-online.service, network will work for about 30 seconds and cut off again.

rebooting router and computer

checked /etc/resolv.conf I did not see issues

looked through /var/log/garuda/garuda-update no issues.

unplugged ethernet, rebooted pc, waited for full boot then plugged in.

attempted system update

Welcome :slight_smile:

First, reboot and check

Second, try other kernel, LTS, mainline ...

I believe you are talking about the other kernels when booting? fallback.img and recovery.img? if so, neither of those worked.


sudo pacman -S linux-lts linux-lts-headers

Use advanced in grub menu to boot with other kernel.

Post as text, output

modinfo r8169 | grep ver 


sudo dmesg | grep r8169 

And search in internet about, you're not alone with this problem.


Maybe you could try this iommu kernel boot parameter (or other troubleshooting in the same article):

modinfo r8169 | grep ver
filename:       /lib/modules/6.1.22-1-lts/kernel/drivers/net/ethernet/realtek/r8169.ko.zst
description:    RealTek RTL-8169 Gigabit Ethernet driver
srcversion:     558F40B12069589D0EE6A84
vermagic:       6.1.22-1-lts SMP preempt mod_unload
╭─[email protected] in ~ took 3ms
╰─λ sudo dmesg | grep r8169
[sudo] password for ean:
[    4.273600] r8169 0000:03:00.0 eth0: RTL8168h/8111h, 3c:7c:3f:4f:7b:29, XID 541, IRQ 94
[    4.273607] r8169 0000:03:00.0 eth0: jumbo features [frames: 9194 bytes, tx checksumming: ko]
[    4.301228] r8169 0000:03:00.0 enp3s0: renamed from eth0
[    5.831008] Generic FE-GE Realtek PHY r8169-0-300:00: attached PHY driver (mii_bus:phy_addr=r8169-0-300:00,irq=MAC)
[    6.027781] r8169 0000:03:00.0 enp3s0: Link is Down
[   12.223411] r8169 0000:03:00.0 enp3s0: Link is Up - 1Gbps/Full - flow control off

will look into what filo said now.

no luck.

You might try with the proprietary driver (r8168 or even better r8168-dkms packages).
See e.g.
Try also with a different ethernet cable you never can say...


no luck with that, it was working with a previous snapshot so I do not believe its an ether cable.

:point_up: Testing this kernel is a good idea, I hope you do not overlook this advice.

1 Like

I did do that. You can see from my other reply it shows that

Right you are, sorry I missed that.

There is a separate kernel module for Realtek 8168 network cards, specifically for the LTS kernel in the [community] repo:

community/r8168-lts 8.051.02-25 [89.27KiB 86.84KiB]
    A kernel module for Realtek 8168 network cards for linux-lts

Try installing that as well to see if you get a different result.

sudo pacman -S r8168-lts
1 Like

You've covered most of the bases with your troubleshooting efforts although there still a few I others would try.

Check that your router's firmware is up to date. If the firmware is current, then I would suggest resetting your router back to the factory default settings.

Asus usually updates their bios pretty regularly, but yours is a little older than I'd expect for that mobo. Be sure to update your bios if there is a newer version.

Also try setting alternate DNS servers.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.