Network connection dropping

I have a new (2021) HP Essential Laptop Computer 17.3" HD+ AMD Athlon 8 GB memory; 128 GB SSD. I have replaced the Windows OS with garuda-xfce-linux-lts-240428.iso. My computer will not stay connected to the internet. My WiFi connects when the computer boots, but after a few minutes the connection is lost and the Network Manager does not list any available networks. Advanced Network Configuration shows my WiFi Router.
I am running Garuda Linux on my desktop machine with no problems with the network connection dropping.

Please post your garuda-inxi as requested by the template.

Welcome to the community :slight_smile:

2 Likes

inxi -b
System:
Host: tjh-hplaptop Kernel: 6.6.29-1-lts arch: x86_64 bits: 64
Desktop: Xfce v: 4.18.1 Distro: Garuda Linux
Machine:
Type: Laptop System: HP product: HP Laptop 17z-cp200 v: Type1ProductConfigId
serial:
Mobo: HP model: 8A81 v: 41.22 serial: UEFI: Insyde
v: F.13 date: 08/04/2023
Battery:
ID-1: BAT0 charge: 40.6 Wh (100.0%) condition: 40.6/40.6 Wh (100.0%)
CPU:
Info: dual core AMD Athlon Gold 7220U with Radeon Graphics [MT MCP]
speed (MHz): avg: 665 min/max: 400/3758
Graphics:
Device-1: AMD Mendocino driver: amdgpu v: kernel
Device-2: Luxvisions Innotech HP TrueVision HD Camera driver: uvcvideo
type: USB
Display: x11 server: X.Org v: 21.1.13 driver: X: loaded: amdgpu
unloaded: modesetting dri: radeonsi gpu: amdgpu resolution: 1600x900~60Hz
API: Vulkan v: 1.3.279 drivers: radv,llvmpipe surfaces: xcb,xlib
API: OpenGL Message: Unable to show GL data. glxinfo is missing.
Network:
Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
driver: rtw_8821ce
Drives:
Local Storage: total: 119.24 GiB used: 4.04 GiB (3.4%)
Info:
Memory: total: 8 GiB note: est. available: 7 GiB used: 1.51 GiB (21.6%)
Processes: 253 Uptime: 4m Shell: Bash inxi: 3.3.34

not

and please

  • After rebooting, post the FULL output of garuda-inxi in the body of the post (not linked externally, or collapsed with the “hide details” feature)
  • Format terminal output (including your garuda-inxi) as a code block by clicking the preformatted text button (</>) , or put three tildes (~) above and below the text
4 Likes

Is this what you need? I am floundering a bit here.


garuda-inxi
System:
  Kernel: 6.6.29-1-lts arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: hpet,acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
    root=UUID=632cf880-6bce-4e34-b59b-cfaa799c66e1 rw rootflags=subvol=@
    quiet loglevel=3 ibt=off
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 wm: xfwm4 v: 4.18.0
    with: xfce4-panel tools: xfce4-screensaver avail: xautolock vt: 7
    dm: LightDM v: 1.32.0 Distro: Garuda base: Arch Linux
Machine:
  Type: Laptop System: HP product: HP Laptop 17z-cp200 v: Type1ProductConfigId
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: HP model: 8A81 v: 41.22 serial: <superuser required>
    part-nu: 67K39AV uuid: <superuser required> UEFI: Insyde v: F.13
    date: 08/04/2023
Battery:
  ID-1: BAT0 charge: 40.6 Wh (100.0%) condition: 40.6/40.6 Wh (100.0%)
    volts: 13.0 min: 11.3 model: Hewlett-Packard Primary type: Li-ion
    serial: <filter> status: full cycles: 1
CPU:
  Info: model: AMD Athlon Gold 7220U with Radeon Graphics bits: 64
    type: MT MCP arch: Zen 2 gen: 3 level: v3 note: check built: 2020-22
    process: TSMC n7 (7nm) family: 0x17 (23) model-id: 0xA0 (160) stepping: 0
    microcode: 0x8A00008
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 1024 KiB desc: 2x512 KiB
    L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 400 min/max: 400/3758 scaling: driver: amd-pstate-epp
    governor: powersave cores: 1: 400 2: 400 3: 400 4: 400 bogomips: 19169
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
Graphics:
  Device-1: AMD Mendocino vendor: Hewlett-Packard driver: amdgpu v: kernel
    arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm) built: 2020-22 pcie:
    gen: 4 speed: 16 GT/s lanes: 16 ports: active: eDP-1
    empty: DP-1,DP-2,HDMI-A-1 bus-ID: 03:00.0 chip-ID: 1002:1506
    class-ID: 0300 temp: 38.0 C
  Device-2: Luxvisions Innotech HP TrueVision HD Camera driver: uvcvideo
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 5-1:2
    chip-ID: 30c9:0064 class-ID: fe01 serial: <filter>
  Display: x11 server: X.Org v: 21.1.13 compositor: xfwm4 v: 4.18.0 driver:
    X: loaded: amdgpu unloaded: modesetting alternate: fbdev,vesa dri: radeonsi
    gpu: amdgpu display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1600x900 s-dpi: 96 s-size: 423x238mm (16.65x9.37")
    s-diag: 485mm (19.11")
  Monitor-1: eDP-1 mapped: eDP model: BOE Display 0x0955 built: 2020
    res: 1600x900 hz: 60 dpi: 106 gamma: 1.2 size: 382x215mm (15.04x8.46")
    diag: 438mm (17.3") ratio: 16:9 modes: max: 1600x900 min: 640x480
  API: Vulkan v: 1.3.279 layers: 5 device: 0 type: integrated-gpu name: AMD
    Radeon Graphics (RADV RAPHAEL_MENDOCINO) driver: mesa radv
    v: 24.0.5-arch1.1 device-ID: 1002:1506 surfaces: xcb,xlib device: 1
    type: cpu name: llvmpipe (LLVM 17.0.6 256 bits) driver: mesa llvmpipe
    v: 24.0.5-arch1.1 (LLVM 17.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
  API: OpenGL Message: Unable to show GL data. glxinfo is missing.
Audio:
  Device-1: AMD Rembrandt Radeon High Definition Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 03:00.1 chip-ID: 1002:1640 class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Hewlett-Packard
    driver: snd_pci_acp6x v: kernel alternate: snd_pci_acp3x, snd_rn_pci_acp3x,
    snd_pci_acp5x, snd_acp_pci, snd_rpl_pci_acp6x, snd_pci_ps,
    snd_sof_amd_renoir, snd_sof_amd_rembrandt, snd_sof_amd_vangogh pcie:
    gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 03:00.5 chip-ID: 1022:15e2
    class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 03:00.6 chip-ID: 1022:15e3 class-ID: 0403
  API: ALSA v: k6.6.29-1-lts status: kernel-api tools: N/A
  Server-1: PipeWire v: 1.0.5 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
    vendor: Hewlett-Packard driver: rtw_8821ce v: N/A modules: rtw88_8821ce
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 2000 bus-ID: 02:00.0
    chip-ID: 10ec:c821 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
Bluetooth:
  Device-1: Realtek Bluetooth Radio driver: btusb v: 0.8 type: USB rev: 1.1
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-2:2 chip-ID: 0bda:b00e
    class-ID: e001 serial: <filter>
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 4.2
    lmp-v: 8 status: discoverable: no pairing: no class-ID: 6c010c
Drives:
  Local Storage: total: 119.24 GiB used: 4.04 GiB (3.4%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Phison model: PSELN128GA87MC0
    size: 119.24 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: HPE4BP00 temp: 26.9 C
    scheme: GPT
Partition:
  ID-1: / raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
    used: 4.04 GiB (3.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 584 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
    used: 4.04 GiB (3.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
    used: 4.04 GiB (3.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
    used: 4.04 GiB (3.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 7 GiB used: 0 KiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 41.0 C mobo: N/A gpu: amdgpu temp: 38.0 C
  Fan Speeds (rpm): N/A
Info:
  Memory: total: 8 GiB note: est. available: 7 GiB used: 1.44 GiB (20.5%)
  Processes: 253 Power: uptime: 1m states: freeze,mem,disk suspend: s2idle
    wakeups: 0 hibernate: platform avail: shutdown, reboot, suspend, test_resume
    image: 2.79 GiB services: upowerd,xfce4-power-manager Init: systemd v: 255
    default: graphical tool: systemctl
  Packages: pm: pacman pkgs: 1250 libs: 398 tools: paru Compilers:
    gcc: 13.2.1 Shell: garuda-inxi default: Bash v: 5.2.26
    running-in: xfce4-terminal inxi: 3.3.34
Garuda (2.6.26-1):
  System install date:     2024-06-12
  Last full system update: 2024-06-12
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       No/Undetected
  Failed units:      

I am having to run the terminal on the laptop, copy the output, email it to myself (before my WiFi connection is lost), open the email on my desktop machine, and send the information to you.

This solution is from a couple years ago, but it’s the same NIC so maybe worth a shot:

The only “gotcha” I see there is that package seems to be no longer in the Chaotic repo (it is just an AUR package now), so you’ll have to install it with something like Paru instead of Pacman.

paru -S rtw88-dkms-git

Press Q to exit the PKGBUILD review and proceed with the installation.

5 Likes

Next time add this exact garuda-inxi field to the first post.

I am far from linux whiz. I am struggling.
I opened Terminal and ran: sudo touch/etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
I received a “command not found” response.

I then ran: paru -S rtw88-dkms-git
I was presented with a Repo and an AUR version and a “proceed to review [Y,n]” choice. I entered “Y”
It downloaded PKGBUILDs: /home/joe/.cache/paru/clone/rtw88-dkms-git/PKGBUILD
Terminal installed: rtw88-dkms-git r400.530dfla-1 32.29MiB

Your instructions were: Add the following contents to the newly created conf file (where is this file?) with your preferred text editor: [connection] wifi.powerssave = 0 you can run the following command to generate the required conf file automatically: echo -e [connection] (what is the “connection” reference?).

Have I generated a “conf file”? What do I do from here?

Here a space is missing:

sudo touch /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

It is the file you’ll have created with the command above.

That was only an alternative way to create and update the file with a one-line command. So, one of the two option is enough ([connection] is the same line you see in the text to be copied with the other option).

Probably not, since sudo touch ... hasn’t worked. Follow the instructions again and:

Then restart Network Manager, or reboot.

Then proceed. The package is installed as you said, so proceed with the

Create /etc/modprobe.d/rtl8821ce.conf

part, again with the same two options, manual and one liner.

3 Likes

I ran the following commands in Terminal:
sudo touch /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

╭─joe@tjh in ~ as :mage:
[:brick:] × sudo echo -e touch /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
touch /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

Restarted laptop

╭─joe@tjh in ~ took 12ms
╰─λ Create /etc/modprobe.d/rt18821ce.conf
find-the-command: “Create” is not found locally, searching in repositories…
find-the-command: /var/cache/pkgfile/*.files are out of date, update? [Y/n] Y
[sudo] password for joe:
:: Updating 6 repos…
download complete: community [ 45.0 B 58.0B/s 5 remaining]
download complete: garuda [ 309.6 KiB 315K/s 4 remaining]
download complete: multilib [ 209.4 KiB 156K/s 3 remaining]
download complete: core [ 1103.1 KiB 334K/s 2 remaining]
download complete: chaotic-aur [ 47.7 MiB 9.39M/s 1 remaining]
download complete: extra [ 39.6 MiB 2.18M/s 0 remaining]
:: download complete in 18.19s < 88.9 MiB 4.89M/s 6 files >
:: waiting for 1 process to finish repacking repos…14 pt
find-the-command: command not found: “Create”

Create did not work.

Following your instructions to rerun “the manual and one liner” I reran:
sudo echo -e touch /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

I then opened Thunar as Root. I then went to /etc/NetworkManager/conf.d and found the file default-wifi-powersave-on. I used a text editor to enter wifi.powersave = 0 into it.

I restarted the laptop. Now I am unable to get Network Manager to even open. Clicking on the icon at the bottom of the screen, I am given a message: “NetworkManager is not running “

What now?

These commands are different from those in the suggested post.
Delete /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf and /etc/modprobe.d/rt18821ce.conf (probably not created, the command was wrong) and copy and paste the following

echo -e "[connection]\nwifi.powersave = 0" | sudo tee /etc/modprobe.d/rtl8821ce.conf
echo -e "options rtw_pci disable_aspm=1\nblacklist rtw88_8821ce" | sudo tee /etc/modprobe.d/rtl8821ce.conf

And reboot
The commands are those in the text blocks, while something like

Create /etc/modprobe.d/rtl8821ce.conf:

is just a description.

2 Likes

I have deleted the two files as you suggested.

Let me double check exactly what I should enter as “connection”. Is it:

sudo touch /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf ?

So my first Terminal entry would be:

sudo touch /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf/nwifi.powersave = 0 |

You are trying to make a file here:

/etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

The name of the file is default-wifi-powersave-on.conf, and it will be saved inside the /etc/NetworkManager/conf.d directory. The touch and tee commands are just quick ways of automatically creating this file for you. You can also open the file in and editor if you would like–any method is fine.

Inside the file should be these lines:

[connection]
wifi.powersave = 0

The echo | sudo tee commands are intended to automatically add this content to the file, but if you would like you can just open the file in an editor and paste in the content as well.

After this file is set up, restart NetworkManager.

sudo systemctl restart NetworkManager
1 Like

Thank you all so much. I think I was successful.
BluishHumility you gave the key. I was not able to get any of the Terminal commands to work, so I used Thunar as root and created a file " default-wifi-powersave-on.conf" within " /etc/NetworkManager/conf.d" and entered “wifi.powersave = 0” into the file. I then restarted NetworkManager.
It looks like my WiFi connection is now working.
I appreciate the hand-holding.
Joe Hall

1 Like

Glad you solved the problem.
I only modified the solution with the post giving the information about the source of the solution, as we always do.

1 Like

Wait guys.
I was too hasty. I started trying to setup my computer, but my laptop is still dropping the WiFi connection. I have to restart the computer to get a connection and that connection closes after a short length of time.

I am not even able to restart NetworkManager using;

sudo systemctl restart NetworkManager

I get this error message:
Failed to restart NetworkManager.service: Unit NetworkManager.service not found.

The only way I can get WiFi back is to restart my computer.

Could this be a hardware issue? The computer is supposedly new from the HP store on ebay.

Just checking: you included the bracketed “[connection]” line, right? The whole file should look like this:

[connection]
wifi.powersave = 0

Double-check for a typo in the command. The capitalization is significant. Copy and paste the full input/output into the thread so we can take a look. Highlight the text in the terminal, and “click” the scroll wheel on the mouse where you want to paste.

Paste also this terminal output:

inxi -Naz