.NET app outbound connection times out on dev machine only

Didn’t want to post this here since I didn’t think it would be OS-related, but I’ve exhausted all other options. Re-installed a clean Garuda, created a new console .NET project in Rider with only this code:

var website = "https://perdu.com";
Console.WriteLine($"Querying {website}...");
using var client = new HttpClient();
client.Timeout = TimeSpan.FromSeconds(5);
var value = await client.GetStringAsync(website);

This should run the equivalent of this command which works perfectly fine

curl https://perdu.com

Instead, the outbound connection is not refused, but it times out. Was having that issue on an ASP.NET project. It works perfectly fine on the production, only fails on the development machine.

And my development machine is a clean new setup. It used to work before.

Is there anything at the OS-level that could be causing this?

Had an issue on the server where Docker interfered with the firewall, so Docker has not been installed at all on this new setup, and I made no firewall configuration.

I ran wtrace on the console app and got this. Not seeing anything useful here.

11:14:08.2429 ConsoleApp1 (47722.47739) Network/SocketInfo info [/#47722/1/59/] (null) (CreateSocket) SafeSocketHandle:17653682(0x3E)
11:14:08.2432 ConsoleApp1 (47722.47739) Network/SocketInfo info [/#47722/1/59/] Socket#35320229 (SetSocketOption) optionLevel:IPv6 optionName:IPv6Only optionValue:0
11:14:08.2434 ConsoleApp1 (47722.47739) Network/SocketInfo info [/#47722/1/59/] Socket#35320229 (SetSocketOption) SetSockOpt returns errorCode:Success
11:14:08.2434 ConsoleApp1 (47722.47739) Network/SocketInfo info [/#47722/1/59/] Socket#35320229 (SetSocketOption) optionLevel:Tcp optionName:NoDelay optionValue:1
11:14:08.2434 ConsoleApp1 (47722.47739) Network/SocketInfo info [/#47722/1/59/] Socket#35320229 (SetSocketOption) SetSockOpt returns errorCode:Success
11:14:08.2437 ConsoleApp1 (47722.47739) Network/SocketConnectedAsyncDns info [/#47722/1/59/] Socket#35320229
11:14:08.2438 ConsoleApp1 (47722.47739) Loader/AssemblyLoadStart info [/#47722/1/59/18/] name: 'System.Net.NameResolution, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a',requested by: 'System.Net.Sockets, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'
11:14:08.2439 ConsoleApp1 (47722.47739) Loader/KnownPathProbed info [/#47722/1/59/18/] '/usr/share/dotnet/shared/Microsoft.NETCore.App/8.0.5/System.Net.NameResolution.dll' source: Microsoft.Diagnostics.Tracing.EventPipeEventSource, runtime: #0
11:14:08.2439 ConsoleApp1 (47722.47739) Loader/ResolutionAttempted error [/#47722/1/59/18/] message: 'Could not locate assembly', stage: FindInLoadContext
11:14:08.2439 ConsoleApp1 (47722.47739) Loader/ResolutionAttempted info [/#47722/1/59/18/] '/usr/share/dotnet/shared/Microsoft.NETCore.App/8.0.5/System.Net.NameResolution.dll' stage: ApplicationAssemblies
11:14:08.2439 ConsoleApp1 (47722.47739) Loader/AssemblyLoadFinished info [/#47722/1/59/18/] name: 'System.Net.NameResolution, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a', requested by: 'System.Net.Sockets, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a', duration: 0.088ms
11:14:08.2440 ConsoleApp1 (47722.47739) Loader/DomainModuleLoad info [/#47722/1/59/] '/usr/share/dotnet/shared/Microsoft.NETCore.App/8.0.5/System.Net.NameResolution.dll' module type: managed
11:14:08.3017 ConsoleApp1 (47722.47741) Loader/AssemblyLoadStart info [/#47722/1/59/19/] name: 'System.Runtime.Intrinsics, Version=, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51',requested by: 'System.Net.Primitives, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'
Unhandled exception. System.Threading.Tasks.TaskCanceledException: The request was canceled due to the configured HttpClient.Timeout of 5 seconds elapsing.


Kernel: 6.9.3-1-cachyos arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
clocksource: tsc avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-cachyos
root=UUID=b3842975-a07f-4abe-a1f6-66b8fcf79638 rw rootflags=subvol=@
quiet loglevel=3 ibt=off
Desktop: KDE Plasma v: 6.0.5 tk: Qt v: N/A info: frameworks v: 6.2.0
wm: kwin_x11 vt: 2 dm: SDDM Distro: Garuda base: Arch Linux
Type: Laptop System: Acer product: Predator PH315-53 v: V2.04
serial: <superuser required>
Mobo: CML model: QX50_CMS v: V2.04 serial: <superuser required>
part-nu: 0000000000000000 uuid: <superuser required> UEFI: Insyde v: 2.04
date: 08/20/2021
ID-1: BAT1 charge: 40.7 Wh (100.0%) condition: 40.7/58.8 Wh (69.2%)
volts: 16.4 min: 15.4 model: SMP AP18E7M type: Li-ion serial: <filter>
status: full
Info: model: Intel Core i7-10750H bits: 64 type: MT MCP arch: Comet Lake
gen: core 10 level: v3 note: check built: 2020 process: Intel 14nm family: 6
model-id: 0xA5 (165) stepping: 2 microcode: 0xFA
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
L3: 12 MiB desc: 1x12 MiB
Speed (MHz): avg: 1714 high: 2101 min/max: 800/5000 scaling:
driver: intel_pstate governor: powersave cores: 1: 2100 2: 800 3: 2100
4: 2101 5: 800 6: 2099 7: 2100 8: 2070 9: 2101 10: 800 11: 1956 12: 1543
bogomips: 62399
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: Acer Incorporated ALI
driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
ports: active: none off: eDP-1 empty: HDMI-A-2 bus-ID: 00:02.0
chip-ID: 8086:9bc4 class-ID: 0300
Device-2: NVIDIA TU106M [GeForce RTX 2060 Mobile]
vendor: Acer Incorporated ALI driver: nvidia v: 550.78
alternate: nouveau,nvidia_drm non-free: 550.xx+ status: current (as of
2024-04; EOL~2026-12-xx) arch: Turing code: TUxxx process: TSMC 12nm FF
built: 2018-2022 pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3
speed: 8 GT/s ports: active: none off: HDMI-A-1 empty: DP-1
bus-ID: 01:00.0 chip-ID: 10de:1f15 class-ID: 0300
Device-3: Quanta HD User Facing driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-5:3 chip-ID: 0408:a061
class-ID: 0e02
Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 24.1.0
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia unloaded: nouveau
alternate: fbdev,intel,nv,vesa dri: iris gpu: i915,nvidia,nvidia-nvswitch
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: HDMI-A-1 mapped: HDMI-1-0 note: disabled pos: primary
model: Samsung serial: <filter> built: 2016 res: 1920x1080 hz: 60 dpi: 40
gamma: 1.2 size: 1210x680mm (47.64x26.77") diag: 1168mm (46") ratio: 16:9
modes: max: 1920x1080 min: 640x480
Monitor-2: eDP-1 note: disabled model: AU Optronics 0x82ed built: 2018
res: 1920x1080 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
diag: 394mm (15.5") ratio: 16:9 modes: 1920x1080
API: EGL v: 1.5 hw: drv: intel iris drv: nvidia platforms: device: 0
drv: nvidia device: 2 drv: iris device: 3 drv: swrast gbm: drv: nvidia
surfaceless: drv: nvidia x11: drv: iris inactive: wayland,device-1
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 24.1.0-arch1.1.1
glx-v: 1.4 direct-render: yes renderer: Mesa Intel UHD Graphics (CML GT2)
device-ID: 8086:9bc4 memory: 7.54 GiB unified: yes
API: Vulkan v: 1.3.285 layers: 8 device: 0 type: integrated-gpu name: Intel
UHD Graphics (CML GT2) driver: mesa intel v: 24.1.0-arch1.1.1
device-ID: 8086:9bc4 surfaces: xcb,xlib device: 1 type: discrete-gpu
name: NVIDIA GeForce RTX 2060 driver: nvidia v: 550.78
device-ID: 10de:1f15 surfaces: xcb,xlib device: 2 type: cpu name: llvmpipe
(LLVM 17.0.6 256 bits) driver: mesa llvmpipe v: 24.1.0-arch1.1.1 (LLVM
17.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Device-1: Intel Comet Lake PCH cAVS vendor: Acer Incorporated ALI
driver: snd_hda_intel v: kernel alternate: snd_soc_skl, snd_soc_avs,
snd_sof_pci_intel_cnl bus-ID: 00:1f.3 chip-ID: 8086:06c8 class-ID: 0403
Device-2: NVIDIA TU106 High Definition Audio vendor: Acer Incorporated ALI
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:10f9 class-ID: 0403
Device-3: Texas Instruments PCM2900B Audio CODEC
driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 2.0 speed: 12 Mb/s
lanes: 1 mode: 1.1 bus-ID: 1-1.3:6 chip-ID: 08bb:29b0 class-ID: 0300
API: ALSA v: k6.9.3-1-cachyos status: kernel-api tools: N/A
Server-1: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Comet Lake PCH CNVi WiFi vendor: Rivet Networks Dual Band
Wi-Fi 6 Killer AX1650i 160MHz 2x2 driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:06f0 class-ID: 0280
IF: wlp0s20f3 state: up mac: <filter>
Device-2: Realtek Killer E2600 GbE vendor: Acer Incorporated ALI
driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000
bus-ID: 08:00.0 chip-ID: 10ec:2600 class-ID: 0200
IF: enp8s0 state: down mac: <filter>
Info: services: NetworkManager, smbd, systemd-timesyncd, wpa_supplicant
Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-14:5 chip-ID: 8087:0026
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
rfk-block: hardware: no software: yes address: <filter> bt-v: 5.2 lmp-v: 11
status: discoverable: no pairing: no
Local Storage: total: 6.83 TiB used: 647.39 GiB (9.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN730
SDBQNTY-512G-1014 size: 476.94 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 11101100 temp: 73.8 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:2 vendor: Western Digital
model: WD Blue SN570 2TB size: 1.82 TiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 234200WD temp: 39.9 C scheme: GPT
ID-3: /dev/sda maj-min: 8:0 vendor: HGST (Hitachi) model: HTS721010A9E630
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: HDD rpm: 7200 serial: <filter> fw-rev: A3J0 scheme: GPT
ID-4: /dev/sdb maj-min: 8:16 vendor: Western Digital
model: WD40NDZW-11A8JS1 size: 3.64 TiB block-size: physical: 4096 B
logical: 512 B type: USB rev: 3.2 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1
tech: HDD rpm: 5400 serial: <filter> fw-rev: 1023 scheme: GPT
ID-1: / raw-size: 781.15 GiB size: 781.15 GiB (100.00%)
used: 376.34 GiB (48.2%) fs: btrfs dev: /dev/nvme1n1p1 maj-min: 259:3
ID-2: /boot/efi raw-size: 301 MiB size: 300.4 MiB (99.79%)
used: 584 KiB (0.2%) fs: vfat dev: /dev/nvme1n1p3 maj-min: 259:5
ID-3: /home raw-size: 781.15 GiB size: 781.15 GiB (100.00%)
used: 376.34 GiB (48.2%) fs: btrfs dev: /dev/nvme1n1p1 maj-min: 259:3
ID-4: /var/log raw-size: 781.15 GiB size: 781.15 GiB (100.00%)
used: 376.34 GiB (48.2%) fs: btrfs dev: /dev/nvme1n1p1 maj-min: 259:3
ID-5: /var/tmp raw-size: 781.15 GiB size: 781.15 GiB (100.00%)
used: 376.34 GiB (48.2%) fs: btrfs dev: /dev/nvme1n1p1 maj-min: 259:3
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.45 GiB used: 178.5 MiB (1.1%)
priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 12
dev: /dev/zram0
ID-2: swap-2 type: partition size: 11.72 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme1n1p2 maj-min: 259:4
System Temperatures: cpu: 55.0 C pch: 79.0 C mobo: N/A
Fan Speeds (rpm): N/A
Memory: total: 16 GiB available: 15.45 GiB used: 5.74 GiB (37.2%)
Processes: 370 Power: uptime: 14h 36m states: freeze,mem,disk
suspend: deep avail: s2idle wakeups: 0 hibernate: platform avail: shutdown,
reboot, suspend, test_resume image: 6.14 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
tool: systemctl
Packages: pm: pacman pkgs: 1655 libs: 447 tools: octopi,pamac,paru
Compilers: gcc: 14.1.1 Shell: garuda-inxi default: fish v: 3.7.1
running-in: konsole inxi: 3.3.34
Garuda (2.6.26-1):
System install date:     2024-05-30
Last full system update: 2024-06-01 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       No/Undetected
Failed units:

(really didn’t do much since last reboot)

↻ = reboot needed, it’s KDE :slight_smile:

From template

  • After rebooting, post the FULL output of garuda-inxi in the body of the post (not linked externally, or collapsed with the “hide details” feature)


Make sure you have done the following before you post:

  • Show us the results of your searches, and what you’ve tried

In case nobody has mentioned it yet.

This forum is not a general technical support forum.


I can assure you I’ve done plenty of research on this issue!

curl works, server works. Reinstalled Garuda OS from scratch. Made sure Docker is not installed.

Setting this before the call does not help either.

System.Net.ServicePointManager.SecurityProtocol = SecurityProtocolType.Tls12;

Connectivity is a plain simple fiber optic connection at home, with no special DNS or proxy configuration. I made no firewall configuration since a fresh install.

Chat GPT has no clue. Ran trace to see details, not much useful.

I really don’t know where to take it from here.

This also affects apps that I deployed into the AUR. Could you install player432hz-appimage from the AUR, and in the About page, tell me whether “Checking for updates…” jams there or not? It’s jamming there on my new system install. If it jams also for other Garuda users, there might be a bigger issue going on.

ACTUALLY let me do just that: boot from USB and try there in the Live Environment.

I cannot install apps there with pacman (cannot install dotnet) but can run self-contained AppImage files. Player432Hz is jamming on the outbound connection in the live environment! It’s really starting to point to a Garuda issue.

I could go one step further, compile the minimal console app as self-contained, to then test in the Live Environment boot, but I’m expecting the same outcome but you could use it to diagnose.

As unlikely as it sounds…


Reproduced with clean app on clean USB boot.

EDIT: reproduced on Manjaro Live Boot and Fedora Live Boot…

How to reproduce:

  1. Boot from Garuda USB (with latest image)

  2. Connect to the internet

  3. Download ConsoleApp1

It is a .NET 8 app that contains this code only. Published as self-contained.

var website = "http://www.perdu.com";
Console.WriteLine($"Querying {website}...");
using var client = new HttpClient();
client.Timeout = TimeSpan.FromSeconds(5);
var value = await client.GetStringAsync(website);
  1. Execute the clean app on the clean environment.


Querying http://www.perdu.com...
Unhandled exception. System.Threading.Tasks.TaskCanceledException: The request was canceled due to the configured HttpClient.Timeout of 5 seconds elapsing.

If a clean app on a clean environment does not work, there is nothing else I can do on my end.

The problem is not with Garuda but with you:

You blame all the issues you have on others, either on KDE, Garuda or Linux in general - just not on yourself…
@tbg pointed this out to you in one of your last topics and so did @BluishHumility. Now you’ll hear the same from me:

Runtime Error 6D at 417A:32CF: Incompetent User



Can you try ConsoleApp1 ?

Why would it work for you, and not from a clean USB boot?

No I won’t. You’re wasting tons of community time, take care of yourself.

1 Like

Your comments are inappropriate and putting a bad reputation on the community.

This is a proper bug report, properly investigated and properly reproduced in a clean environment. Booting from the latest ISO image discards any user configuration or user problem.

Trash-talking is way out of place.

Unfortunately re-installing my system fixed few of the issues I was having. Most are minor and can be ignored, but this one is a deal-breaker.

Please let me know whether there are plans to look into this. If this gets ignored, I must look for a different distro.

You don’t want to understand, do you?

It all started because you ignored small issues over a long period of time instead of solving them right away. This added up until you had a system that no longer worked properly - including hardware problems and BIOS issues. Then you dumped all the problems that had accumulated into one topic.
After that, you reinstalled Garuda and, at the first small problem, opened a new topic in a panic instead of reading through the error messages and reacting accordingly.
And no matter what, every time a small problem occurs, the first thing you suspect is that it’s Linux.
Linux should tell you that faulty booting is due to incorrect BIOS settings, Linux should tell you that Intel Optane is not supported in Linux, Linux should tell you that your mobo manufacturer MSI has implemented stupid BIOS settings that can only be changed using a key combination. And these are just a few examples that run through your last 5 topics.
And you constantly assume that there are general bugs in Garuda Linux - and in this topic again. It’s commendable that you have a production machine and a development machine - but what you don’t have is a testing machine ← next user error.

Very few of your issues have anything to do with Linux, KDE or Garuda, it’s because you don’t have enough knowledge. And that in turn is the reason why you don’t have your IT under control.

You also constantly ignore the forum rules, one issue per topic is a foreign word to you. Then you start writing long answers that are completely off topic. Your thread about the issues with davinci resolve is the next “my car won’t run, what to do?” topic…zero information about what you’ve already tried to solve the problem.

@SGS pointed you to the topic template again in his post above - and you ignored everything again.

The question arises as to who is bringing the community into disrepute :wink:


Is the reboot absolutely 100% necessary if I know it was for a very minor thing that has nothing to do with the issue?

I’ve done weeks of searching, and posted to results of a lot of things I tried so far.

It all started because you ignored small issues over a long period of time instead of solving them right away.

This problem has nothing to do with my setup, as it persists on a Live Boot environment with the latest image.

In fact, the majority of the small issues I was having persisted a clean re-install, but are just generally ignored by the community.

This particular deal-breaker, I could not find any information about it online whatsoever. Because it affects specifically a little-known OS, even from a Live Boot, and thus nobody else experienced it.

This is starting to look like a values mismatch. I need something that works out-of-the-box. Spending too much time debugging Linux issues drastically reduces business productivity and focus, and I’m 10000% saturated.

but what you don’t have is a testing machine ← next user error.

Common give me a break. I just re-installed the entire server, migrating from a very old installation to a fully docker-based deployment. Setting up a test server would be the next step but not a priority at the moment.

Please, use M$ or Apple.

I guess people who know how to use Linux and Windows software don’t give free support in a Linux forum.


No thanks. But I don’t understand how bug reports are looked down upon in this community. As a result issues just don’t get fixed and persist over time. Even one as serious as the .NET connectivity issue; which probably very few Garuda users use.

I think that by now most of us in this community are weary of your near-flood of Topics Going Nowhere (TGN). As far as I’ve been able to read, all of your problems come from only one place…


1 Like


We cannot fix every existing software bug that is in any application that we have not programmed.
Is that so difficult to understand?

Here is the Garuda Linux Forum. Over and out.


I am going to try and be tactful, and attempt to not pile on unnecessarily. However, your above statements point to your distros intended role as a large part of your problem.

You are running a business and are using Garuda in a server role. Garuda uses mostly near cutting edge software and requires very frequent updates being a rolling distro based on Arch.

Running Garuda in a business server role, you are using far different software than the average Garuda user in a very different use case. While you certainly can configure and use Arch or any of its varients as a business server, I think most people would advise against this.

Rolling distros constituent components simply change far too frequently to offer the rock solid stability of a static distro intended for use on a business server. There is a reason why large businesses rely on static Linux distros intended for enterprise servers. These distros intended for servers change very little over many years and therefore offer many years of support. The more frequently the software is updated, the higher the chances of introducing bugs or encountering breakages.

If you are looking for stability running a business server, you should probably be running a distro designed and intended for this as its primary role. Garuda was neither designed nor intended to be used in a business server role. I think most people would agree that an Arch based rolling distro is not the best choice for stability in a business server capacity.

Perhaps you are simply attempting to make a square peg fit in a round hole.


I have reopened this thread so that @Hanuman has an opportunity to correct a misunderstanding regarding his server’s configuration.

Correction: I do not use Garuda as a server. Server is Debian. I use Garuda as a development machine. It worked fine for years.