Need to change UID to 1000 from 1001

Looks like this might have to do with creating the new user a couple of weeks back. I’m now 1001 which I should of realized and changed to 1000. I’ve just gone through post here and on LinuxQuestions and I’m not seeing anything that would walk me through safely removing locusus and then changing cccp to 1000 instead of 1001.

   ~  cat /etc/passwd|grep 1000                                           ✔  08:15:26 AM 
   ~  cat /etc/passwd|grep 1001                                           ✔  08:15:31 AM 
   ~                                                                      ✔  08:15:43 AM 
   ~  garuda-inxi                                                         ✔  08:20:25 AM 
Kernel: 6.9.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
clocksource: tsc avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=67fa465d-cdbb-4ff0-b9b7-9ddf6577d903 rw rootflags=subvol=@
quiet loglevel=3 ibt=off
Desktop: KDE Plasma v: 6.1.2 tk: Qt v: N/A info: frameworks v: 6.3.0
wm: kwin_x11 with: krunner vt: 2 dm: SDDM Distro: Garuda base: Arch Linux
Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
Mobo: ASUSTeK model: TUF GAMING B550-PLUS WIFI II v: Rev X.0x
serial: <superuser required> part-nu: SKU uuid: <superuser required>
UEFI: American Megatrends v: 3405 date: 12/13/2023
Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard K360
serial: <filter> charge: 100% (should be ignored) rechargeable: yes
status: discharging
Info: model: AMD Ryzen 7 5700X bits: 64 type: MT MCP arch: Zen 3+ gen: 4
level: v3 note: check built: 2022 process: TSMC n6 (7nm) family: 0x19 (25)
model-id: 0x21 (33) stepping: 2 microcode: 0xA20120E
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
L3: 32 MiB desc: 1x32 MiB
Speed (MHz): avg: 3464 high: 3656 min/max: 2200/4662 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3400 2: 3593
3: 3400 4: 3400 5: 3400 6: 3656 7: 3596 8: 3400 9: 3400 10: 3400 11: 3591
12: 3400 13: 3400 14: 3400 15: 3592 16: 3400 bogomips: 108592
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3
Vulnerabilities: <filter>
Device-1: NVIDIA GA106 [GeForce RTX 3060 Lite Hash Rate] vendor: ASUSTeK
driver: nvidia v: 555.58.02 alternate: nouveau,nvidia_drm non-free: 550.xx+
status: current (as of 2024-06; EOL~2026-12-xx) arch: Ampere code: GAxxx
process: TSMC n7 (7nm) built: 2020-2023 pcie: gen: 4 speed: 16 GT/s
lanes: 16 ports: active: none off: HDMI-A-1 empty: DP-1,DP-2,DP-3
bus-ID: 0a:00.0 chip-ID: 10de:2504 class-ID: 0300
Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 24.1.0
compositor: kwin_x11 driver: gpu: nvidia,nvidia-nvswitch display-ID: :0
screens: 1
Screen-1: 0 s-res: 2560x1080 s-dpi: 97 s-size: 670x283mm (26.38x11.14")
s-diag: 727mm (28.63")
Monitor-1: HDMI-A-1 mapped: HDMI-0 note: disabled model: AOC Q2963
serial: <filter> built: 2016 res: 2560x1080 hz: 60 dpi: 97 gamma: 1.2
size: 673x284mm (26.5x11.18") diag: 730mm (28.8") modes: max: 2560x1080
min: 640x480
API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 2
drv: swrast gbm: drv: nvidia surfaceless: drv: nvidia x11: drv: nvidia
inactive: wayland,device-1
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 555.58.02
glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce RTX 3060/PCIe/SSE2
memory: 11.72 GiB
API: Vulkan v: 1.3.279 layers: 1 device: 0 type: discrete-gpu
name: NVIDIA GeForce RTX 3060 driver: nvidia v: 555.58.02
device-ID: 10de:2504 surfaces: xcb,xlib
Device-1: NVIDIA GA106 High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 0a:00.1 chip-ID: 10de:228e class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 0c:00.4 chip-ID: 1022:1487 class-ID: 0403
API: ALSA v: k6.9.7-zen1-1-zen status: kernel-api tools: N/A
Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
Server-2: PipeWire v: 1.2.0 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 1 bus-ID: 07:00.0 chip-ID: 8086:2723 class-ID: 0280
IF: wlp7s0 state: down mac: <filter>
Device-2: Realtek RTL8125 2.5GbE vendor: ASUSTeK driver: r8169 v: kernel
pcie: gen: 2 speed: 5 GT/s lanes: 1 port: f000 bus-ID: 09:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: enp9s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Info: services: NetworkManager, smbd, sshd, systemd-timesyncd,
Device-1: IMC Networks Wireless_Device driver: btusb v: 0.8 type: USB
rev: 2.1 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-5:3 chip-ID: 13d3:3563
class-ID: e001 serial: <filter>
Report: btmgmt ID: hci0 rfk-id: 1 state: up address: <filter> bt-v: 5.2
lmp-v: 11 status: discoverable: no pairing: no class-ID: 6c0104
Device-2: Intel AX200 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-7.4:11 chip-ID: 8087:0029
class-ID: e001
Report: ID: hci1 rfk-id: 2 state: up address: <filter> bt-v: 5.2 lmp-v: 11
status: discoverable: no pairing: no class-ID: 6c0104
Local Storage: total: 26.83 TiB used: 18.03 TiB (67.2%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Crucial model: CT1000T500SSD8
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: P8CR002 temp: 31.9 C
scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:5 vendor: Crucial model: CT500P3SSD8
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: P9CR30A temp: 27.9 C
scheme: GPT
ID-3: /dev/sda maj-min: 8:0 vendor: Seagate model: Expansion HDD
size: 7.28 TiB block-size: physical: 4096 B logical: 512 B type: USB
rev: 3.2 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: N/A serial: <filter>
fw-rev: 1801 scheme: GPT
ID-4: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST8000AS0002-1NA17Z
size: 7.28 TiB block-size: physical: 4096 B logical: 512 B type: USB
rev: 3.0 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: HDD rpm: 5980
serial: <filter> scheme: GPT
ID-5: /dev/sdc maj-min: 8:32 vendor: Seagate model: Expansion HDD
size: 10.91 TiB block-size: physical: 4096 B logical: 512 B type: USB
rev: 3.2 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: N/A serial: <filter>
fw-rev: 0003 scheme: GPT
ID-1: / raw-size: 232.8 GiB size: 232.8 GiB (100.00%)
used: 64.22 GiB (27.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 1.7 MiB (0.6%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 232.8 GiB size: 232.8 GiB (100.00%)
used: 64.22 GiB (27.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 232.8 GiB size: 232.8 GiB (100.00%)
used: 64.22 GiB (27.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 232.8 GiB size: 232.8 GiB (100.00%)
used: 64.22 GiB (27.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 46.96 GiB used: 31.5 MiB (0.1%)
priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16
dev: /dev/zram0
System Temperatures: cpu: 42.9 C mobo: N/A gpu: nvidia temp: 40 C
Fan Speeds (rpm): N/A gpu: nvidia fan: 0%
Memory: total: 48 GiB available: 46.96 GiB used: 9.01 GiB (19.2%)
Processes: 547 Power: uptime: 2h 27m states: freeze,mem,disk suspend: deep
avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 18.74 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 256 default: graphical
tool: systemctl
Packages: 1838 pm: pacman pkgs: 1832 libs: 468 tools: pacseek,pikaur,yay
pm: flatpak pkgs: 6 pm: snap pkgs: 0 Compilers: clang: 17.0.6 gcc: 14.1.1
Shell: garuda-inxi default: Zsh v: 5.8 running-in: konsole inxi: 3.3.35
Garuda (2.6.26-1):
System install date:     2024-07-05
Last full system update: 2024-07-05
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       No/Undetected
Failed units:

I have not used this method since Garuda first began 4 years ago, but I assume it likely still applies. Initially Garuda was configured with with a guest account that used the 1000 UID & GID. I found the guest account superfluous, as well as I always configured my own user account as 1000 on all my Linux systems. Having the same account username, GID, and UID simplifies sharing amongst my various Linux computers. Therefore I needed to remove the guest account and reasign the 1000 UID & GID to my usual account name. After removing the guest account, I used the following procedure to change my user account UID & GID to 1000:

Power down your computer completely, then restart. Do not login to your desktop session, instead switch to a TTY. Press CTRL+ALT+F3 to get to TTY3, then login as root (not your user account):

On the root account enter the following commands:

usermod -u 1000 <user>
groupmod -g 1000 <user>

In the above commands, you must substitute the account username you wish to assign to 1000 in place of <user>.


usermod -u 1000 locutus
groupmod -g 1000 locutus

After successfully reasigning the UID & GID, switch back to the login screen with CTRL+ALT+F1. Then login under your normal desktop user account that should now be reassigned to 1000.

To be sure the procedure worked, you can double check on your relevant account details. To check that the UID/GID and file ownerships for your user account have been reset properly:

ls -l /home/$USER
id -u ls -l /home/$USER
id -g ls -l /home/$USER
grep $USER /etc/passwd
grep $USER /etc/group

It’s been quite a while since I’ve had to reset my account, but I assume this method still works properly.

1 Like

I’m assuming type root then my password when prompted. I ask cause the passwords are the same.

I had to do this in the past cause at one time Garuda had the main admin account as 1001 which was no big deal unless you were multi-booting.

That should be the correct way if both passwords are the same.

I suggest you rename your thread to somemething more relevant.

1 Like

Give me 2 mins to rename it then just please remove the first post if possible and I’ll edit the second post so it makes more sense. Thanks

I’m not 100% sure I can delete your first post, as I believe that’s the same as deleting the thread. Perhaps simply edit your opening post to be more appropriate.

OK ran into a couple of issues I can’t seem to resolve. I go into SDDM to uncheck autologin and it’s already unchecked. I tried to check it and hit apply so I could then uncheck and hit apply to see if toggling it would fix it but the apply button stays grayed out. The second issue is I went ahead and logged out and attempted to login as root and I Couldn’t.

I’m willing to bet that the root password isthe same as the one for the locutus user that I removed, and not the one for cccp.

You’ve managed to get yourself into a pickle that I’ve never encountered myself. I would read the Arch Wiki entries carefully on creating and deleting user accounts and I’m sure you will find a workaround to fix up this mess if you do some in depth searching.


I believe the best workaround would be for the Plasma devs to disassociate SDDM from KWallet. I’m very sure it’s what’s at the heart of this problem, I’m sure of that. I always disable KWallet cause I personally find it useless. As for the password I’m pretty sure I’m right about that which I will test later.

I’m going to also run a test and add back a secondary user (non admin) and temp enable KWallet to see if I’n right. Thanks for all the input and help.

Adding a secondary standard account was all I needed to fix the SDDM issue. Now on to the UID GID.

I decided to cheat. I created a new Admin user in Cachy and removed the original. It made sense since the last update there brought back that stupid issue with the shrunken wallpaper and only having access to my panels on the main desktop. The same reason it was suggested to me to create a new admin user in Garuda. I don’t know what the KDE devs but in my book they screwed the pooch with that one.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.