Need help with changing taskbar behaviour similar to windows and desktop

Hello, fellow users of Garuda forum. I searched all over the web for these issues and i cannot find any tutorials or anyone mentioning solutions that would help my case. I minimize my tasks and i have to alt+tab to switch back to them. Now i know i can change key settings to my liking. The thing i would like to change is when i minimize lets say brave browser i would like it it to open back up when i click on the icon in my task bar. I tried changing my setting to let me have only 1 brave open, but that doesn’t work. It would be really helpful if i didn’t have to alt+tab or whatever to juggle between my tasks. Is there any option that allows for similar behaviour as windows has ? I tried contacting a few youtubers that i had seen have this enabled, but no one really responded. How can i make it, so my programs open back up when i click on them. And is there any way to make taskbar icons appear different when programs are already running, but are minimized ? I would also like to know if there is any way to make desktop usable ? I cannot copy anything on it. It just opens setting for visual changes, etc. I have some files in my desktop directory, but they are not visable unless i’m in the desktop directory. This would really help me speed up file transfer and sorting.

  Kernel: 6.8.9-zen1-2-zen arch: x86_64 bits: 64 compiler: gcc v: 14.1.1 clocksource: tsc
    avail: hpet,acpi_pm parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=b58c058b-2bff-4086-96d2-a19d53deca95 rw rootflags=subvol=@ quiet loglevel=3 ibt=off
  Desktop: KDE Plasma v: 6.0.4 tk: Qt v: N/A info: frameworks v: 6.1.0 wm: kwin_x11 vt: 2
    dm: SDDM Distro: Garuda base: Arch Linux
  Type: Desktop Mobo: Micro-Star model: Z390-A PRO (MS-7B98) v: 1.0 serial: <superuser required>
    uuid: <superuser required> UEFI: American Megatrends v: 1.10 date: 08/22/2018
  Info: model: Intel Core i7-9700KF bits: 64 type: MCP arch: Coffee Lake gen: core 9 level: v3
    note: check built: 2018 process: Intel 14nm family: 6 model-id: 0x9E (158) stepping: 0xC (12)
    microcode: 0xF6
  Topology: cpus: 1x cores: 8 smt: <unsupported> cache: L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB
    L2: 2 MiB desc: 8x256 KiB L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 4600 min/max: 800/4900 scaling: driver: intel_pstate governor: performance
    cores: 1: 4600 2: 4600 3: 4600 4: 4600 5: 4600 6: 4600 7: 4600 8: 4600 bogomips: 57600
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: NVIDIA TU106 [GeForce RTX 2070] vendor: Micro-Star MSI driver: nvidia v: 550.78
    alternate: nouveau,nvidia_drm non-free: 550.xx+ status: current (as of 2024-04; EOL~2026-12-xx)
    arch: Turing code: TUxxx process: TSMC 12nm FF built: 2018-2022 pcie: gen: 3 speed: 8 GT/s
    lanes: 16 ports: active: none off: DP-1 empty: DP-2,DP-3,HDMI-A-1 bus-ID: 01:00.0
    chip-ID: 10de:1f02 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 23.2.6 compositor: kwin_x11 driver: X:
    loaded: nvidia unloaded: modesetting,nouveau alternate: fbdev,nv,vesa gpu: nvidia,nvidia-nvswitch
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2560x1440 s-dpi: 92 s-size: 707x393mm (27.83x15.47") s-diag: 809mm (31.85")
  Monitor-1: DP-1 mapped: DP-0 note: disabled model: AOC Q32G2WG3 serial: <filter> built: 2023
    res: 2560x1440 hz: 60 dpi: 93 gamma: 1.2 size: 700x390mm (27.56x15.35") diag: 800mm (31.5")
    ratio: 16:9 modes: max: 2560x1440 min: 640x480
  API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 2 drv: swrast gbm:
    drv: nvidia surfaceless: drv: nvidia x11: drv: nvidia inactive: wayland,device-1
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 550.78 glx-v: 1.4 direct-render: yes
    renderer: NVIDIA GeForce RTX 2070/PCIe/SSE2 memory: 7.81 GiB
  API: Vulkan v: 1.3.279 layers: 14 device: 0 type: discrete-gpu name: NVIDIA GeForce RTX 2070
    driver: nvidia v: 550.78 device-ID: 10de:1f02 surfaces: xcb,xlib device: 1 type: cpu
    name: llvmpipe (LLVM 17.0.6 256 bits) driver: mesa llvmpipe v: 24.0.6-arch1.2 (LLVM 17.0.6)
    device-ID: 10005:0000 surfaces: xcb,xlib
  Device-1: Intel Cannon Lake PCH cAVS vendor: Micro-Star MSI driver: snd_hda_intel v: kernel
    alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3 chip-ID: 8086:a348 class-ID: 0403
  Device-2: NVIDIA TU106 High Definition Audio vendor: Micro-Star MSI driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:10f9 class-ID: 0403
  API: ALSA v: k6.8.9-zen1-2-zen status: kernel-api with: aoss type: oss-emulator tools: N/A
  Server-1: PipeWire v: 1.0.6 status: active with: 1: pipewire-pulse status: active
    2: wireplumber status: active 3: pipewire-alsa type: plugin 4: pw-jack type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Ethernet I219-V vendor: Micro-Star MSI driver: e1000e v: kernel port: N/A
    bus-ID: 00:1f.6 chip-ID: 8086:15bc class-ID: 0200
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Info: services: NetworkManager,systemd-timesyncd
  Local Storage: total: 10.96 TiB used: 4.4 TiB (40.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: SNV2S2000G size: 1.82 TiB block-size:
    physical: 512 B logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: SBM02103 temp: 34.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Kingston model: SKC6002048G size: 1.86 TiB block-size:
    physical: 4096 B logical: 512 B speed: 6.0 Gb/s tech: SSD serial: <filter> fw-rev: 0113
    scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST8000NT001-3LZ101 size: 7.28 TiB
    block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 7200 serial: <filter>
    fw-rev: EN01 scheme: GPT
  ID-1: / raw-size: 1.82 TiB size: 1.82 TiB (100.00%) used: 335.39 GiB (18.0%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 584 KiB (0.2%) fs: vfat
    dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 1.82 TiB size: 1.82 TiB (100.00%) used: 335.39 GiB (18.0%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 1.82 TiB size: 1.82 TiB (100.00%) used: 335.39 GiB (18.0%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 1.82 TiB size: 1.82 TiB (100.00%) used: 335.39 GiB (18.0%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 31.28 GiB used: 0 KiB (0.0%) priority: 100 comp: zstd
    avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 8 dev: /dev/zram0
  System Temperatures: cpu: 49.0 C pch: 45.0 C mobo: N/A gpu: nvidia temp: 39 C
  Fan Speeds (rpm): N/A gpu: nvidia fan: 17%
  Memory: total: 32 GiB available: 31.28 GiB used: 5.01 GiB (16.0%)
  Processes: 308 Power: uptime: 5h 37m states: freeze,mem,disk suspend: deep avail: s2idle
    wakeups: 0 hibernate: platform avail: shutdown, reboot, suspend, test_resume image: 12.47 GiB
    services: org_kde_powerdevil, power-profiles-daemon, upowerd Init: systemd v: 255
    default: graphical tool: systemctl
  Packages: pm: pacman pkgs: 2061 libs: 557 tools: octopi,paru pm: flatpak pkgs: 0 Compilers:
    clang: 17.0.6 gcc: 14.1.1 Client: shell wrapper v: 5.2.26-release inxi: 3.3.34
Garuda (2.6.26-1):
  System install date:     2024-04-25
  Last full system update: 2024-05-10 ↻
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut nvidia-dkms
  Windows dual boot:       No/Undetected
  Failed units:            

Which global theme are you using, Dr460nized or a different one?

1 Like

if you right click on the the icons in the taskbar you can pick, configure icons only task bar there might be some settings in there for you. setting it to do not group might be what you want

On videos you watch kinda make sure there from kde 6 if you can cause unless the developer has upgraded the widget/addon its likely it wont work.


I am using Noir Dark theme 6.

How do i get into this settings window ? For the god of me i cannot find it…

Switch the global theme back to Dr460nized and check if your desktop works without issues.


it doesn’t

Did you reboot after changing the global theme? If not, try it.
KDE loves this.


Where ever your dock icons are R click on them. You can also do the same by clicking enter edit mode and the panel an hovering over the icons a config window will pop up.

-my dock is set up a bit different so if i don’t have a app open there is nothing in the dock other then 1 icon for the app launcher.




1 Like

I think the OP has the issues because he installed the Noir Dark theme 6. His desktop now runs with the default settings of Plasma 6. By default the desktop cannot be used and the context menu looks like this:


That’s what the last image is for you right click on the panel it will bring up the option to enter edit mode click it then hover over the icons an it will pop up the config for the widget. Kde only got rid of the “add panel an add widget” for new users from the R click menu when you click on empty desktop as they now show up at the top or bottom or with the panel edit screen.

also kaos is fun i messed with it for a while

That’s not what it is about. What he describes is related to the installed theme, including:

For example:

1 Like

this is what I’m referring to

1 Like

Okay thank you. I see what you mean. I am sorry if i said it wrong. I wish to have this option, but not on dock. I want to have it on my normal taskbar without dock.

I guess i could replace taskbar with dock and remove taskbar i just wanted to know if there is an option to mimic behaviour. Now about desktop, how can i see files i have on it ? Without going into desktop directory of course.

I’ll try to give you a lil more insight on the thing, adding to what other people told you already. As you may have noticed, compared to windows, kde doesn’t offer a basically pre-built, immutable task bar. In fact: the taskbar i’t just a component of the panel, one of many and each comes with its own options. Going in the settings menu for the component you want to customize allows you to change the behavior, I’m pretty sure you can stop groups from being formed and many other things or you can get used to it by realizing that on kde is even more simple (solution to your problem would be to leave the previews active, hover with the mouse on the group and click on the specific window you want to open), if no option satisfies you in that particular task manager (I guess you are using the “icons only” one) you can remove it and look for others. Keep dragonized till you get your expected behavior (for ease to use), once you know how to get to the desired result switch themes as much as you please.

I made a quick video for ya.
For icons on the desktop as I show just make sure its in folder view. Then you can move, sort, and lock them in place same as on windows or mac with a right click on empty desktop.

Now I hope someone can chime in with what setting you need to change so that if you have a full screen window it has window decorations when the widget/top panel is removed. As have forgotten haha.

*sorry if youtube is a bit slow with the quality-


How am I supposed to know how to change the desktop to be “similar to Windows”?

The last time I had a Windows OS installed on my computer it was running Windows 7. The last version of Windows I tested on that laptop was Windows 8. Were you looking for the Windows 8 type “Metro” style of desktop? :rofl:


M$ looks like old KDE :smiley:

Everything just stolen.


You can have the taskbar in windows group icons or have a individual one for each open window. Other then that it hasn’t changed since XP :joy: