Need help with Behringer x32 install

Trying to install Behringer x32edit mixing console app on laptop.
Found the arch link, but have no idea how to install it on Garuda.
I’ve done it on Mint as a deb., but I’m Garuda newb.
Followed some of the arch install tuts, but not a clue.

https://aur.archlinux.org/packages/x32edit

inxi:

System:
  Kernel: 6.5.9-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=3c88b928-4cf2-4914-97d1-9b2c285f07b5 rw rootflags=subvol=@
    quiet loglevel=3 ibt=off
  Desktop: Cinnamon v: 5.8.4 tk: GTK v: 3.24.38 wm: muffin dm: LightDM
    v: 1.32.0 Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: Acer product: Aspire 7741 v: V1.26 serial: <filter>
  Mobo: Acer model: JE70_CP v: V1.26 serial: <filter> BIOS: Phoenix v: 1.26
    date: 04/28/2011
Battery:
  ID-1: BAT0 charge: 46.0 Wh (100.0%) condition: 46.0/45.4 Wh (101.4%)
    volts: 12.3 min: 10.8 model: Panasonic AS10D51 type: Li-ion serial: <filter>
    status: full
CPU:
  Info: model: Intel Pentium P6200 bits: 64 type: MCP arch: Westmere level: v1
    built: 2010-11 process: Intel 32nm family: 6 model-id: 0x25 (37) stepping: 5
    microcode: 0x7
  Topology: cpus: 1x cores: 2 smt: <unsupported> cache: L1: 128 KiB
    desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB L3: 3 MiB
    desc: 1x3 MiB
  Speed (MHz): avg: 2133 min/max: 933/2133 base/boost: 2130/3200 scaling:
    driver: acpi-cpufreq governor: performance volts: 3.3 V ext-clock: 100 MHz
    cores: 1: 2133 2: 2133 bogomips: 8511
  Flags: ht lm nx pae sse sse2 sse3 ssse3
  Vulnerabilities: <filter>
Graphics:
  Device-1: Intel Core Processor Integrated Graphics
    vendor: Acer Incorporated ALI driver: i915 v: kernel arch: Gen-5.75
    process: Intel 45nm built: 2010 ports: active: LVDS-1
    empty: DP-1,HDMI-A-1,VGA-1 bus-ID: 00:02.0 chip-ID: 8086:0046
    class-ID: 0300
  Device-2: Alcor Micro Acer Integrated Webcam driver: uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 2-1.5:4
    chip-ID: 058f:b002 class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.9 driver: X: loaded: modesetting
    alternate: fbdev,intel,vesa dri: crocus gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1600x900 s-dpi: 96 s-size: 423x238mm (16.65x9.37")
    s-diag: 485mm (19.11")
  Monitor-1: LVDS-1 model: AU Optronics 0x139e built: 2009 res: 1600x900
    hz: 60 dpi: 106 gamma: 1.2 size: 382x214mm (15.04x8.43") diag: 438mm (17.2")
    ratio: 16:9 modes: 1600x900
  API: Vulkan v: 1.3.269 layers: 3 device: 0 type: cpu name: llvmpipe (LLVM
    16.0.6 128 bits) driver: mesa llvmpipe v: 23.2.1-arch1.2 (LLVM 16.0.6)
    device-ID: 10005:0000 surfaces: xcb,xlib
  API: OpenGL Message: Unable to show GL data. glxinfo is missing.
Audio:
  Device-1: Intel 5 Series/3400 Series High Definition Audio
    vendor: Acer Incorporated ALI 5 driver: snd_hda_intel v: kernel
    bus-ID: 00:1b.0 chip-ID: 8086:3b56 class-ID: 0403
  API: ALSA v: k6.5.9-zen2-1-zen status: kernel-api tools: N/A
  Server-1: PipeWire v: 0.3.83 status: n/a (root, process) with:
    1: pipewire-pulse status: active 2: wireplumber status: active
    3: pipewire-alsa type: plugin 4: pw-jack type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Broadcom NetLink BCM57780 Gigabit Ethernet PCIe vendor: Acer
    Incorporated ALI Aspire 7740G driver: tg3 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: N/A bus-ID: 02:00.0 chip-ID: 14e4:1692
    class-ID: 0200
  IF: enp2s0 state: down mac: <filter>
  Device-2: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz driver: iwlwifi v: kernel
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 link-max: gen: 2 speed: 5 GT/s
    bus-ID: 04:00.0 chip-ID: 8086:2725 class-ID: 0280
  IF: wlp4s0 state: up mac: <filter>
Bluetooth:
  Device-1: Intel AX210 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 2-1.4:3 chip-ID: 8087:0032
    class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 2 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: <filter> bt-v: 5.3 lmp-v: 12
    status: discoverable: no pairing: no
Drives:
  Local Storage: total: 953.87 GiB used: 9.4 GiB (1.0%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Silicon Power
    model: SPCC Solid State Disk size: 953.87 GiB block-size: physical: 512 B
    logical: 512 B speed: 3.0 Gb/s tech: SSD serial: <filter> fw-rev: AA20
    scheme: MBR
Partition:
  ID-1: / raw-size: 97.79 GiB size: 97.79 GiB (100.00%) used: 9.4 GiB (9.6%)
    fs: btrfs block-size: 4096 B dev: /dev/sda1 maj-min: 8:1
  ID-2: /home raw-size: 97.79 GiB size: 97.79 GiB (100.00%)
    used: 9.4 GiB (9.6%) fs: btrfs block-size: 4096 B dev: /dev/sda1
    maj-min: 8:1
  ID-3: /var/log raw-size: 97.79 GiB size: 97.79 GiB (100.00%)
    used: 9.4 GiB (9.6%) fs: btrfs block-size: 4096 B dev: /dev/sda1
    maj-min: 8:1
  ID-4: /var/tmp raw-size: 97.79 GiB size: 97.79 GiB (100.00%)
    used: 9.4 GiB (9.6%) fs: btrfs block-size: 4096 B dev: /dev/sda1
    maj-min: 8:1
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 7.44 GiB used: 0 KiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 2 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 49.0 C mobo: N/A
  Fan Speeds (rpm): N/A
Info:
  Processes: 221 Uptime: 7m wakeups: 1 Memory: total: 8 GiB
  available: 7.44 GiB used: 1.61 GiB (21.7%) igpu: 128 MiB Init: systemd
  v: 254 default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
  pm: pacman pkgs: 1251 libs: 369 tools: paru Shell: garuda-inxi (sudo)
  default: Bash v: 5.1.16 running-in: gnome-terminal inxi: 3.3.30
Garuda (2.6.17-1):
  System install date:     2024-01-12
  Last full system update: 2024-01-12
  Is partially upgraded:   Yes
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       No/Undetected
  Failed units:

Please, ask the support, paid software?

https://community.musictribe.com/

no it’s not paid software.
Windows and Linux versions are free downloads, I have installed it on Linux Mint and Windows…Just clueless on Garuda.
I’s also available as: X32-Edit_LINUX_4.3.tar.gz On the Behringer site.
But can’t figure out how to install it from that either.

Always search the arch wiki, please.

Install the package

The package can now be installed with pacman:

pacman -U *package_name*-*version*-*architecture*.pkg.tar.zst

Note:

  • If you have changed your PKGEXT in makepkg.conf, the name of the package file may be slightly different.
  • The above example is only a brief summary of the build process. It is highly recommended to read the makepkg and Arch build system articles for more details.

https://wiki.archlinux.org/title/Arch_User_Repository

Read the Comments at the link you gave.

2 Likes

Doesn’t seem to work, I tried every combination of that, I do need to include the path to the file I presume, but I tried every conceivable that I could think of.
Guess I’ll have to do a lot of reading.
I like Garuda, but it’s just weird coming from Ubuntu, Debian, distro’s.

pacman -U installs an archive following the pacman package format. pacman -S installs a package from the repos.

man pacman, pacman --help

What SGS is probably trying to tell you is that you can install the archive from the behringer website via pacman -U

1 Like

did you change the name?

Just post what you did, please. Input command and the following log as text (like the inxi)

Ok I’ll do some reading and experiments…
Will post outcome.
Thanks.

Can’t look at it right now but I’ll try to remember the inputs I did.

pacman -U  /home/keith/Downloads/x32-edit.pkg.tar.zst
pacman -U  /home/user/Downloads/x32-edit.pkg.tar

went ahead and extracted then tried

pacman -U  /home/user/Downloads/x32-edit.pkg
] × sudo pacman -S https://aur.archlinux.org/packages/x32edit
error: database not found: https:
sudo pacman -S https://aur.archlinux.org/packages/x32edit

I think that is all but can’t get to machine at moment, will try anything later.

You know my adage is with “the first thing to do with new software”,
break it, so you know how to fix it. :sweat_smile:

I see it’s a package in the AUR repository, not a binary available in the Arch repo.
So you’ll have to build it, as opposed to a simple installation with pacman.
Either you use the manual instructions in the Arch wiki or use a helper. E.g.

paru x32edit

Exit from the presented PKGBUILD with button q and confirm installation.

3 Likes

Awesome, the paru x32edit worked, I just didn’t get the q and answer y for yes at the end of all the output.
Fired up just fine, Thanks…"Why don’t they include those tips?

1 Like

Because learning Garuda (Arch-based) takes a little more time than a stroll through the park.

I’ve been learning Linux for over 25 years, Arch for 10-12 years. And I am far far from having completed that task…

How about you?

4 Likes

Well, if that’s the case I think the egg was just fertilized.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.