Need help dealing with the recent xorg bug scaling up all Qt apps

So there was this stupid update pushed very recently which is creating scaling issues for everyone.

I have tried what people on internet suggested like editing the /etc/sddm.conf and setting dpi as 96 (in my case 120 looks better), but this only fixed the sddm login screen for me.

All the KDE apps ie Qt apps are still being scaled large and it's creating Huge icons and text, and in many cases blurry thumbnails and previews. GTK apps like chromium, gimp are being scaled properly.

Look at this for example : https://imgur.com/a/ghH8D2g

It's present in Dolphin, Gwenview, RSIBreak, flameshot and pretty much all Qt apps.

Now, honestly I kind of like the slightly bigger text this bug has introduced since I have a small laptop screen. But the image previews being so low resolution is annoying.

For instance, RSIBreak displays fullscreen images after the patience timer runs out. These images I have selected are 1080p and 1440p images which used to look clear before, now look like some 360p or 480p images stretched to entire display.

I tried the command xrandr --dpi 120 and relogged, didn't have any effect too.

So yeah, the editing of sddm.conf and forcing font dpi in system settings hasn't solved the problem for me. Could you guys please provide additional help?

Background : I have a 14 inch 1080p display and 125% global scaling.

╰─λ inxi -Faz
System:    Kernel: 5.14.15-arch1-g14-1 x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: pm_debug_messages amd_pmc.enable_stb=1 amd_pmc.dyndbg="+p" acpi.dyndbg="file
drivers/acpi/x86/s2idle.c +p" BOOT_IMAGE=/@/boot/vmlinuz-linux-g14
root=UUID=a12edf4b-f91d-4792-a992-2baac1ce3438 rw [email protected] quiet
cryptdevice=UUID=1f19efd7-c4e6-4eaf-accf-83d0acf1403e:luks-1f19efd7-c4e6-4eaf-accf-83d0acf1403e
root=/dev/mapper/luks-1f19efd7-c4e6-4eaf-accf-83d0acf1403e rd.udev.log_priority=3
vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3 splash
Desktop: KDE Plasma 5.23.3 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: ASUSTeK product: ROG Zephyrus G14 GA401II_GA401II v: 1.0 serial: <filter>
Mobo: ASUSTeK model: GA401II v: 1.0 serial: <filter> UEFI: American Megatrends v: GA401II.219
date: 12/30/2020
Battery:   ID-1: BAT0 charge: 58.2 Wh (79.6%) condition: 73.1/76.0 Wh (96.2%) volts: 15.8 min: 15.8
model: ASUSTeK ASUS Battery type: Li-ion serial: N/A status: Not charging
Device-1: hidpp_battery_0 model: Logitech G304 Lightspeed Wireless Gaming Mouse
serial: <filter> charge: 100% (should be ignored) rechargeable: yes status: Discharging
CPU:       Info: 6-Core model: AMD Ryzen 5 4600HS with Radeon Graphics bits: 64 type: MT MCP arch: Zen 2
family: 17 (23) model-id: 60 (96) stepping: 1 microcode: 8600104 cache: L2: 3 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 71899
Speed: 3987 MHz min/max: 1400/3000 MHz boost: enabled Core speeds (MHz): 1: 3987 2: 3639
3: 3298 4: 3774 5: 2841 6: 3132 7: 2258 8: 1774 9: 3408 10: 3745 11: 3560 12: 2645
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: AMD Renoir vendor: ASUSTeK driver: amdgpu v: kernel bus-ID: 04:00.0
chip-ID: 1002:1636 class-ID: 0300
Display: x11 server: X.Org 1.21.1.1 compositor: kwin_x11 driver: loaded: amdgpu,ati
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 120 s-size: 406x228mm (16.0x9.0") s-diag: 466mm (18.3")
Monitor-1: eDP res: 1920x1080 hz: 120 dpi: 158 size: 309x174mm (12.2x6.9") diag: 355mm (14")
OpenGL: renderer: AMD RENOIR (DRM 3.42.0 5.14.15-arch1-g14-1 LLVM 12.0.1) v: 4.6 Mesa 21.2.4
direct render: Yes
Audio:     Device-1: AMD driver: snd_hda_intel v: kernel bus-ID: 04:00.1 chip-ID: 1002:1637 class-ID: 0403
Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: ASUSTeK driver: N/A
alternate: snd_pci_acp3x, snd_rn_pci_acp3x bus-ID: 04:00.5 chip-ID: 1022:15e2 class-ID: 0480
Device-3: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
bus-ID: 04:00.6 chip-ID: 1022:15e3 class-ID: 0403
Sound Server-1: ALSA v: k5.14.15-arch1-g14-1 running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.39 running: yes
Network:   Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 02:00.0 chip-ID: 8086:2723
class-ID: 0280
IF: wlp2s0 state: up mac: <filter>
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 5-4:3 chip-ID: 8087:0029
class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: down bt-service: enabled,running rfk-block:
hardware: no software: yes address: <filter>
Drives:    Local Storage: total: 953.87 GiB used: 262.51 GiB (27.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNW010T8 size: 953.87 GiB
block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 004C temp: 32.9 C scheme: GPT
Partition: ID-1: / raw-size: 953.61 GiB size: 953.61 GiB (100.00%) used: 262.5 GiB (27.5%) fs: btrfs
dev: /dev/dm-0 maj-min: 254:0 mapped: luks-1f19efd7-c4e6-4eaf-accf-83d0acf1403e
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 706 KiB (0.3%) fs: vfat
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 953.61 GiB size: 953.61 GiB (100.00%) used: 262.5 GiB (27.5%) fs: btrfs
dev: /dev/dm-0 maj-min: 254:0 mapped: luks-1f19efd7-c4e6-4eaf-accf-83d0acf1403e
ID-4: /var/log raw-size: 953.61 GiB size: 953.61 GiB (100.00%) used: 262.5 GiB (27.5%)
fs: btrfs dev: /dev/dm-0 maj-min: 254:0 mapped: luks-1f19efd7-c4e6-4eaf-accf-83d0acf1403e
ID-5: /var/tmp raw-size: 953.61 GiB size: 953.61 GiB (100.00%) used: 262.5 GiB (27.5%)
fs: btrfs dev: /dev/dm-0 maj-min: 254:0 mapped: luks-1f19efd7-c4e6-4eaf-accf-83d0acf1403e
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.05 GiB used: 1024 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 51.2 C mobo: 49.0 C gpu: amdgpu temp: 46.0 C
Fan Speeds (RPM): cpu: 2800
Info:      Processes: 360 Uptime: 37m wakeups: 5 Memory: 15.05 GiB used: 2.94 GiB (19.5%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1448 lib: 361
Shell: fish v: 3.3.1 default: Zsh v: 5.8 running-in: konsole inxi: 3.3.08

When is the last time you updated this was patched yesterday (xorg)

5 Likes

yes, it was

4 Likes

I got the update today. Doesn't seem to fix the issue though.
Do the thumbnails and previews get cached or something?

Yes they do.

I think previously I had a different scaling for general desktop and Qt apps somehow. On that Qt apps looked slightly smaller than everything else but at least the images and svg rendered properly. Is there a way to get that back?

Like 125% scaling on desktop, but 100% scaling on Qt apps.

UPDATE: I had to reinstall Garuda Linux. It's some DPI issue at 125% scaling. After re-installing Garuda it was still present, but went away as soon as I removed garuda configs for nvidia and optimus. The blur effect on Qt apps also come back.

Removing them is part of my setup since I require packages called asusctl and supergfxctl for my particular laptop in order to properly handle power and fan management and graphics switching. Optimus manager which is installed by default (and is a dependency of garuda-optimus-config) has to be fully removed so it doesn't conflict with supergfxctl.

Some input from Garuda Team would be great. @tbg @dr460nf1r3

I'm not a dev, but I'll respond. It's unfortunate that you had to change the default Garuda setup because of conflicts. Unfortunately, I don't think there's too much the team can do about that. However, they could take a look at it (time permitting).

If your issue was widespread I'm sure something would have to be done. At this point however, your's seems like more of an edge case. You'd really need to chat with the devs to discuss your case to see if there's a better workaround for you.

Perhaps TLP or some other power management utility could be used instead of the 2 utilities you are currently using. I know nothing about either of those apps, so I really couldn't say.

It's out of my hands, so you'll have to wait for a better response from someone on the development end of things. Hopefully something can be done, but in the mean time I'd test out alternate software to replace the problematic utilities from the AUR. Try doing some in depth searching to see if others have had problems, and if there were any workarounds found.

Good luck.

2 Likes

I'm getting this too. I found this old bug on KDE's bugtracker.

I set my scaling to 1.25 and, for now, this clears up the problems for me.

https://bugs.kde.org/show_bug.cgi?id=410632

1 Like

Since this is a KDE bug rather than garuda configuration, I'd consider this solution.

I set my scaling to 1.25 and, for now, this clears up the problems for me.

By this you mean in ~/.config/kdeglobals right?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.