N00bie issues

Older 2015 MBP from Apple, wiped clean and installed Garuda Gamer KDE version. Customized to a point where I had Bluetooth Logitech KB and MX Master 3 mouse working.

Got funky and decided that mouse was really not working well, so I tried the logid software. Goofed around until it seemed like it was sorta working, as in, I could change DPI and feel the difference. Still not great performance, but it was OK.


I then farted around with the window appearance and picked some other desktop. No idea what I am doing, but I chose the checkbox to change desktop layout too. Reboot. Boom. In a dark place.


First off, no Bluetooth anymore. Cannot enable it. It is Kaboom gone. No idea what happened to it, but I cannot get it going and all systemctl start/enable bluetooth commands work with nothing changing with the actual Bluetooth being on.

What happened?

Also, that swanky nice thing we would call a Dock from GNOME world or MacOS world, that I had with Garuda… it is gone too!

How does one re-enable that and what is it called? I understand I am new to KDE and it is just some kind of Panel, but I am seriously bummed that I have zero clue how that was even a thing? The Window Activation hot spots for the bottom of the screen brings up a lot of actions, but none of them are that panel! Where did it go? What is it called?

All in all, I am loving my Garuda experience, but it is so wildly different for me.

Also, it was booting really fast, snappy even. But once I started playing with Logid, and the Toshy KB S/W, wow… all of a sudden, every reboot was taking 30 seconds. Damn! I wish I knew what changed suddenly because it just started when I was fiddling with the mouse parameters. Fragility strikes! I somehow busted a ton of nice things fiddling with the mouse.

Any pointers appreciated on what to do. Re-installing from USB stick to ground zero is an option but seems brutal all things considered.

Merry Christmas!

:warning: Missing information requested in the template may result in not receiving assistance :warning:

Make sure you have done the following before you post:

Issue still unresolved? Then:

  • ONE issue per topic.
  • Describe your issue in detail. The more we know, the better we can help
  • Show us the results of your searches, and what you’ve tried
  • After rebooting, post the FULL output of garuda-inxi in the body of the post (not linked externally, or collapsed with the “hide details” feature)
  • Format terminal output (including your garuda-inxi) as a code block by clicking the preformatted text button (</>) , or put three tildes (~) above and below the text

Welcome to the Garuda forums! :_garuda_:
Have you tried booting from a snapshot from before making those changes to see whether you can return to your original state?

And as posted by SGS, please follow the template. If you can’t get your garuda-inxi from your broken install, see if you can access a TTY (ctrl + alt + F2-F7) and get it from there, or get it from a live USB session.


I would definitely use a snapshot you can either type in btrfs-Assistant and you snapshot restore to go to a previous point.

To get the dock back type in settings, click on appearances, scroll till you see the dragonized theme and you can select it there, you can also right click on the desktop go to add panel and add the default, Garuda dock. If you’re missing the top panel, you can add that as well.

If the theme selected, added some random taskbar or something you can remove that.


Booting back a few changes from a snapshot worked fine. Brings up the question though, if I am happy with this snapshot as it fixed the mistake, how can I make it the new default boot? Can I delete bad snapshots?

Thanks for the advice, I will see if I can follow through and achieve success!

After booting off a snapshot, you have to restore it.
The system should have prompted you to do so. If not, you can use the btrfs-assistant, snapper tab, restore function. Select the right snapshot!


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.