My wifi is not connecting and Kde daemon asking for password again and again

I don't know why but wifi is not connecting and Kde daemon asking for password again and again. But previously it was fine.

System:    Kernel: 5.12.1-zen2-1-zen x86_64 bits: 64 compiler: gcc v: 10.2.0 
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=55a11460-701e-495c-887b-ddead1586312 
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
systemd.unified_cgroup_hierarchy=1 resume=UUID=b8b297b0-6b81-43d9-8d71-88eb175e498f loglevel=3 
Desktop: KDE Plasma 5.21.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM 
Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Desktop Mobo: Micro-Star model: A320M-A PRO MAX (MS-7C52) v: 1.0 serial: <filter> 
UEFI: American Megatrends v: 2.60 date: 06/10/2020 
CPU:       Info: Quad Core model: AMD Ryzen 5 3400G with Radeon Vega Graphics bits: 64 type: MT MCP 
arch: Zen/Zen+ note: check family: 17 (23) model-id: 18 (24) stepping: 1 microcode: 8108109 
cache: L2: 2 MiB 
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 59201 
Speed: 3700 MHz min/max: N/A Core speeds (MHz): 1: 3700 2: 3700 3: 3700 4: 3700 5: 3700 6: 3700 
7: 1312 8: 3700 
Vulnerabilities: Type: itlb_multihit status: Not affected 
Type: l1tf status: Not affected 
Type: mds status: Not affected 
Type: meltdown status: Not affected 
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
Type: spectre_v2 
mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling 
Type: srbds status: Not affected 
Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: AMD Picasso vendor: Micro-Star MSI driver: amdgpu v: kernel bus-ID: 29:00.0 
chip-ID: 1002:15d8 class-ID: 0300 
Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: loaded: amdgpu,ati 
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1 
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") s-diag: 414mm (16.3") 
Monitor-1: HDMI-A-0 res: 1366x768 hz: 60 dpi: 81 size: 430x255mm (16.9x10.0") 
diag: 500mm (19.7") 
OpenGL: renderer: AMD Radeon Vega 11 Graphics (RAVEN DRM 3.40.0 5.12.1-zen2-1-zen LLVM 11.1.0) 
v: 4.6 Mesa 21.0.3 direct render: Yes 
Audio:     Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel v: kernel 
bus-ID: 29:00.1 chip-ID: 1002:15de class-ID: 0403 
Device-2: AMD Family 17h HD Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel 
bus-ID: 29:00.6 chip-ID: 1022:15e3 class-ID: 0403 
Sound Server-1: ALSA v: k5.12.1-zen2-1-zen running: yes 
Sound Server-2: JACK v: 0.125.0 running: no 
Sound Server-3: PulseAudio v: 14.2 running: yes 
Sound Server-4: PipeWire v: 0.3.26 running: yes 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI 
driver: r8169 v: kernel port: f000 bus-ID: 25:00.0 chip-ID: 10ec:8168 class-ID: 0200 
IF: enp37s0 state: down mac: <filter> 
Device-2: TP-Link AC600 wireless Realtek RTL8811AU [Archer T2U Nano] type: USB 
driver: rtl88XXau bus-ID: 1-9:3 chip-ID: 2357:011e class-ID: 0000 serial: <filter> 
IF: wlp18s0f0u9 state: dormant mac: <filter> 
IF-ID-1: enp18s0f0u3 state: unknown speed: N/A duplex: N/A mac: <filter> 
Drives:    Local Storage: total: 447.13 GiB used: 13.75 GiB (3.1%) 
SMART Message: Unable to run smartctl. Root privileges required. 
ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37480G size: 447.13 GiB block-size: 
physical: 512 B logical: 512 B speed: 6.0 Gb/s rotation: SSD serial: <filter> rev: 0102 
scheme: GPT 
Partition: ID-1: / raw-size: 432.03 GiB size: 432.03 GiB (100.00%) used: 13.75 GiB (3.2%) fs: btrfs 
dev: /dev/sda3 maj-min: 8:3
ID-2: /boot/efi raw-size: 100 MiB size: 98.4 MiB (98.42%) used: 546 KiB (0.5%) fs: vfat
dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 432.03 GiB size: 432.03 GiB (100.00%) used: 13.75 GiB (3.2%) fs: btrfs
dev: /dev/sda3 maj-min: 8:3
ID-4: /var/log raw-size: 432.03 GiB size: 432.03 GiB (100.00%) used: 13.75 GiB (3.2%) fs: btrfs
dev: /dev/sda3 maj-min: 8:3
ID-5: /var/tmp raw-size: 432.03 GiB size: 432.03 GiB (100.00%) used: 13.75 GiB (3.2%) fs: btrfs
dev: /dev/sda3 maj-min: 8:3
Swap:      Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100)
ID-1: swap-1 type: partition size: 15 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda2
maj-min: 8:2
ID-2: swap-2 type: zram size: 1.71 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0
ID-3: swap-3 type: zram size: 1.71 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1
ID-4: swap-4 type: zram size: 1.71 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2
ID-5: swap-5 type: zram size: 1.71 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3
ID-6: swap-6 type: zram size: 1.71 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram4
ID-7: swap-7 type: zram size: 1.71 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram5
ID-8: swap-8 type: zram size: 1.71 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram6
ID-9: swap-9 type: zram size: 1.71 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram7
Sensors:   System Temperatures: cpu: 49.1 C mobo: 0 C gpu: amdgpu temp: 49.0 C
Fan Speeds (RPM): N/A
Info:      Processes: 297 Uptime: 9m wakeups: 0 Memory: 13.66 GiB used: 2.76 GiB (20.2%) Init: systemd
v: 248 tool: systemctl Compilers: gcc: 10.2.0 clang: 11.1.0 Packages: pacman: 1230 lib: 291
Shell: fish v: 3.2.1 running-in: konsole inxi: 3.3.04

Maybe you could check the solution which worked for this one:

Edit: Sorry, I see only now that you're not a new user and it was working before.
I just quickly saw your Wifi model...
I'm afraid you'll need to wait for someone else to support you...

2 Likes

What may have caused this change?

Did you update recently?

Have you tried rebooting your computer and router?

Have you tried disabling MAC address randomization?

Have you tried below yet?

Select your wifi connection in Network Manager and apply these settings:

“All users may connect to this network”

“Automatically connect to this network when it is available”

“Store password for all users (not encrypted)”

Then, reboot.


If that doesn't work try below.

Paste the commands below into the terminal and execute them:

nmcli networking off
sleep 1
sudo systemctl stop NetworkManager
sleep 1
sudo ip link set wlp18s0f0u90 down
sleep 1
sudo modprobe -rv rtl88XXau
sleep 3
sudo modprobe -v rtl88XXau
sleep 1
sudo ip link set wlp18s0f0u9 mode default
sleep 1
sudo ip link set wlp18s0f0u9 up
sleep 1
sudo systemctl start NetworkManager
sleep 1
sudo nmcli networking on
sleep 1
nmcli r wifi off
sleep 1
nmcli r wifi on

Post all inputs and outputs please.

Welcome to Garuda.

3 Likes

I just update my app with the default app store. Again It's only app update not mejor update. after that wifi is not connecting.

╭─[email protected] in ~ took 1s
╰─λ sudo ip link set wlp18s0f0u90 down
Cannot find device "wlp18s0f0u90"

╭─[email protected] in ~ took 1s
╰─λ sudo modprobe -rv rtl88XXau
modprobe: FATAL: Module rtl88XXau not found.

╭─[email protected] in ~ took 3s
╰─λ sudo modprobe -v rtl88XXau
modprobe: FATAL: Module rtl88XXau not found in directory /lib/modules/5.12.1-zen2-1-zen

If you updated only one app (?), maybe it could be worth restoring the previous snapshot and checking if that was the problem?

Not one app. I said only app not system update. I also tried to store the previous snapshot and problem not fix

This does not make sense. Maybe you should look into how Archlinux packages/system works.
Or explain in detail what you mean.

1 Like

I just app update. there was no reboot needed

First rule, when you have system problems, is

Reboot

If it is not fixed, then do as you are advised from @tbg and post the full terminal input/output.

1 Like

I just said that, update didn't ask for any reboot. But I already reboot the system more than 15 times with various solutions.

You did not say you have rebooted.
If we cannot communicate in English, then maybe try your native language. Maybe there is some user that can help you.

Have you read that already?
Why did you not respond?
Why did you not do as @tbg asked?
Do you really want help, or just trolling?...

1 Like

Dear sir, I already post the output of the shell commands

I am sure, not all.

Have you tried changing the kernel?
5.12.1-zen2-1-zen is quite new, maybe there is something wrong there...

Those are failing.

You did not answer all the questions or provide full feedback from my prior post.

You must provide proper feedback on every suggestion or we will make no progress.

Did you have your USB Wifi adapter plugged in when you ran all the commands I gave you?

Frankly the outputs make zero sense if your adapter was plugged into the computer

When I specifically ask you to provide all inputs and outputs from commands run, I do mean all. Never Cherry pick command outputs to post, always provide the complete inputs and outputs of all commands you run.

Did you have the driver @filo listed in his first post installed? Or have you installed a different realtek driver package? Or are you simply using the kernel driver for your adapter (meaning you never installed a separate Wifi driver package).

Have you tested any alternate kernels yet? I would recommend installing at least the linux-lts kernel and perhaps the linux-mainline kernel as well.

If you are using a separate Realtek driver package then I would suggest rebuilding (reinstalling) the driver package. DKMS drivers don't usually require rebuilding regularly, however occasionally they must be rebuilt.

Have you tried deleting and recreating your Wifi connection in Network Manager?

I somewhat doubt we will make much progress with this issue, as for whatever reason (language I assume) your answers are in no way sufficient to diagnose your problem.

Again I ask, have you rebooted your router? This definitely needs to be done. You may also need to reset your router back to the factory default to correct your issue.

Did your wifi work on the live boot disk when you installed Garuda?

If so I would suggest testing the live image again to see if your adapter is still working correctly. Please let me know if your adapter is functioning properly from the live environment or on another computer.

Please answer all questions and provide feedback on any and all suggestions given or there is little chance I will be able to help you. Make a full list of every suggestion or each question I've asked and provide full feedback and answers to each and every one please. Otherwise I'm simply wasting my time here and I would rather spend my time assisting users who provide proper feedback.

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.

If possible could you please update your thread for others benefit to indicate which of my suggestions resolved your issue.

Glad I could help and that your issue is now solved.

2 Likes