My system is not being fully used up: how to hack?

I have a decent computer with good cooling. Usually, whilst mining crypto, my gpu sits around 70degrees and I don't have any issues with browsing, using chat clients and other general tasks. Lighter games even are able to run at an ok speed- though anything heavier is not plausible.

Today I started mining, my gpu is not overclocked. And even as I am typing this there are stutters and the mouse is slow. Opening applications like Dolphin feel like my pc will crash at any point. My gpu is at a healthy temp, and my cpu cores are all but un-touched. Its not like the mining program is using everything it can- not even out of the gpu. (i have not set any bottle necks or limits)

--tl;dr--

I have mutch room left in my cpu to be used. I could also push my gpu quite a bit further for more performance also. My ram is at 50% no matter how many things I open.
what can i do to enable a more efficient use of my hardware? on paper, i can do more. In practice, I have been able to do more.


System:    Kernel: 5.10.14-119-tkg-bmq x86_64 bits: 64 compiler: gcc v: 10.2.1 
           parameters: intel_pstate=passive BOOT_IMAGE=/@/boot/vmlinuz-linux-tkg-bmq 
           root=UUID=8385376e-058c-4190-b13c-0411b1ce92e4 rw [email protected] quiet splash rd.udev.log_priority=3 
           vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 resume=UUID=25f83cb9-6cfa-4fc0-9ebb-5459b0de6e09 
           loglevel=3 
           Desktop: KDE Plasma 5.20.5 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM Distro: Garuda Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: PRIME B350-PLUS v: Rev X.0x serial: <filter> UEFI [Legacy]: American Megatrends 
           v: 5220 date: 09/12/2019 
CPU:       Info: 6-Core model: AMD Ryzen 5 2600 bits: 64 type: MT MCP arch: Zen+ family: 17 (23) model-id: 8 stepping: 2 
           microcode: 800820D L2 cache: 3 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 92321 
           Speed: 1780 MHz min/max: 1550/3850 MHz boost: enabled Core speeds (MHz): 1: 1780 2: 1750 3: 1499 4: 2066 5: 1858 
           6: 1586 7: 1893 8: 1589 9: 1625 10: 1476 11: 2039 12: 1599 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA GP104 [GeForce GTX 1060 6GB] vendor: Gigabyte driver: nvidia v: 460.39 
           alternate: nouveau,nvidia_drm bus ID: 09:00.0 chip ID: 10de:1b83 class ID: 0300 
           Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: loaded: nvidia display ID: :0 screens: 1 
           Screen-1: 0 s-res: 3840x1449 s-dpi: 101 s-size: 965x364mm (38.0x14.3") s-diag: 1031mm (40.6") 
           Monitor-1: DP-0 res: 1920x1080 dpi: 82 size: 598x336mm (23.5x13.2") diag: 686mm (27") 
           Monitor-2: DVI-D-1 res: 1920x1080 hz: 60 dpi: 102 size: 477x268mm (18.8x10.6") diag: 547mm (21.5") 
           OpenGL: renderer: GeForce GTX 1060 6GB/PCIe/SSE2 v: 4.6.0 NVIDIA 460.39 direct render: Yes 
Audio:     Device-1: NVIDIA GP104 High Definition Audio vendor: Gigabyte driver: snd_hda_intel v: kernel bus ID: 09:00.1 
           chip ID: 10de:10f0 class ID: 0403 
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 0b:00.3 chip ID: 1022:1457 class ID: 0403 
           Device-3: Cambridge Silicon Radio FiiO BTR3K type: USB driver: snd-usb-audio bus ID: 1-2:2 chip ID: 0a12:1004 
           class ID: 0102 serial: <filter> 
           Device-4: Logitech Webcam C310 type: USB driver: snd-usb-audio,uvcvideo bus ID: 1-3:3 chip ID: 046d:081b 
           class ID: 0102 serial: <filter> 
           Sound Server: ALSA v: k5.10.14-119-tkg-bmq 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8169 v: kernel port: f000 
           bus ID: 03:00.0 chip ID: 10ec:8168 class ID: 0200 
           IF: enp3s0 state: down mac: <filter> 
           Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: f000 bus ID: 08:00.0 chip ID: 8086:2723 
           class ID: 0280 
           IF: wlp8s0 state: up mac: <filter> 
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus ID: 1-6:5 chip ID: 8087:0029 class ID: e001 
           Message: Required tool hciconfig not installed. Check --recommends 
Drives:    Local Storage: total: 1.25 TiB used: 57.57 GiB (4.5%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda maj-min: 8:0 vendor: Transcend model: TS256GSSD370S size: 238.47 GiB block size: physical: 512 B 
           logical: 512 B speed: 6.0 Gb/s rotation: SSD serial: <filter> rev: 6KB scheme: MBR 
           ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital model: WD10EZEX-08WN4A0 size: 931.51 GiB block size: 
           physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: 1A02 scheme: GPT 
           ID-3: /dev/sdc maj-min: 8:32 vendor: SanDisk model: SSD PLUS 120GB size: 111.8 GiB block size: physical: 512 B 
           logical: 512 B speed: 6.0 Gb/s rotation: SSD serial: <filter> rev: 00RL scheme: MBR 
Partition: ID-1: / raw size: 94.61 GiB size: 94.61 GiB (100.00%) used: 57.57 GiB (60.8%) fs: btrfs dev: /dev/sdc1 
           maj-min: 8:33 
           ID-2: /home raw size: 94.61 GiB size: 94.61 GiB (100.00%) used: 57.57 GiB (60.8%) fs: btrfs dev: /dev/sdc1 
           maj-min: 8:33 
           ID-3: /var/log raw size: 94.61 GiB size: 94.61 GiB (100.00%) used: 57.57 GiB (60.8%) fs: btrfs dev: /dev/sdc1 
           maj-min: 8:33 
           ID-4: /var/tmp raw size: 94.61 GiB size: 94.61 GiB (100.00%) used: 57.57 GiB (60.8%) fs: btrfs dev: /dev/sdc1 
           maj-min: 8:33 
Swap:      Kernel: swappiness: 10 (default 60) cache pressure: 75 (default 100) 
           ID-1: swap-1 type: partition size: 17.19 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sdc2 maj-min: 8:34 
           ID-2: swap-2 type: zram size: 1.3 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0 
           ID-3: swap-3 type: zram size: 1.3 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1 
           ID-4: swap-4 type: zram size: 1.3 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2 
           ID-5: swap-5 type: zram size: 1.3 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3 
           ID-6: swap-6 type: zram size: 1.3 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram4 
Sensors:   System Temperatures: cpu: 51.2 C mobo: N/A gpu: nvidia temp: 69 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 49% 
Info:      Processes: 384 Uptime: 2h 28m wakeups: 0 Memory: 15.63 GiB used: 8.49 GiB (54.3%) Init: systemd v: 247 Compilers: 
           gcc: 10.2.0 clang: 11.0.1 Packages: pacman: 1813 lib: 548 Shell: fish v: 3.1.2 default: Bash v: 5.1.4 
           running in: konsole inxi: 3.3.01
```

Just to confirm, you are asking for help making more use of your system for cryptomining?

1 Like

No. I am happy with the speeds I am mining at- I would rather make use of the rest of my system for everything else

OK, so the first thing I would check is whether the issue is being caused by the kernel. The TKG kernels are focussed on very specific workloads (e.g. gaming) not general desktop responsiveness. So, try linux, linux-zen, linux-lqx, ...

2 Likes

Mmh, it looked to me like linux-zen was a solid all-rounder. Though after installing it and selecting "linux-zen" from the garuda boot loader it never loaded from boot. I am quite sure i done it right though.

In grub use advanced, please.

I assume you also installed matching headers so the DKMS GPU drivers will build?

1 Like

ii assume you mean go under the advanced options in the boot menu? thats what I had done, how else would I try to use zen

wwell ii rre-installled it and it has booted into zen. though the preformence is no better once the mining stars

After a few days of my pc not being able to both mine with PhoenixMiner and do basic tasks, here are pretty much all the noticeable effects it has.

It seems to slow down the drawing of my screens: a very visible line comes down from the top, moving downwards as it refreshes what ever I moved. Though it cant literally be that, as my mouse visuals are all but unaffected, and some apps dont even do that- even if they are doing the same tasks.

Regardless of which program is open, my mouse will fight, slow down and delay its motion at certain intervals.
What ever it is, its making my pc a little less available with these irregular drops. It does the same when moving windows across the screens or opening system settings or trying to change my volume.

Most apps that allow me to type will suffer also, and my typing bbecommes likke tthis if ii typpe toffast.

When using brave, the issues are nonexistent. I am using brave now to type this and its flawless. Really hoping there is an explanation for that one.

My application launcher (ctrl+space) is my only way, really, to launch apps. It's very hard to use the mouse. That said, moving my mouse around in brave, no issue. Moving it around the task bar is hit/miss. But moving it across most other apps its going to slow and going to cause issues.
Point is: its predictable depending where I move.

I can, how ever, once I manage to open such thing, easily run a game and a heavy-ish program with 0 frame drops. Its harder to open the damn game than run it, it feels like. Though when I start streaming and gaming and mining at the same time, things slow down a bit- but thats the expected response and totally normal.

I have tried changing kernels, no noticeable difference at all. I have tried to over/under-clock, tho iI failed miserably. I have used different DE's, with no avail.

I should definitely mention that when im watching a movie, or when I am gaming, I have no issues. It just runs like normal. But exiting, or opening a new app or even just scrolling down on a webpage, its like it all goes on holiday..
alt-tab seems to hate me though- every time. (when mining, of course)

I have no idea about mining but it doesn't seem to be doing your system any good.
Open htop and see what's holding up your system.

1 Like

Its a heavy thing to do on the Graphics card. I know what its doing. Just, it should not be causing this to happen. Right clicking an app on the taskbar to close it freezes my pc- this is not normal

Testing 1 alternate kernel is not conclusive.

I would test at least the following kernels:

linux-mainline
linux-lts
linux
linux-hardened
linux-rt

No offense, but I wouldn't expect the official Garuda support volunteers to dedicate a ton of time trying to rectify your issue. I say this because I don't think most of us would consider this a valid Garuda support issue.

I can only speak for myself, but if you want to run a cryptominer and it causes you problems, that's mostly a problem of your own making (and not a Garuda issue IMO).

I do wish you well solving your problem.

2 Likes

thanks for your input