My problems so far

Hey good people.

I've been using Garuda exclusively for almost 6 months, and I'd like to air some of the things I have been having a problem with. But first some story.

I started my journey in LInux in 2001. When I installed Debian on a school pc. Soon that ended up in me testing Slackware, then RedHat, SuSe, and then Gentoo. At this time getting my graphics card to function properly was a hassle, and I reluctantly reverted back to Windows. I ever so often tried diffrent new versions of Linux as there was new ones. And during the last few years Ubuntu and Kubuntu has been my tests. But never really felt at home. Arch fixed this, and Garuda is by far the best I have tried so far.

I am by no means a super user. I manage to get some problems fixed, whilst other I have no clue on how to get around. And I'd like to mention some of the problems I have and maybe get someone to fill my heads on what to search for. I will be posting my garuda-inix at the end.

  1. Terminal resolution. And by terminal I am not talking about the terminal of witch my window manager use. I am talking about the tty's. The text there is rather small. Too small for someone to effectively use it. But you have the Window Manager... yes and sometimes you don't.

Been trying to fix this by going into the grub configs and manually changing the resolution, but this keeps failing me.

  1. Sddm is also really small. seems my resolution is 3840x2160 and whilst I in KDE can set up a scale that makes everything readable, this tends to fail in Sddm. I've tried installing gdm instead, and this scales up, but the resolution cant be changed.

  2. My resolution on the desktop cant be changed anymore. I say anymore because I cannot change it anymore since some update in January. I cannot say what went wrong, but I have been trying everything I can thionk of to be able to change it again. I'd really like to be able to set it to 1080p. Mostly because I play an old windows Game(Anarchy Online) that has got no way of scaling the GUI (to my knowledge) and reading stuff in game is straining on the eyes.

For this I have tried downgrading driver (nvidia), Ive tried setting resolution with xredr. I've tried adding modes, deleting modes. I've tried installing the system all over again. I've tried using another DM (gdm)... When using gdm the screen still goes black, BUT I can see the mousepointer, and it can only move in the top left side of the screen suggesting to me that... I dont know... THis makes me afraid of trying to sett the resolution in any other capasity. I need the TTY to get back after things blackout.. Been thinking it might be something with the display. That it is somehow not configured properly. But my expertise is far from there.

Other than theese things I really have nothing bothersome that I can point to. Good Job!!!

garuda-inix:

[🔍] × sudo garuda-inxi 
[sudo] password for aia:         
System:
Kernel: 5.16.10-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=7a1a328c-6a99-45ff-973a-08bb2de00f48 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=9d11bc5e-9535-457a-86a0-41eb16d4ca92 loglevel=3
Console: pty pts/1 wm: kwin_x11 DM: GDM 41.3, SDDM Distro: Garuda Linux
base: Arch Linux
Machine:
Type: Laptop System: LENOVO product: 20378 v: Lenovo Y50-70
serial: <filter> Chassis: type: 10 v: Lenovo Y50-70 serial: <filter>
Mobo: LENOVO model: Lenovo Y50-70 v: 31900058WIN serial: <filter>
UEFI: LENOVO v: 9ECN36WW(V2.00) date: 01/12/2015
Battery:
ID-1: BAT1 charge: 37.2 Wh (100.0%) condition: 37.2/54.8 Wh (67.9%)
volts: 8.0 min: 7.4 model: LENOVO PABAS0241231 type: Li-ion
serial: <filter> status: Full
Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard K270
serial: <filter> charge: 100% (should be ignored) rechargeable: yes
status: Discharging
CPU:
Info: model: Intel Core i7-4720HQ socket: LGA1150 (U3E1) note: check
bits: 64 type: MT MCP arch: Haswell family: 6 model-id: 0x3C (60)
stepping: 3 microcode: 0x28
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 6 MiB desc: 1x6 MiB
Speed (MHz): avg: 2595 high: 2597 min/max: 800/3600 base/boost: 2600/2600
scaling: driver: intel_cpufreq governor: performance volts: 0.8 V
ext-clock: 100 MHz cores: 1: 2594 2: 2595 3: 2595 4: 2597 5: 2595 6: 2596
7: 2594 8: 2597 bogomips: 41507
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel 4th Gen Core Processor Integrated Graphics vendor: Lenovo
driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:0416 class-ID: 0300
Device-2: NVIDIA GM107M [GeForce GTX 960M] vendor: Lenovo driver: nvidia
v: 510.54 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:139b
class-ID: 0302
Device-3: Acer Lenovo EasyCamera type: USB driver: uvcvideo bus-ID: 3-6:3
chip-ID: 5986:055e class-ID: 0e02 serial: <filter>
Display: server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
loaded: modesetting,nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x2160 s-dpi: 96 s-size: 1016x571mm (40.0x22.5")
s-diag: 1165mm (45.9")
Monitor-1: eDP-1-1 res: 3840x2160 hz: 48 dpi: 284
size: 344x194mm (13.5x7.6") diag: 395mm (15.5")
OpenGL: renderer: NVIDIA GeForce GTX 960M/PCIe/SSE2
v: 4.6.0 NVIDIA 510.54 direct render: Yes
Audio:
Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio
vendor: Lenovo driver: snd_hda_intel v: kernel bus-ID: 00:03.0
chip-ID: 8086:0c0c class-ID: 0403
Device-2: Intel 8 Series/C220 Series High Definition Audio vendor: Lenovo
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:8c20
class-ID: 0403
Sound Server-1: ALSA v: k5.16.10-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.47 running: yes
Network:
Device-1: Intel Wireless 3160 driver: iwlwifi v: kernel bus-ID: 08:00.0
chip-ID: 8086:08b4 class-ID: 0280
IF: wlp8s0 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Lenovo driver: r8169 v: kernel port: 3000 bus-ID: 09:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: enp9s0 state: down mac: <filter>
Bluetooth:
Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
bus-ID: 3-7:5 chip-ID: 8087:07dc class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
Drives:
Local Storage: total: 476.94 GiB used: 34.74 GiB (7.3%)
ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: MZ7TE512HMHP-000L2
family: based SSDs size: 476.94 GiB block-size: physical: 512 B
logical: 512 B sata: 3.1 speed: 6.0 Gb/s type: SSD serial: <filter>
rev: 6L0Q temp: 29 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 6y 101d 10h cycles: 1595
Partition:
ID-1: / raw-size: 459.55 GiB size: 459.55 GiB (100.00%)
used: 34.74 GiB (7.6%) fs: btrfs block-size: 4096 B dev: /dev/sda2
maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat block-size: 512 B dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 459.55 GiB size: 459.55 GiB (100.00%)
used: 34.74 GiB (7.6%) fs: btrfs block-size: 4096 B dev: /dev/sda2
maj-min: 8:2
ID-4: /var/log raw-size: 459.55 GiB size: 459.55 GiB (100.00%)
used: 34.74 GiB (7.6%) fs: btrfs block-size: 4096 B dev: /dev/sda2
maj-min: 8:2
ID-5: /var/tmp raw-size: 459.55 GiB size: 459.55 GiB (100.00%)
used: 34.74 GiB (7.6%) fs: btrfs block-size: 4096 B dev: /dev/sda2
maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 17.09 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sda3 maj-min: 8:3
ID-2: swap-2 type: zram size: 15.54 GiB used: 1.8 MiB (0.0%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 56.0 C mobo: N/A gpu: nvidia temp: 47 C
Fan Speeds (RPM): N/A
Info:
Processes: 303 Uptime: 3h 40m wakeups: 13 Memory: 15.54 GiB
used: 3.54 GiB (22.8%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 2050 lib: 584
Shell: garuda-inxi (sudo) default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.12
Garuda (2.5.5-1):
System install date:     2022-02-21
Last full system update: 2022-02-21
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:            nmb.service

╭─[email protected] in ~ as 🧙 took 4s

There is a way to do that, I've done it on another machine, however it will scale within the DE as well. Not sure if there's a way to unscale permanently when after you login.
I can't remember by heart what I did, but in 10-12h I can tell you. However I found this fix on google so maybe you will find it before I gain access to my machine.

I believe I did "Apply Plasma Settings" on the "Login Screen (SDDM)" section of Startup and Shutdown.

For tty, i've never looked into that before but according to [solved] how to change tty-font / Newbie Corner / Arch Linux Forums it might not be too difficult.

1 Like

Sometimes xrandr locks in on an undesirable resolution. I'm not sure why, but I have seen it come up in the forum a couple times. You can add missing resolutions and instruct xrandr to use them by default in a config file: xrandr - ArchWiki

1 Like

As it's a little late now, (just for future reference) do not lump multiple issues in together on a single help wanted thread. It often causes confusion if the thread becomes extended, and makes it hard for others to find an answer if they have similar issues.

Far better to open an individual topic for each issue with a consise title identifying what the thread is about. This makes it far easier for others to locate information on a similar problem. Also, having a concise title makes it far more likely that you will get an expert on a particular issue to respond to your question.

If you have an audio issue and you identify this in the title you are far more likely to have an expert in audio matters respond to your help request. If you have a graphics issue and you identify this in the title you are far more likely to have an expert in graphics matters respond to your help request, etc, etc. If you simply state you are having a bunch of issues in your title then many experts in that field will simply ignore your post as it is not in their field of interest. For example, I often respond to networking issues that interest me. If the thread title does not implicitly identify a network problem I may ignore the help request entirely. I'm uninterested in responding to most graphics or audio issues and am unlikely to respond to a network issue lumped in with a dog's breakfast of other non-network related issues.

Just some tips to consider in the future when opening help requests.

5 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.