My linux partision fills up like crazy, how to counter this problem

I have tried all possible methods of cleaning up the system.

I have removed any orphans, removed all cache from web browsers and other applications (expect firedragon, i need the cache)

All my applications are necessary, but they previous had more than 22gb , now its almost 13gb left in 44 gb partition.




Please any tips or way to save some space or remove something, my OS is Gardua Dragonized (non gaming edition)

  1. Clean your package cache
  2. Prune old snapshots
8 Likes

how do i purge my old snapshots?

Consider buying a drive, they're not expensive (either HD or SSD). That's by far the easiest and most permanent solution.

1 Like

In the Timeshift application -> Delete button

2 Likes

laptop, : (

I see it's solved now :wink:
I think this could be a good time to check your sudo btrfs filesystem usage /
and, if necessary, balance.
I leave you a couple of posts I bookmarked long ago to start reading how it works:

And how to do it (I suggest not to go for a full balance with the Garuda assistant):

5 Likes

Wait, where is the problem?

Actually, @diehardman , you shouldn't be worried at all. This space will fill, only upto 5 snapshots by default. Then on, there won't be any crazy filling of space.

So, just take a deep breath and keep calm. You should be concerned only if 3 to 4 GB is left.

7 Likes

it usually devolves to filling with 5 or 6 gb left in the end, i deleted my last garuda dragonized system due to this reason, its perfect distro for me as i spend 5 hours setting up my os and customizing it.

No screenshot, please, just text, formatted with 3 ~ before and after.
In my opinion, it's high time to balance ("compare the difference between "unallocated" and "free", and "allocated" and "used"").

5 Likes
Overall:
Device size:                  44.88GiB
Device allocated:             31.80GiB
Device unallocated:           13.09GiB
Device missing:                  0.00B
Used:                         23.59GiB
Free (estimated):             19.97GiB      (min: 19.97GiB)
Free (statfs, df):            19.97GiB
Data ratio:                       1.00
Metadata ratio:                   1.00
Global reserve:               61.25MiB      (used: 0.00B)
Multiple profiles:                  no

Data,single: Size:30.01GiB, Used:23.13GiB (77.07%)
/dev/nvme0n1p4         30.01GiB

Metadata,single: Size:1.76GiB, Used:475.20MiB (26.40%)
/dev/nvme0n1p4          1.76GiB

System,single: Size:32.00MiB, Used:16.00KiB (0.05%)
/dev/nvme0n1p4         32.00MiB

Unallocated:
/dev/nvme0n1p4         13.09GiB

why is the 13GB unallocated? and how do i allocate it?

If / when you want to go into details, ref. e.g.:
https://wiki.archlinux.org/title/Btrfs
https://btrfs.wiki.kernel.org/index.php/FAQ#How_much_free_space_do_I_have.3F

4 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.