My desktop is unresponsive

My KDE desktop is basically just a wallpaper. I can see it, I just can’t use it. I can still use ALT+SPACE and search up apps. Also for some reason I can’t use my snapshots. I’m kinda desperate.

By default your home directory is not included in snapshots, so rolling back with a snapshot will not restore your user settings. Try creating a new user account.


If your issue is the same as mine, it may be due to a bugged widget. I would try editing out all non-default widgets in .config/plasma-org.kde.plasma.desktop-appletsrc (especially anything using the process-table or bar graph style, these were causing the issue for me).

[Yeah I was editing my ram widget and then it said KDE desktop has crashed and I didn’t pay attention so I pressed terminate. Btw the command didn’t work.

I just now tried that and any time I put in the password for my new account, my screen goes black for a quick second and sends me to the lock screen again without any sort of “Login Error.”

Please, follow the template, post your garuda-inxi.

  • After rebooting, post the FULL output of garuda-inxi in the body of the post (not linked externally, or collapsed with the “hide details” feature)
  • Format terminal output (including your garuda-inxi) as a code block by clicking the preformatted text button (</>) , or put three tildes (~) above and below the text

Use live ISO if X11 did not work.

1 Like

I’m sorry I’ve gotta be annoying I know, but I somewhat new to Arch and I don’t really understand what this means and what it will do to help or fix my computer.


  • It contains additional, useful information about the status of your system.


  • You can change on login screen from wayland to X11, try it.
1 Like

I did that but the desktop is still frozen, some icons shrunk my monitor layout is different, but other than that it’s all just the same.

What kind of widget is that? A default KDE widget or a user-created one you downloaded?

Can you open apps like Dolphin or the console?

If a new account doesn’t work, it’s probably not because of the home directory and user settings.

Why not, what happens when you select a snapshot in the grub menu?

Yes the ram widget was user created.

Yes I can open all of those apps.

Yeah I made the account when I thought it might fix the issue.

So when tried my first time to get a snapshot the day before, everything looked normal, except for my desktop ofc. Now I don’t see an option for snapshots. When I had loaded into the snapshot it asked me to fix it or something like that ( I can’t remember) it just went away and I don’t know how to go to snapshots anymore. There isn’t an older snapshot than 5-31-24 to my knowing.
EDIT: This issue started yesterday.

Ok, then open Dolphin and go to /home/username/.local/share/plasma/plasmoids/ and delete the folders in there. Reboot.

The folder doesn’t exist?

Which folder does not exist?
usename is your old and broken account name.

nvm i fixed the username

So now I don’t know how to explain what’s going on at this point, but the desktop is still just like a watermark, but the icons are different.

For example, if your old account was JollyJeffy, then the path is /home/jollyjeffy/.local/share/plasma/plasmoids/ . And in the folder plasmoids you delete the contents. Did you do that? Did you reboot afterward?

I deleted every single folder that was in the dolphin path you sent me.

Please answer all questions.

If that doesn’t work, open the system settings using ALT+SPACE and change the global theme to “Breeze”. Reboot.
If that doesn’t work either, then it’s not the widget’s fault.

Post your garuda-inxi, enter this in the terminal:


Sorry for not responding. Apparently new users can’t send more than 15 messages a day whenever all they want is to fix their pc. I’m a little pissed off by that, but I will do all those things.