My compilation attempt in terminal fails

Greetings I experience a longstanding annoyance whit Garuda (arch). And it is custom kernel compiling from terminal.

What i want to do ?
I want to build a custom tkg kernel with futex 2 mypatch interface.

What is the problem?
After i git cloned this repository and added futex 2 interface patch ( GitHub - Frogging-Family/linux-tkg: linux-tkg custom kernels ), I could not build it from terminal.

Is this problem occur in any other Arch based distro?
No! I could successfully build this in any other derivatives (Endeavor, Manjaro, even base arch)
There is something wrong with garuda linux for sure. I want to have an answer for this problem !

What is the written error message ?

Makefile:151: *** source directory cannot contain spaces or colons. Stop.
==> ERROR: A failure occurred in prepare().
Aborting...

Have I tried to use konsole instead of Alacitty?
Yes, same result.

Type

bash

Then try building i think its probably shell scripting issue

1 Like

Nope. after using bash and going back to /Downloads/Tkg Stuff/tkg linux and using makepkg -si command. Still receiving the error

Makefile:151: *** source directory cannot contain spaces or colons. Stop.
==> ERROR: A failure occurred in prepare().
Aborting...
-> exit cleanup done

This issue is very annoying, since this kind of behavior is Garuda specific
Pls help me !

Pls can you try to build kernel from tkg linux git lab repo? maybe you will experience the same behavior

https://www.google.com/search?client=firefox-b-d&biw=1591&bih=1698&sxsrf=ALeKk029X3WjrMhzvuWwvRyjuNFqzBFe5Q%3A1609602119353&ei=R5TwX6iQFYawtQX-rbagCg&q=source+directory+cannot+contain+spaces+or+colons&oq=source+directory+cannot+contain+spaces+or+colons&gs_lcp=CgZwc3ktYWIQDDIFCAAQywEyBQgAEMsBOgQIIxAnOgQILhBDOgcIABAUEIcCOgIIADoGCAAQFhAeULs3WLs3YJ1QaABwAHgAgAHcAYgBswOSAQMyLTKYAQCgAQGqAQdnd3Mtd2l6wAEB&sclient=psy-ab&ved=0ahUKEwjoz7aUy_3tAhUGWK0KHf6WDaQQ4dUDCAw

That message means that the current directory (containing the Makefile) has a full path which contains at least one space or colon, and that’s not supported. You need to move your source tree elsewhere.

Ok will reply later

It's telling you what the problem is right there in the error message. This is not something "wrong with Garuda" - the directory containing the source files contains spaces.

I'd suggest you do some reading about how to build packages: Arch User Repository - ArchWiki

3 Likes

So :slight_smile:

2 Likes

kernel already exists in aur and chaotic aur. why'd you want to compile it yourself.? or have i misunderstood?

Why not, I build my own kernel in Mint too.

Why do people write books when there are already so many of them?

2 Likes

Or climb mountains... :wink:

2 Likes

Thank you, it looks like cloning the repository to the home directory and using bash command before executing makepkg -si solved my problem ! The fact is bash must be used in order to avoiding compiling error.

Why compiling wine tkg and custom kernel?

Because of futex 2 interface mypatch and futex 2 mypatch on wine side

2 Likes

i am a mere mortal and i do not comprehend your godly language. :wink:
you can mark the post that solved your problem as solution so people referring to it dont need to search it.

2 Likes

That was, rude.

I didn't understand what you were talking about xd. I was saying it was way beyond my knowledge. Wasn't trying to be rude but honest

2 Likes