My bios dont show sata controller option

i am currenty using a 512 gb nvme m.2 ssd. I was following the installation steps listed on the download page, when i came to the ahci section i searched my laptop(hp15 fr2006) bios and there was no option for sata controller, so i ignored it and dual booted it, eveything was fine until i rebooted and it got stuck after i selected garuda on grub menu. Please tell me what to do!

Options i am considering-
Use debian(KDE plasma) and setup like garuda dra460nised.
Dont install Garuda use any other distro (SADDEST)
Not use dual boot and just use Garuda linux on my nvme ssd

Are you saying you installed the system and then rebooted and got stuck? If so, that likely has nothing to do with the AHCI settings.

You need to describe exactly what happened after you selected garuda in grub. It is probably fixable.

You should start by including the information we need to help you! When you create a new post there is text there that describes exactly what we need and how to provide it. Please go back and read that and update your post with that information.


My sata controller is set to NVMe. And its status is NON RAID and controller interface is PCIe.

setfont: KDFONTOP: Function not implemented
mount: /new_root: cant find UUID=(NUMBERS)
You are now being dropped into an emergency shell
sh: cant access tty: job control turned off

garuda showed this when i pressed esc when it was stuck on loader having a dragon and spiral background.

I think the problem is that i am dual booting but i cant say if single boot will fix it and i dont wanna try.

Could you please check if you have in the BIOS an option like Intel-VMD and this can be disabled or set to different values?

have a look for yourself. These are all the options i have

Ok, so that was not the issue in my mind...

Check /etc/fstab , missing hardware error.

what to check for?

There is no dual boot support.
Read man fstab,
Boot live ISO, search in forum for boot repair, try garuda-assistant.

If i do single boot do u guarantee it wont mess up

I use dual boot on some hardware, nobody can give you a guarrenty.
Why do you not follow the template?
Why do you not follow dalto post #2?

I move your topic, edit your post with needed data.

I see VMD in a picture, not changable.
If you want, I think you could try the following:

  • use the USB and from there chroot into your system
  • run sudo micro /etc/mkinitcpio.conf
  • add the module vmd to the MODULES list
  • run sudo mkinitcpio -P to regenerate all initramfs
  • run sudo micro /etc/default/grub
  • add nvme_load=YES to GRUB_CMDLINE_LINUX line
  • run sudo grub-mkconfig -o /boot/grub/grub.cfg to regenerate the GRUB menu
  • reboot
1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.