Multiple bugs after garuda-update

After I updated my system, my top panels disappeared completely. I had to rebuild them from scratch.
Even after rebuilding them, I started having this bug Garuda Default Top Panel not showing on primary monitor after restart - #7 by ImGarudaLearner.

Optimus Manager QT used to work fine on my system, now when I try to activate my Nvidia GPU it says:


The grouping behaviour of applications on bottom panel and other configurations broke. I have been reconfiguring everything again.

The background images of the desktop changed after garuda-update. ‘-’

I deeply need help on this one: screen sharing on OBS Studio or Discord stopped working completely. I’m always streaming while working, and I would appreciate any help on fixing this. I’m not sure if this is related to “wayland” or how to “x11” (not sure if this is the recommended fix)

I appreciate any input on any of these problems

[EDIT] The biggest issue for me was the screen sharing, it has been solved after switching to x11 on login screen. Also, the Optimus Manager warning disappeared after selecting x11.
The top panel is now positioned on the right place even after rebooting. Not sure if the x11 also solved it somehow.

╰─λ garuda-inxi
Kernel: 6.7.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc avail: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=1841fbdb-0a5a-497a-86d3-67c2ef2f6c76 rw rootflags=subvol=@
quiet rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3 ibt=off
Desktop: KDE Plasma v: 6.0.2 tk: Qt v: N/A info: frameworks v: 6.0.0
wm: kwin_wayland with: krunner vt: 1 dm: SDDM Distro: Garuda
base: Arch Linux
Type: Laptop System: Avell High Performance product: A65 MOB v: Standard
serial: <superuser required>
Mobo: Avell High Performance model: Avell A65 MOB v: Standard
serial: <superuser required> part-nu: A65 MOB uuid: <superuser required>
UEFI: American Megatrends LLC. v: N.1.07AVE00 date: 07/23/2021
ID-1: BAT0 charge: 68.6 Wh (97.0%) condition: 70.7/93.5 Wh (75.6%)
volts: 12.2 min: 11.4 model: standard type: Li-ion serial: <filter>
status: not charging
ID-2: hidpp_battery_0 charge: 100% condition: N/A volts: 4.2 min: N/A
model: Logitech G703 LIGHTSPEED Wireless Gaming Mouse w/ HERO type: N/A
serial: <filter> status: full
Info: model: 11th Gen Intel Core i7-11800H bits: 64 type: MT MCP
arch: Tiger Lake gen: core 11 level: v4 note: check built: 2020
process: Intel 10nm family: 6 model-id: 0x8D (141) stepping: 1
microcode: 0x50
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 640 KiB desc: d-8x48 KiB; i-8x32 KiB L2: 10 MiB desc: 8x1.2 MiB
L3: 24 MiB desc: 1x24 MiB
Speed (MHz): avg: 1568 high: 4200 min/max: 800/4600 scaling:
driver: intel_pstate governor: performance cores: 1: 917 2: 4200 3: 1370
4: 800 5: 1961 6: 801 7: 2744 8: 800 9: 1314 10: 800 11: 800 12: 800
13: 1791 14: 2431 15: 2760 16: 800 bogomips: 73728
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel TigerLake-H GT1 [UHD Graphics] vendor: Tongfang Hongkong
driver: i915 v: kernel arch: Gen-12.1 process: Intel 10nm built: 2020-21
ports: active: eDP-1 empty: DP-1 bus-ID: 00:02.0 chip-ID: 8086:9a60
class-ID: 0300
Device-2: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q]
vendor: Tongfang Hongkong driver: nvidia v: 550.54.14
alternate: nouveau,nvidia_drm non-free: 545.xx+ status: current (as of
2024-02; EOL~2026-12-xx) arch: Ampere code: GAxxx process: TSMC n7 (7nm)
built: 2020-2023 pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 4
speed: 16 GT/s ports: active: none off: HDMI-A-1 empty: DP-2,DP-3,eDP-2
bus-ID: 01:00.0 chip-ID: 10de:2520 class-ID: 0300
Device-3: Chicony Integrated IR Camera driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-13:9 chip-ID: 04f2:b71a
class-ID: 0e02 serial: <filter>
Display: wayland server: v: with: Xwayland v: 23.2.4
compositor: kwin_wayland driver: X: loaded: modesetting,nvidia dri: iris
gpu: i915,nvidia d-rect: 5120x2520 display-ID: 0
Monitor-1: HDMI-A-1 pos: bottom-r res: 2560x1080 size: N/A modes: N/A
Monitor-2: eDP-1 pos: primary,top-left res: 2560x1440 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: intel iris drv: nvidia platforms: device: 0
drv: nvidia device: 1 drv: iris device: 3 drv: swrast surfaceless:
drv: nvidia wayland: drv: iris x11: drv: iris inactive: gbm,device-2
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 24.0.2-arch1.2
glx-v: 1.4 direct-render: yes renderer: Mesa Intel UHD Graphics (TGL GT1)
device-ID: 8086:9a60 memory: 61.08 GiB unified: yes display-ID: :1.0
API: Vulkan v: 1.3.279 layers: 8 device: 0 type: integrated-gpu name: Intel
UHD Graphics (TGL GT1) driver: mesa intel v: 24.0.2-arch1.2
device-ID: 8086:9a60 surfaces: xcb,xlib,wayland device: 1
type: discrete-gpu name: NVIDIA GeForce RTX 3060 Laptop GPU driver: nvidia
v: 550.54.14 device-ID: 10de:2520 surfaces: xcb,xlib,wayland device: 2
type: cpu name: llvmpipe (LLVM 17.0.6 256 bits) driver: mesa llvmpipe
v: 24.0.2-arch1.2 (LLVM 17.0.6) device-ID: 10005:0000
surfaces: xcb,xlib,wayland
Device-1: Intel Tiger Lake-H HD Audio vendor: Tongfang Hongkong
driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_tgl
bus-ID: 00:1f.3 chip-ID: 8086:43c8 class-ID: 0403
Device-2: NVIDIA GA106 High Definition Audio vendor: Tongfang Hongkong
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:228e class-ID: 0403
Device-3: Fifine Microphone driver: hid-generic,snd-usb-audio,usbhid
type: USB rev: 1.1 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-1.2:4
chip-ID: 3142:5060 class-ID: 0300
API: ALSA v: k6.7.9-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: alsactl,alsamixer,amixer
Server-1: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Tiger Lake PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:43f0 class-ID: 0280
IF: wlo1 state: down mac: <filter>
Device-2: Realtek RTL8125 2.5GbE vendor: Tongfang Hongkong driver: r8169
v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 port: 3000 bus-ID: 2e:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: enp46s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
IF-ID-1: anbox0 state: down mac: <filter>
IF-ID-2: br-3736135ffeba state: down mac: <filter>
IF-ID-3: br-d30e7aa2761f state: up speed: 10000 Mbps duplex: unknown
mac: <filter>
IF-ID-4: docker0 state: down mac: <filter>
IF-ID-5: veth19a3c4a state: up speed: 10000 Mbps duplex: full
mac: <filter>
IF-ID-6: veth5bc61dd state: up speed: 10000 Mbps duplex: full
mac: <filter>
IF-ID-7: veth5ef0d41 state: up speed: 10000 Mbps duplex: full
mac: <filter>
IF-ID-8: veth6fa73ab state: up speed: 10000 Mbps duplex: full
mac: <filter>
IF-ID-9: veth70568fe state: up speed: 10000 Mbps duplex: full
mac: <filter>
IF-ID-10: veth78a7498 state: up speed: 10000 Mbps duplex: full
mac: <filter>
IF-ID-11: veth87fbf73 state: up speed: 10000 Mbps duplex: full
mac: <filter>
IF-ID-12: veth9645284 state: up speed: 10000 Mbps duplex: full
mac: <filter>
IF-ID-13: vetha8c414c state: up speed: 10000 Mbps duplex: full
mac: <filter>
IF-ID-14: vethee2053e state: up speed: 10000 Mbps duplex: full
mac: <filter>
Info: services: NetworkManager, nginx, smbd, systemd-networkd,
systemd-timesyncd, wpa_supplicant
Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-14:10 chip-ID: 8087:0026
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 1 state: down bt-service: enabled,running
rfk-block: hardware: no software: yes address: <filter> bt-v: 5.2 lmp-v: 11
status: discoverable: no pairing: no
Local Storage: total: 3.73 TiB used: 629.16 GiB (16.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:1 vendor: A-Data model: SX8200PNP
size: 1.86 TiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 42B9T6TB temp: 42.9 C
scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: A-Data model: SX8200PNP
size: 1.86 TiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 42B9T6TB temp: 40.9 C
scheme: GPT
ID-1: / raw-size: 1.86 TiB size: 1.86 TiB (100.00%) used: 629.16 GiB (33.0%)
fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:3
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
used: 571 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:2
ID-3: /home raw-size: 1.86 TiB size: 1.86 TiB (100.00%)
used: 629.16 GiB (33.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:3
ID-4: /var/log raw-size: 1.86 TiB size: 1.86 TiB (100.00%)
used: 629.16 GiB (33.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:3
ID-5: /var/tmp raw-size: 1.86 TiB size: 1.86 TiB (100.00%)
used: 629.16 GiB (33.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:3
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 62.54 GiB used: 1004 MiB (1.6%)
priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16
dev: /dev/zram0
System Temperatures: cpu: 61.0 C mobo: N/A
Fan Speeds (rpm): N/A
Memory: total: 64 GiB note: est. available: 62.54 GiB
used: 29.89 GiB (47.8%)
Processes: 684 Power: uptime: 1h 47m states: freeze,mem,disk
suspend: s2idle avail: deep wakeups: 0 hibernate: platform avail: shutdown,
reboot, suspend, test_resume image: 24.98 GiB
services: org_kde_powerdevil,upowerd Init: systemd v: 255
default: graphical tool: systemctl
Packages: pm: dpkg pkgs: 0 pm: pacman pkgs: 2386 libs: 564
tools: pamac,paru Compilers: clang: 17.0.6 gcc: 13.2.1 alt: 12
Shell: garuda-inxi default: fish v: 3.7.0 running-in: konsole inxi: 3.3.33
Garuda (2.6.23-1):
System install date:     2021-09-13
Last full system update: 2024-03-14 ↻
Is partially upgraded:   No
Relevant software:       timeshift NetworkManager mkinitcpio nvidia-dkms
Windows dual boot:       Probably (Run as root to verify)
Failed units:            anbox-container-manager.service systemd-networkd-wait-online.service

First of all, a reboot is pending.
Especially important if the migration to KDE 6 has just been performed.
Then, at the next loging, select an x11 session as opposed to wayland.
The panel issue is a known and reported KDE bug.
Ops, sorry, this was a different bug.
But disappearing panel was already mentioned amongst the KDE 6 issues…

1 Like

I have rebooted the computer multiple times after garuda-update, while trying to fix the top panel issue. I think the issue was Wayland causing problems.

Well I believe this topic can be closed. I already solved all the issues one by one, recreating the panel, reconfiguring the behaviour of some screens, setting the background image etc. OBS Studio and Discord is back again after selecting x11.

There is one extra bug I would like to talk about which is very annoying. I have two monitors.

When I right click on the top of one application, the window appears on a different monitor.

Also, the “Dolphin” file manager became transparent after the garuda-update, but it was opaque before. I’m trying to fix it but it’s always transparent

This issue is a known KDE bug/problem.
There are a few threads about that here on the forum, however there has been so many threads about the Plasma 6 update I am having a bit of difficulties finding it. :frowning:
Try reading the recent Plasma 6 threads, I’m sure you’ll land on a few people mentioning this.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.