MSI Fast Boot with Garuda

Even thought I have an SSD as my Root and /boot/efi partition, my computer took 1min to 1m30s to boot up, which is pretty slow. So I started looking for answers. I know that Windozes Fast Boot causes some issues with dual booting and when installing a new distro, But if I am not dual booting, And I don't have any plans to switch from garuda, can I use it to make my boot a bit faster? I tried it and Garuda worked with no issues and boot time was reduced by a few seconds I think. I didn't try it a lot because then I saw that my motherboard had a MSI Fast Boot option, and I tried that and now my computer booted up SUPER FAST taking only 30 seconds for the whole process.

The inprovement seemed mainly at the firmware and userspace level.
Time took without any sort of fast boot:

Startup finished in 42.135s (firmware) + 4.088s (loader) + 2.237s (kernel) + 26.057s (userspace) = 1min 14.518s 
graphical.target reached after 7.187s in userspace

Time took with MSI Fast Boot:

Startup finished in 15.884s (firmware) + 6.119s (loader) + 2.109s (kernel) + 6.075s (userspace) = 30.190s
graphical.target reached after 6.042s in userspace

As you can see that MSI Fast Boot shaved off 27s at firmware, and 20s in userspace!

Now this seems too good to be true, so my question is that can this cause any problems in the future? Has anyone tried this before?
I tried looking it up but didn't find anything about MSI Fast Boot.

1 Like

Looks like my old pc is much faster :wink:

Startup finished in 3.665s (kernel) + 9.126s (userspace) = 12.792s 
graphical.target reached after 5.455s in userspace

Post

systemd-analyze blame

And

inxi -Fza
2 Likes

systemd-analyze blame:

4.469s optimus-manager.service
3.554s NetworkManager-wait-online.service
2.797s linux-modules-cleanup.service
2.168s systemd-swap.service
1.561s mariadb.service
 823ms lvm2-monitor.service
 751ms ananicy.service
 496ms dev-sdb1.device
 325ms bluetooth.service
 323ms plymouth-deactivate.service
 322ms plymouth-quit-wait.service
 320ms plymouth-quit.service
 278ms [email protected]
 277ms systemd-journal-flush.service
 254ms wpa_supplicant.service
 237ms upower.service
 233ms [email protected]
 224ms ModemManager.service
 219ms [email protected]
 217ms systemd-random-seed.service
 161ms systemd-guest-user.service
 158ms polkit.service
 157ms [email protected]
 142ms NetworkManager.service
 141ms avahi-daemon.service
 137ms plymouth-start.service
 128ms systemd-remount-fs.service
 122ms udisks2.service
 116ms systemd-udev-trigger.service
 115ms home.mount
 113ms systemd-logind.service
 102ms systemd-modules-load.service
  93ms systemd-vconsole-setup.service
  90ms [email protected]\x2duuid-BD3A\x2d683F.service
  64ms dev-zram0.swap
  60ms systemd-udevd.service
  60ms systemd-binfmt.service
  57ms smb.service
  55ms dev-zram2.swap
  52ms systemd-tmpfiles-clean.service
  51ms boot-efi.mount
  50ms proc-sys-fs-binfmt_misc.mount
  48ms sys-kernel-config.mount
  48ms systemd-timesyncd.service
  38ms sys-fs-fuse-connections.mount
  37ms var-log.mount
  37ms var-tmp.mount
  35ms dev-zram3.swap
  33ms dev-zram1.swap
  30ms nmb.service
  30ms nmb.service

inxi -Fza:

System:    Kernel: 5.12.8-3-cacule x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-cacule
           root=UUID=f1fa8c94-888f-41ef-888d-27f6cf870468 rw [email protected] quiet splash
           rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1
           loglevel=3 sysrq_always_enabled=1
           Desktop: KDE Plasma 5.21.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
           Distro: Garuda Linux base: Arch Linux
Machine:   Type: Desktop Mobo: Micro-Star model: H310M PRO-VDH (MS-7B29) v: 1.0 serial: <filter>
           UEFI: American Megatrends v: 1.20 date: 03/30/2018
CPU:       Info: Quad Core model: Intel Core i3-8100 bits: 64 type: MCP arch: Kaby Lake
           note: check family: 6 model-id: 9E (158) stepping: B (11) microcode: DE cache:
           L2: 6 MiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 28800
           Speed: 2991 MHz min/max: 800/3600 MHz Core speeds (MHz): 1: 2991 2: 2936 3: 3222
           4: 2848
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled
           Type: mds mitigation: Clear CPU buffers; SMT disabled
           Type: meltdown mitigation: PTI
           Type: spec_store_bypass
           mitigation: Speculative Store Bypass disabled via prctl and seccomp
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW,
           STIBP: disabled, RSB filling
           Type: srbds mitigation: Microcode
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel 8th Gen Core Processor Gaussian Mixture Model vendor: Micro-Star MSI
           driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:3e91 class-ID: 0380
           Device-2: NVIDIA GP107 [GeForce GTX 1050 Ti] driver: nvidia v: 465.31
           alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1c82 class-ID: 0300
           Device-3: Logitech Webcam C310 type: USB driver: snd-usb-audio,uvcvideo
           bus-ID: 1-14:7 chip-ID: 046d:081b class-ID: 0102 serial: <filter>
           Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver:
           loaded: modesetting,nvidia display-ID: :0 screens: 1
           Screen-1: 0 s-res: 3286x1080 s-dpi: 101 s-size: 826x271mm (32.5x10.7")
           s-diag: 869mm (34.2")
           Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 102 size: 480x270mm (18.9x10.6")
           diag: 551mm (21.7")
           Monitor-2: DP-1-1 res: 1366x768 hz: 60 dpi: 85 size: 410x230mm (16.1x9.1")
           diag: 470mm (18.5")
           OpenGL: renderer: NVIDIA GeForce GTX 1050 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 465.31
           direct render: Yes
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Micro-Star MSI driver: snd_hda_intel
           v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
           chip-ID: 8086:a348 class-ID: 0403
           Device-2: NVIDIA GP107GL High Definition Audio driver: snd_hda_intel v: kernel
           bus-ID: 01:00.1 chip-ID: 10de:0fb9 class-ID: 0403
           Device-3: Logitech Webcam C310 type: USB driver: snd-usb-audio,uvcvideo
           bus-ID: 1-14:7 chip-ID: 046d:081b class-ID: 0102 serial: <filter>
           Sound Server-1: ALSA v: k5.12.8-3-cacule running: yes
           Sound Server-2: JACK v: 0.125.0 running: no
           Sound Server-3: PulseAudio v: 14.2 running: yes
           Sound Server-4: PipeWire v: 0.3.28 running: yes
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
           vendor: Micro-Star MSI driver: r8169 v: kernel port: 4000 bus-ID: 02:00.0
           chip-ID: 10ec:8168 class-ID: 0200
           IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
           Device-2: Realtek RTL8188EE Wireless Network Adapter driver: rtl8188ee v: kernel
           port: 3000 bus-ID: 03:00.0 chip-ID: 10ec:8179 class-ID: 0280
           IF: wlp3s0 state: up mac: <filter>
Bluetooth: Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB driver: btusb
           v: 0.8 bus-ID: 1-6:5 chip-ID: 0a12:0001 class-ID: e001
           Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:    Local Storage: total: 1.72 TiB used: 69.58 GiB (3.9%)
           SMART Message: Unable to run smartctl. Root privileges required.
           ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000DX001-1NS162-SSHD
           size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
           rotation: 7200 rpm serial: <filter> rev: HP76 scheme: GPT
           ID-2: /dev/sdb maj-min: 8:16 vendor: Gigabyte model: GP-GSTFS31240GNTD
           size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
           rotation: SSD serial: <filter> rev: 61.2 scheme: GPT
           ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: HP model: v221w size: 14.86 GiB
           block-size: physical: 512 B logical: 512 B serial: <filter> rev: 1100 scheme: MBR
           SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
           ID-4: /dev/sdd maj-min: 8:48 type: USB vendor: Western Digital
           model: WD6400BPVT-16HXZT1 size: 596.17 GiB block-size: physical: 512 B logical: 512 B
           rotation: 5400 rpm serial: <filter> rev: 2.12 scheme: GPT
Partition: ID-1: / raw-size: 210.53 GiB size: 210.53 GiB (100.00%) used: 37.95 GiB (18.0%)
           fs: btrfs dev: /dev/sdb1 maj-min: 8:17
           ID-2: /boot/efi raw-size: 13.04 GiB size: 13.03 GiB (99.90%) used: 576 KiB (0.0%)
           fs: vfat dev: /dev/sdb2 maj-min: 8:18
           ID-3: /home raw-size: 931.51 GiB size: 931.51 GiB (100.00%) used: 31.63 GiB (3.4%)
           fs: btrfs dev: /dev/sda1 maj-min: 8:1
           ID-4: /var/log raw-size: 210.53 GiB size: 210.53 GiB (100.00%)
           used: 37.95 GiB (18.0%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
           ID-5: /var/tmp raw-size: 210.53 GiB size: 210.53 GiB (100.00%)
           used: 37.95 GiB (18.0%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
Swap:      Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
           ID-1: swap-1 type: zram size: 3.88 GiB used: 0 KiB (0.0%) priority: 32767
           dev: /dev/zram0
           ID-2: swap-2 type: zram size: 3.88 GiB used: 0 KiB (0.0%) priority: 32767
           dev: /dev/zram1
           ID-3: swap-3 type: zram size: 3.88 GiB used: 0 KiB (0.0%) priority: 32767
           dev: /dev/zram2
           ID-4: swap-4 type: zram size: 3.88 GiB used: 0 KiB (0.0%) priority: 32767
           dev: /dev/zram3
Sensors:   System Temperatures: cpu: 56.0 C mobo: N/A gpu: nvidia temp: 46 C
           Fan Speeds (RPM): N/A gpu: nvidia fan: 40%
Info:      Processes: 262 Uptime: 45m wakeups: 0 Memory: 15.51 GiB used: 4.15 GiB (26.7%)
           Init: systemd v: 248 tool: systemctl Compilers: gcc: 11.1.0 clang: 11.1.0 Packages:
           pacman: 1692 lib: 487 flatpak: 0 Shell: fish v: 3.2.2 running-in: alacritty
           inxi: 3.3.04

My PC took 3min before but it was fairly easy to drop the boot time to where it is now. I created another post before where I talked about how I did it.
I am using an SSD as root and /boot/efi but still boot is slow for some reason? Am I doing something wrong?

Kernel version?

Perhaps others may differ.

1 Like

Linux Cacule: 5.12.8

Ya, I saw that in your inxi output.

That's not exactly a standard kernel.

I was meaning, have you tested perhaps the regular linux kernel or perhaps the LTS kernel instead for comparison.

1 Like

I tried the LTS Kernel with MSI Fast Boot and this is the result:

Startup finished in 15.916s (firmware) + 6.061s (loader) + 2.652s (kernel) + 7.227s (userspace) = 31.857s
graphical.target reached after 7.227s in userspace

TBH, I expected there to be a bigger difference than 1s between Cacule and LTS.

My GRUB doesn't take any input with MSI Fast Boot. Probably due to MSI not enabling USBs and SATAs on boot.

I used systemctl reboot --firmware-setup. I disabled MSI Fast Boot to get my keyboard working at boot again, and without MSI Fast Boot my boot time doubled :(. I will try to find a way to make MSI detect USBs on boot so that my keyboard and mouse work.

Fast boot is not the answer to your problem as you already see it bypasses hardware . The answer is to find what is slowing boot and fixing it a simple cheat code in grub usually solves the problem read the arch wiki their is lots on Kaby Lake problems with boot

1 Like

I was trying to do that before and I did make progress, I saved boot down from 3min to 1min, but now I found this and I do like it very much. I also found a setting in bios which allows my to get into the bios by holding down the power button for 4 seconds, so the hardware isn't that much of a problem anymore.

1 Like

Fast boot is a windows only application to use with Windows 8/10 it stops all hardware from booting till it reaches the login window now unless Garuder has changed to win10 it is useless the board is made for windows no Linux support what so ever.
AS i said in my last post read the cheat codes for grub and find the ones applicable to you then it will boot in 6 to 10 secs or like mine with a similar motherboard i5 6.5 secs, with a SSD.

3 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.