Mr.Mine broke after installing Java

After I've installed and updated Java (Java programs that I needed do work, so it's most likely properly installed) Javascript programs decided to no longer work. The issue actually is with a game called Mr. Mine, which without Java installed it worked fine and well and everything, but after installing Java it no longer wants to launch. I tried to google a little but I can't seem to find anything similar, and found that Java and Javascript have nothing to do with each other, so I'm now completely confused.

I did not have this problem on Linux Mint - I installed Java and Mr. Mine worked despite that, but here, on Garuda, it doesn't. Proton does not help it in any way, and the game also ran without Proton to begin with. There were no changes whatsoever to my system before installing Java; I've actually restarted my PC after installing Gimp (which was the last thing I've done before installing Java) and launched the game just fine.

I've followed this to install Java:

Guess I'll spend plenty of time in this forum, unlike on Mint forum where I asked like one question. xD
Thank you in advance.

This has nothing to do with garuda. Java has nothing to do with Javascript. You are better off searching proton/lutris db and forums for assistance.

2 Likes

I mean, it literally happened after I installed Java. Also, feels like you haven't read my message at all.

Ah right I forgot you weren't using proton. Either way you need to check the game's community for this. This is beyond the scope of garuda.

3 Likes

Ok, after toying a little, I realized that something's wrong. At first everything worked, but it seems that after restarting my PC I'm getting an error:

Exception in thread "main" java.awt.AWTError: Assistive Technology not found: org.GNOME.Accessibility.AtkWrapp
er
at java.desktop/java.awt.Toolkit.newAWTError(Toolkit.java:473)
at java.desktop/java.awt.Toolkit.fallbackToLoadClassForAT(Toolkit.java:489)
at java.base/java.util.stream.ForEachOps$ForEachOp$OfRef.accept(ForEachOps.java:183)
at java.base/java.util.stream.ReferencePipeline$2$1.accept(ReferencePipeline.java:177)
at java.base/java.util.HashMap$KeySpliterator.forEachRemaining(HashMap.java:1694)
at java.base/java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:484)
at java.base/java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:474)
at java.base/java.util.stream.ForEachOps$ForEachOp.evaluateSequential(ForEachOps.java:150)
at java.base/java.util.stream.ForEachOps$ForEachOp$OfRef.evaluateSequential(ForEachOps.java:173)
at java.base/java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234)
at java.base/java.util.stream.ReferencePipeline.forEach(ReferencePipeline.java:497)
at java.desktop/java.awt.Toolkit.loadAssistiveTechnologies(Toolkit.java:537)
at java.desktop/java.awt.Toolkit.getDefaultToolkit(Toolkit.java:598)
at java.desktop/javax.swing.UIManager.getSystemLookAndFeelClassName(UIManager.java:660)
at com.dabomstew.pkrandom.gui.RandomizerGUI.main(RandomizerGUI.java:131)
Caused by: java.lang.ClassNotFoundException: org.GNOME.Accessibility.AtkWrapper
at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:606)
at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:168)
at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:522)
at java.base/java.lang.Class.forName0(Native Method)
at java.base/java.lang.Class.forName(Class.java:468)
at java.desktop/java.awt.Toolkit.fallbackToLoadClassForAT(Toolkit.java:486)
... 13 more

Searching in the internet, they're saying to edit "accessibility.properties", though I don't seem to have it because using sudo vim /etc/java-8-openjdk/accessibility.properties opens an empty file. Does anyone have any idea what to do?

Literally all I can find is to modify that accessibility file, but I don't have it.

Ok, so I tried to delete Java altogether, and I did that, but there are still java things on my PC... Is there any list of things I should remove after removing Java itself?

So I found also this:

java may be found in the following packages:
extra/java-runtime-common 3-3 /usr/bin/java
extra/jdk7-openjdk 7.u261_2.6.22-1 /usr/lib/jvm/java-7-openjdk/bin/java
extra/jdk8-openjdk 8.u292-1 /usr/lib/jvm/java-8-openjdk/bin/java
extra/jre-openjdk-headless 15.0.2.u7-1 /usr/lib/jvm/java-15-openjdk/bin/java
extra/jre11-openjdk-headless 11.0.11.u9-1 /usr/lib/jvm/java-11-openjdk/bin/java
extra/jre7-openjdk-headless 7.u261_2.6.22-1 /usr/lib/jvm/java-7-openjdk/jre/bin/java
extra/jre8-openjdk-headless 8.u292-1 /usr/lib/jvm/java-8-openjdk/jre/bin/java
chaotic-aur/android-studio 4.2.1.0-1 /opt/android-studio/jre/bin/java
chaotic-aur/bitwig-studio 3.3.8-1 /opt/bitwig-studio/lib/jre/bin/java
chaotic-aur/clion-eap-jre 212.3724.2-1 /opt/clion-eap/jbr/bin/java
chaotic-aur/clion-jre 1:2021.1.2-1 /opt/clion/jbr/bin/java
chaotic-aur/eclipse-cpp 2:4.18-2 /usr/lib/eclipse/plugins/org.eclipse.justj.ope
njdk.hotspot.jre.full.linux.x86_64_15.0.1.v20201027-0507/jre/bin/java
chaotic-aur/eclipse-java 2:4.18-2 /usr/lib/eclipse/plugins/org.eclipse.justj.ope
njdk.hotspot.jre.full.linux.x86_64_15.0.1.v20201027-0507/jre/bin/java
chaotic-aur/eclipse-javascript 2:4.18-2 /usr/lib/eclipse/plugins/org.eclipse.justj.ope
njdk.hotspot.jre.full.linux.x86_64_15.0.1.v20201027-0507/jre/bin/java
chaotic-aur/eclipse-jee 2:4.18-2 /usr/lib/eclipse/plugins/org.eclipse.justj.ope
njdk.hotspot.jre.full.linux.x86_64_15.0.1.v20201027-0507/jre/bin/java
chaotic-aur/eclipse-rust 2:4.18-2 /usr/lib/eclipse/plugins/org.eclipse.justj.ope
njdk.hotspot.jre.full.linux.x86_64_15.0.1.v20201027-0507/jre/bin/java
chaotic-aur/fiji-bin 2:20201104.1356-1 /opt/fiji/java/linux-amd64/zulu8.48.0.53-ca-fx
-jdk8.0.265-linux_x64/jre/bin/java
chaotic-aur/intellij-idea-ultimate-edition-jre 2021.1.2-1 /opt/intellij-idea-ultimate-edition/jbr/bin/ja
va
chaotic-aur/java-openjdk-ea-bin 17b16-1 /usr/lib/jvm/java-17-openjdk/bin/java
chaotic-aur/jre8 8u291-1 /usr/lib/jvm/java-8-jre/jre/bin/java
chaotic-aur/phpstorm-eap-jre 211.7442.50-1 /opt/phpstorm-eap/jbr/bin/java
chaotic-aur/pycharm-community-eap 10:2021.1.2.211.7442.45-1 /opt/pycharm-community-eap/jbr/bin/java
chaotic-aur/pycharm-professional 2021.1.2-1 /opt/pycharm-professional/jbr/bin/java
chaotic-aur/quartus-130 13.0.1.232-1 /opt/altera130/quartus/linux/jre/bin/java
chaotic-aur/quartus-130 13.0.1.232-1 /opt/altera130/quartus/linux64/jre/bin/java
chaotic-aur/quartus-130 13.0.1.232-1 /opt/altera130/quartus/linux64/jre64/bin/java
chaotic-aur/quartus-free-130 13.0.1.232-3 /opt/altera/13.0sp1/quartus/linux/jre/bin/java
chaotic-aur/quartus-free-130 13.0.1.232-3 /opt/altera/13.0sp1/quartus/linux64/jre/bin/ja
va
chaotic-aur/quartus-free-130 13.0.1.232-3 /opt/altera/13.0sp1/quartus/linux64/jre64/bin/
java
chaotic-aur/quartus-free-quartus 20.1.1.720-1 /opt/intelFPGA/20.1/quartus/linux64/jre64/bin/
java
chaotic-aur/ums 10.6.0-1 /opt/ums/jre8/bin/java
chaotic-aur/yozo-office 8.0.1331.101ZH.S1-3 /opt/Yozosoft/Yozo_Office/Jre/bin/java

But I can't seem to remove it in any way. Any tips?

This does not appear to be in the repos or in the AUR. What is it?

What version of Java did you install, which version does the software require, and what output do you get when running it from within a terminal?

4 Likes

Check your program/game user manual and installation instructions and prerequisities. What do they advise?

Or try Archwiki

3 Likes

Okay, so I went to eat something and then smashed the uninstall command by accident again because I thought I missed something. And I was right, I did miss something and now everything works. Thank you for at least trying to help, and sorry for being that dumb...

That is not a solution, sorry.

1 Like

Yeah, sorry. The fix was me not using sudo pacman -Rdd jr9-openjdk-headless (chose to remove Java). Did that and everything worked. Though, the game just opened once and then didn't want to open again, so it was not the issue of Java but the game itself, and I did get a response that the game likes to not launch at all, but I was able to launch it with 99% of success on Mint. Contacted the developers of the game because there was an update today for the game as well, so it might've broken something.

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.