Mpv not working when switched from hybrid to nvidia in optimus manager

I have problem with mpv , it is not opening when switched hybrid to nvidia in optimus manager , when I tried to open it through terminal , so that i could see what is the problem ,
it shows me this :

[email protected] in ~
 ╰─λ mpv 2021-06-22\ 16-19-04.mkv
 (+) Video --vid=1 (*) (h264 1920x1080 30.000fps)
 (+) Audio --aid=1 (*) 'Track1' (aac 2ch 48000Hz)
GPU at BusId 0x1 doesn't have a supported video decoder
fish: Job 1, 'mpv 2021-06-22\ 16-19-04.mkv' terminated by signal SIGFPE (Floating point exception)

 ╭─[email protected] in ~ took 697ms
[⚡] ×

Please help because i get more performance in Nvidia mode instead of hybrid so i don't want to switch!!

inxi -Fxxxza


 ╭─[email protected] in ~ took 30ms
 ╰─λ inxi -Fxxxza
System:    Kernel: 5.14.9-204-tkg-pds x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: intel_pstate=passive BOOT_IMAGE=/@/boot/vmlinuz-linux-tkg-pds
           root=UUID=77438ce7-4125-4f45-bfc9-a7a802bb0680 rw [email protected] loglevel=3 quiet
           splash sysrq_always_enabled=1 systemd.unified_cgroup_hierarchy=1
           Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
           Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: Dell product: Inspiron 7570 v: N/A serial: <filter> Chassis:
           type: 10 serial: <filter>
           Mobo: Dell model: 06K08K v: A00 serial: <filter> UEFI: Dell v: 1.16.0
           date: 02/17/2020
Battery:   ID-1: BAT0 charge: 15.6 Wh (85.2%) condition: 18.3/42.0 Wh (43.5%) volts: 12.8
           min: 11.4 model: Samsung SDI DELL CYMGM79 type: Li-ion serial: <filter>
           status: Charging
           Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard serial: <filter>
           charge: 55% (should be ignored) rechargeable: yes status: Discharging
CPU:       Info: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP arch: Kaby Lake
           note: check family: 6 model-id: 8E (142) stepping: A (10) microcode: EA cache:
           L2: 8 MiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 32026
           Speed: 3302 MHz min/max: 400/4000 MHz Core speeds (MHz): 1: 3302 2: 3612 3: 3776
           4: 3592 5: 3672 6: 3722 7: 3776 8: 3757
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable
           Type: meltdown mitigation: PTI
           Type: spec_store_bypass
           mitigation: Speculative Store Bypass disabled via prctl and seccomp
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW,
           STIBP: conditional, RSB filling
           Type: srbds mitigation: Microcode
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel UHD Graphics 620 vendor: Dell driver: i915 v: kernel bus-ID: 00:02.0
           chip-ID: 8086:5917 class-ID: 0300
           Device-2: NVIDIA GM108M [GeForce 940MX] vendor: Dell driver: nvidia v: 470.74
           alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:134d class-ID: 0302
           Device-3: Sunplus Innovation Integrated_Webcam_HD type: USB driver: uvcvideo
           bus-ID: 1-5:2 chip-ID: 1bcf:28c1 class-ID: 0e02
           Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver:
           loaded: modesetting,nvidia display-ID: :0 screens: 1
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
           s-diag: 582mm (22.9")
           Monitor-1: eDP-1-1 res: 1920x1080 dpi: 142 size: 344x194mm (13.5x7.6")
           diag: 395mm (15.5")
           OpenGL: renderer: NVIDIA GeForce 940MX/PCIe/SSE2 v: 4.6.0 NVIDIA 470.74
           direct render: Yes
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell driver: snd_hda_intel
           v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3 chip-ID: 8086:9d71 class-ID: 0403
           Sound Server-1: ALSA v: k5.14.9-204-tkg-pds running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: yes
           Sound Server-4: PipeWire v: 0.3.38 running: yes
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Dell
           driver: r8169 v: kernel port: d000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
           IF: enp2s0 state: down mac: <filter>
           Device-2: Intel Wireless 7265 driver: iwlwifi v: kernel port: d000 bus-ID: 03:00.0
           chip-ID: 8086:095a class-ID: 0280
           IF: wlp3s0 state: down mac: <filter>
           IF-ID-1: enp0s20f0u1 state: unknown speed: -1 duplex: half mac: <filter>
Bluetooth: Device-1: T & A Mobile Phones Android type: USB driver: rndis_host v: kernel
           bus-ID: 1-1:8 chip-ID: 1bbb:af10 class-ID: 0a00 serial: <filter>
           Device-2: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
           bus-ID: 1-7:3 chip-ID: 8087:0a2a class-ID: e001
           Report: ID: hci0 rfk-id: 0 state: down bt-service: enabled,running rfk-block:
           hardware: no software: yes address: <filter>
RAID:      Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci v: 3.0
           port: f060 bus-ID: 00:17.0 chip-ID: 8086.282a rev: 21 class-ID: 0104
Drives:    Local Storage: total: 1.14 TiB used: 52.34 GiB (4.5%)
           SMART Message: Unable to run smartctl. Root privileges required.
           ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM035-1RK172
           size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
           type: HDD rpm: 5400 serial: <filter> rev: SDM3 scheme: GPT
           ID-2: /dev/sdb maj-min: 8:16 vendor: Micron model: 1100 SATA 256GB size: 238.47 GiB
           block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: SSD
           serial: <filter> rev: L003 scheme: GPT
Partition: ID-1: / raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 52.34 GiB (5.6%)
           fs: btrfs dev: /dev/sda2 maj-min: 8:2
           ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 560 KiB (0.2%)
           fs: vfat dev: /dev/sda1 maj-min: 8:1
           ID-3: /home raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 52.34 GiB (5.6%)
           fs: btrfs dev: /dev/sda2 maj-min: 8:2
           ID-4: /var/log raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 52.34 GiB (5.6%)
           fs: btrfs dev: /dev/sda2 maj-min: 8:2
           ID-5: /var/tmp raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 52.34 GiB (5.6%)
           fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 50 (default 100)
           ID-1: swap-1 type: zram size: 7.51 GiB used: 0 KiB (0.0%) priority: 100
           dev: /dev/zram0
Sensors:   System Temperatures: cpu: 61.0 C mobo: N/A gpu: nvidia temp: 60 C
           Fan Speeds (RPM): cpu: 3710
Info:      Processes: 274 Uptime: 19m wakeups: 6 Memory: 7.51 GiB used: 3 GiB (39.9%)
           Init: systemd v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages:
           pacman: 1731 lib: 471 Shell: fish v: 3.3.1 running-in: alacritty inxi: 3.3.06

 ╭─[email protected] in ~ took 2s
 ╰─λ

Thanks.

How have you configured mpv?

i have not configured for any thing , it is the same as it was installed by default.
just replaced to mpv full , when i saw that it is not working , but it is still not working.

1 Like

Do other applications work on the dGPU? e.g. does nvidia-smi report the card correctly?

Do you have the necessary packages installed for hardware acceleration of video in mpv?

2 Likes

actually i tried to solve this thing , but it was very complicated then i removed all nvidia drivers and installed everything manually , then i switched to nvidia prime and vollah , I am getting more stability and i have low CPU usage now less heat is released ( Just i face some lag after starting my PC for around 20 seconds and then its working better) , I don't think I will try again optimus manager :sweat_smile:

Well, Thanks for help! :blush:

1 Like

I also don't see the point in third-party tools given render offloading is built in to the Nvidia driver now. :man_shrugging:

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.