Mouse stops responding after about 3 seconds of inactivity

Hey, after a update my mouse stops working after about 3 seconds of inactivity and only comes back to life if i press a button, is there something i could do to prevent such an waste of time? Also already looked into energy settings etc. but i found nothing that could be the problem in there
inxi:

System:
  Kernel: 5.19.15-hardened2-1-hardened arch: x86_64 bits: 64 compiler: gcc
    v: 12.2.0 parameters: pti=on page_alloc.shuffle=1
    BOOT_IMAGE=/@/boot/vmlinuz-linux-hardened
    root=UUID=d16ddc96-5d12-402f-bbcb-9fa585484f0b rw [email protected]
    cryptdevice=UUID=3c647ba3-56c7-43a5-bafc-5f6213b05312:luks-3c647ba3-56c7-43a5-bafc-5f6213b05312
    root=/dev/mapper/luks-3c647ba3-56c7-43a5-bafc-5f6213b05312
    rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
  Desktop: KDE Plasma v: 5.26.0 tk: Qt v: 5.15.6 info: latte-dock
    wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: LENOVO product: 82C7 v: Lenovo V15-ADA
    serial: <superuser required> Chassis: type: 10 v: Lenovo V15-ADA
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: No DPK serial: <superuser required>
    UEFI: LENOVO v: E8CN30WW date: 07/28/2021
Battery:
  ID-1: BAT0 charge: 34.5 Wh (99.4%) condition: 34.7/35.3 Wh (98.2%)
    volts: 8.6 min: 7.6 model: CPT-COS L16C2PB1 type: Li-poly serial: <filter>
    status: not charging cycles: 68
CPU:
  Info: model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx bits: 64
    type: MT MCP arch: Zen/Zen+ note: check gen: 1 level: v3 note: check
    built: 2019 process: GF 12nm family: 0x17 (23) model-id: 0x18 (24)
    stepping: 1 microcode: 0x8108109
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 384 KiB desc: d-4x32 KiB; i-4x64 KiB L2: 2 MiB desc: 4x512 KiB
    L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 2361 high: 2762 min/max: 1400/2100 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2743 2: 2761
    3: 2762 4: 2754 5: 1400 6: 1231 7: 2477 8: 2761 bogomips: 33550
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT vulnerable
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    disabled, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Mobile Series]
    vendor: Lenovo driver: amdgpu v: kernel arch: GCN-5 code: Vega
    process: GF 14nm built: 2017-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
    ports: active: HDMI-A-1,eDP-1 empty: none bus-ID: 03:00.0
    chip-ID: 1002:15d8 class-ID: 0300 temp: 40.0 C
  Device-2: WCM_USB WEB CAM type: USB driver: snd-usb-audio,uvcvideo
    bus-ID: 1-3.3:11 chip-ID: 1c3f:2002 class-ID: 0102
  Device-3: IMC Networks Integrated Camera type: USB driver: uvcvideo
    bus-ID: 3-1:2 chip-ID: 13d3:5a08 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
    compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
    alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x285mm (40.00x11.22")
    s-diag: 1055mm (41.54")
  Monitor-1: HDMI-A-1 mapped: HDMI-A-0 pos: primary,left
    model: Samsung C24F390 serial: <filter> built: 2019 res: 1920x1080 hz: 60
    dpi: 94 gamma: 1.2 size: 521x293mm (20.51x11.54") diag: 598mm (23.5")
    ratio: 16:9 modes: max: 1920x1080 min: 720x400
  Monitor-2: eDP-1 mapped: eDP pos: right model: BOE Display 0x0812
    built: 2018 res: 1920x1080 hz: 60 dpi: 142 gamma: 1.2
    size: 344x194mm (13.54x7.64") diag: 395mm (15.5") ratio: 16:9 modes:
    max: 1920x1080 min: 640x480
  OpenGL: renderer: AMD Radeon Vega 8 Graphics (raven LLVM 14.0.6 DRM 3.47
    5.19.15-hardened2-1-hardened) v: 4.6 Mesa 22.2.1 direct render: Yes
Audio:
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel bus-ID: 1-3.3:11 pcie: chip-ID: 1c3f:2002
    gen: 3 class-ID: 0102 speed: 8 GT/s lanes: 16 bus-ID: 03:00.1
    chip-ID: 1002:15de class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Lenovo
    driver: snd_pci_acp3x v: kernel
    alternate: snd_rn_pci_acp3x,snd_pci_acp5x,snd_pci_acp6x,snd_acp_pci,snd_sof_amd_renoir
    pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 03:00.5 chip-ID: 1022:15e2
    class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 03:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Device-4: WCM_USB WEB CAM type: USB driver: snd-usb-audio,uvcvideo
  Device-5: JMTek LLC. USB PnP Audio Device type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-3.4.2:8
    chip-ID: 0c76:161e class-ID: 0300
  Sound API: ALSA v: k5.19.15-hardened2-1-hardened running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
  Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
    vendor: Lenovo driver: ath10k_pci v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 bus-ID: 02:00.0 chip-ID: 168c:003e class-ID: 0280
  IF: wlp2s0 state: down mac: <filter>
  Device-2: ASIX AX88179 Gigabit Ethernet type: USB driver: ax88179_178a
    bus-ID: 2-3.4.3:5 chip-ID: 0b95:1790 class-ID: ff00 serial: <filter>
  IF: enp3s0f3u3u4u3 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
  Device-1: Qualcomm Atheros QCA61x4 Bluetooth 4.0 type: USB driver: btusb
    v: 0.8 bus-ID: 3-2:3 chip-ID: 0cf3:e300 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 2 state: down
    bt-service: enabled,running rfk-block: hardware: no software: yes
    address: <filter>
Drives:
  Local Storage: total: 1.38 TiB used: 280.25 GiB (19.9%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: MZALQ512HALU-000L2 size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: BL2QFXV7 temp: 24.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Crucial model: CT1000BX500SSD1
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 054
Partition:
  ID-1: / raw-size: 467.84 GiB size: 467.84 GiB (100.00%) used: 280.25 GiB
    (59.9%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-3c647ba3-56c7-43a5-bafc-5f6213b05312
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 736 KiB
    (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 467.84 GiB size: 467.84 GiB (100.00%) used: 280.25
    GiB (59.9%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-3c647ba3-56c7-43a5-bafc-5f6213b05312
  ID-4: /var/log raw-size: 467.84 GiB size: 467.84 GiB (100.00%) used: 280.25
    GiB (59.9%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-3c647ba3-56c7-43a5-bafc-5f6213b05312
  ID-5: /var/tmp raw-size: 467.84 GiB size: 467.84 GiB (100.00%) used: 280.25
    GiB (59.9%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-3c647ba3-56c7-43a5-bafc-5f6213b05312
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 17.45 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  ID-2: swap-2 type: partition size: 8.8 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/dm-1 maj-min: 254:1
    mapped: luks-48d04c79-6793-4578-a7bd-b7f3baa922dc
Sensors:
  System Temperatures: cpu: 40.5 C mobo: N/A gpu: amdgpu temp: 40.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 295 Uptime: 1h 11m wakeups: 71 Memory: 17.45 GiB used: 4.86 GiB
  (27.9%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman pkgs: 1477
  libs: 375 tools: octopi,paru Shell: Bash v: 5.1.16 running-in: konsole
  inxi: 3.3.22
e[1;34mGaruda (2.6.8-1):e[0m
e[1;34m  System install date:e[0m     2022-06-18
e[1;34m  Last full system update:e[0m 2022-10-14 e[1;31m↻
e[1;34m  Is partially upgraded:  e[0m No
e[1;34m  Relevant software:      e[0m NetworkManager
e[1;34m  Windows dual boot:      e[0m Probably (Run as root to verify)
e[1;34m  Snapshots:              e[0m Snapper
e[1;34m  Failed units:           e[0m 

have you tried different kernels yet?
does the same thing happen

2 Likes

i did not, i've almost always used hardened and neither the mouse nor the usb hub is new since the update

so which of the updates do you think broke your current configuration then?

i just tried zen and it did not happen there, oddly enough, now back to hardened the mouse is not doing that again, and i do not have any clue what happened nor why... i guess thank you?

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.