Mouse lagging on 2013 Macbook (v10)

I’m getting something very similar to these mouse problems here.

Something is wrong with timing at which KDE/Linux is either pulling or pushing the values to … the device file?

The problem is mainly in the smoothness of the mouse motion. When drawing small/medium circles with the mouse, I almost never see circles in the cursor motion on screen. And quite predictably, if you drag the mouse over KDE UI elements like drop downs that light up or interact, this causes the mouse to slow down.

Strangely, when the mouse cursor travels from being on top of one window to another window, this seems to trigger the delay/slowdown in mouse cursor motion. So scrolling from one side of the screen to another is never smooth and this is unusable.

I think that the system is exhibiting problems of the same nature with the touchpad, but the resulting cursor motion is smooth because of some differences in how touchpad/mouse device files store their values (as to what specific differences in device files IDK…) in other words the touchpad motion feels smooth but the choppiness is still there. The cursor’s resulting motion isn’t affected and thrown off the curve like with the mouse though.

I don’t really know where to start looking. This seemed to be happening on the Sway & KDE live USB’s. It may be a wayland issue. I checked compositing options. I removed blur/transparency from konsole & will do the same as far as I can with KDE but previous experience has taught me that one does not simply turn off KDE transparency…

(My poor GPU… it will be over soon I swear. Do pass gently into that sweet night)

Have you tested a different mouse to eliminate a hardware issue. You never mentioned if the mouse was wireless. Is it a Bluetooth mouse? Have you tested a wired mouse? Are you using a 4K resolution?

You would be best to post inxi -Faz

3 Likes

It is a Razer Basilisk RZ01-0233. I typically do not use wireless/Bluetooth input devices, esp. keyboards.

I just tested with an older optical mouse, which works flawlessly. Hmmm… on my older Garuda I did not need special drivers for the Razer device.

Let me see what I can find.

2 Likes

There maybe software for your Razer model in the AUR. You will need to search there. I do not use their products, so I'm not fully aware of their requirements.

2 Likes

DId you try what worked for me?

"I found the fix,
Get a new charger seriously it works on unplugging it"

The compositor has options for different level of smoothness and latencies check that. Try going for prefer lowest latency if that helps

1 Like

I am running a summer 2013 Macbook (v10)

Actually, the new optical mouse only solved some of the problems. It’s still slowing when the cursor crosses KDE/Qt UI elements.

To explain why I’m a bit slow to respond here: I’m still getting everything like Emacs setup, so I’m in the classic noob Linux situation of “I know! I’ll just use XYZ … oh it’s not installed/configured yet”. And Neovim deleted the Org installation notes I was taking.

I also keep getting shut out of my login session and need to reset it with “login to unlock-session 2”, but when I do I can’t open windows. I have downloaded SystemdGenie and there is probably a service that needs to be restarted.

I may switch to sway, but I need to figure out Wacom compatibility and a few other things.

I have changed the heading, as it looks so far, the fault is not with Garuda KDE.

Read

please
and post terminal in- and output from

inxi -Fza

as text!

Even if you personally think it is unnecessary.

1 Like

You can never know... Maybe you can find some useful utility in AUR.

Another test can be to disable some power/performance utility that may be causing this.
I had something similar, that was greatly improved stopping/disabling ananicy service.

3 Likes

You never answered this question.

The reason I asked is because I experienced sluggish responsiveness on 4K displays about a year ago. I forget exactly what configuration files I had to change to correct that issue.

1 Like

Sorry, I will update the thread soon with the requested details. I am visiting family and haven’t had much access to my laptop.

Installing =nouveau-fw= via yay solved most of the problems with responsiveness. I expect that installing a few Razer-specific packages will solve the rest.

My graphics card is old. This ended up being mostly a compositing issue, not an input issue. I will still post my inxi output when I get my laptop set up enough to get into my password files.

No, it is not a 4K resolution, although sometimes I drive an external monitor at 4K.

It's possible that could be a contributing factor.

ever since i installed nouveau-fw everything has been improving. the interactivity issues i was having with the mouse have completely ceased.

here is the output to ixni -Fza:

System:    Kernel: 5.13.4-zen2-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=bdd84505-f371-4ecc-ac02-91797be83798 rw 
rootflags=subvol=@ quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
systemd.unified_cgroup_hierarchy=1 loglevel=3 
Desktop: KDE Plasma 5.22.3 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux 
base: Arch Linux 
Machine:   Type: Laptop System: Apple product: MacBookPro11,3 v: 1.0 serial: <filter> Chassis: type: 10 
v: Mac-2BD1B31983FE1663 serial: <filter> 
Mobo: Apple model: Mac-2BD1B31983FE1663 v: MacBookPro11,3 serial: <filter> UEFI: Apple v: 430.0.0.0.0 
date: 12/17/2020 
Battery:   ID-1: BAT0 charge: 54.5 Wh (97.0%) condition: 56.2/95.4 Wh (58.9%) volts: 12.3 min: 11.3 model: DP bq20z451 
type: Li-ion serial: N/A status: Full cycles: 1617 
CPU:       Info: Quad Core model: Intel Core i7-4850HQ bits: 64 type: MT MCP arch: Haswell family: 6 model-id: 46 (70) 
stepping: 1 microcode: 1C cache: L2: 6 MiB 
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 36718 
Speed: 2686 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 2686 2: 2446 3: 2408 4: 2454 5: 2478 6: 2484 7: 2524 
8: 2322 
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
Type: meltdown mitigation: PTI 
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
Type: srbds mitigation: Microcode 
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: NVIDIA GK107M [GeForce GT 750M Mac Edition] vendor: Apple driver: nouveau v: kernel bus-ID: 01:00.0
chip-ID: 10de:0fe9 class-ID: 0300
Device-2: Logitech Webcam C930e type: USB driver: snd-usb-audio,uvcvideo bus-ID: 1-5:3 chip-ID: 046d:0843
class-ID: 0102 serial: <filter>
Display: x11 server: X.Org 1.20.12 compositor: kwin_x11 driver: loaded: nouveau unloaded: modesetting
alternate: fbdev,nv,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x3960 s-dpi: 96 s-size: 1015x1046mm (40.0x41.2") s-diag: 1458mm (57.4")
Monitor-1: eDP-1 res: 2880x1800 hz: 60 dpi: 221 size: 331x207mm (13.0x8.1") diag: 390mm (15.4")
Monitor-2: HDMI-1 res: 3840x2160 hz: 30 dpi: 160 size: 608x345mm (23.9x13.6") diag: 699mm (27.5")
OpenGL: renderer: NVE7 v: 4.3 Mesa 21.1.5 direct render: Yes
Audio:     Device-1: Intel 8 Series/C220 Series High Definition Audio driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
chip-ID: 8086:8c20 class-ID: 0403
Device-2: NVIDIA GK107 HDMI Audio vendor: Apple driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:0e1b
class-ID: 0403
Device-3: Broadcom 720p FaceTime HD Camera driver: N/A bus-ID: 04:00.0 chip-ID: 14e4:1570 class-ID: 0480
Device-4: Logitech Webcam C930e type: USB driver: snd-usb-audio,uvcvideo bus-ID: 1-5:3 chip-ID: 046d:0843
class-ID: 0102 serial: <filter>
Sound Server-1: ALSA v: k5.13.4-zen2-1-zen running: yes
Sound Server-2: JACK v: 0.125.0 running: no
Sound Server-3: PulseAudio v: 14.2 running: no
Sound Server-4: PipeWire v: 0.3.32 running: yes
Network:   Device-1: Broadcom BCM4360 802.11ac Wireless Network Adapter vendor: Apple driver: wl v: kernel modules: bcma
port: 2000 bus-ID: 03:00.0 chip-ID: 14e4:43a0 class-ID: 0280
IF: wlp3s0 state: down mac: <filter>
Device-2: Broadcom NetXtreme BCM57762 Gigabit Ethernet PCIe vendor: Apple Thunderbolt to driver: tg3 v: kernel
port: 2000 bus-ID: 0b:00.0 chip-ID: 14e4:1682 class-ID: 0200
IF: ens9 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth: Device-1: Apple Bluetooth Host Controller type: USB driver: btusb v: 0.8 bus-ID: 1-8.3:10 chip-ID: 05ac:8289
class-ID: fe01
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:    Local Storage: total: 704.39 GiB used: 314.42 GiB (44.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: THNSNJ256GCST size: 238.47 GiB block-size: physical: 512 B
logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 0102 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Apple model: SSD SM0512F size: 465.92 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: JA1Q scheme: GPT
Partition: ID-1: / raw-size: 89.79 GiB size: 89.79 GiB (100.00%) used: 10.03 GiB (11.2%) fs: btrfs dev: /dev/sdb8
maj-min: 8:24
ID-2: /boot/efi raw-size: 200 MiB size: 196.9 MiB (98.44%) used: 562 KiB (0.3%) fs: vfat dev: /dev/sdb1
maj-min: 8:17
ID-3: /home raw-size: 69.34 GiB size: 67.7 GiB (97.64%) used: 15.86 GiB (23.4%) fs: ext4 dev: /dev/sdb4
maj-min: 8:20
ID-4: /var/log raw-size: 89.79 GiB size: 89.79 GiB (100.00%) used: 10.03 GiB (11.2%) fs: btrfs dev: /dev/sdb8
maj-min: 8:24
ID-5: /var/tmp raw-size: 89.79 GiB size: 89.79 GiB (100.00%) used: 10.03 GiB (11.2%) fs: btrfs dev: /dev/sdb8
maj-min: 8:24
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 16.98 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sdb3 maj-min: 8:19
ID-2: swap-2 type: zram size: 15.54 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 67.0 C mobo: N/A gpu: nouveau temp: 67.0 C
Fan Speeds (RPM): N/A
Info:      Processes: 282 Uptime: 1h 17m wakeups: 2 Memory: 15.54 GiB used: 2.95 GiB (19.0%) Init: systemd v: 249
tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1223 lib: 296 Shell: Bash v: 5.1.8
default: Zsh v: 5.8 running-in: yakuake inxi: 3.3.06

i may end up moving to the Sway build of Garuda though. KDE lacks declarative configuration and makes tiling hard.

this is a bit off-topic, but the recent addition of transparency to the Sweet(ified) themes was a bit perplexing. does this not degrade performance as much as I think it does? the changes look good, but i have never had good experiences with transparency. i wish there was a simple way at the compositor level to turn transparency off globally in KDE.

just my opinion though.