Most recent update prevented Lightdm from starting, here was my fix

So I just updated my system today and I came everyone's worst nightmare after rebooting: Lightdm not starting. I booted into and restored a snapshot (I can't thank you guys enough for the BTRFS integration :smiley:) and tried the update again (from the terminal instead of Pamac) and found no errors had occurred. And yet, the issue persisted. However, checking the status of lightdm.service, I got a hint.

Nov 21 16:03:45 elliot-msi systemd[1]: lightdm.service: Two services allocated for the same bus name org.freedesktop.DisplayManager, refusing operation.
Nov 21 16:04:03 elliot-msi systemd[1]: lightdm.service: Two services allocated for the same bus name org.freedesktop.DisplayManager, refusing operation.

Luckily, I just happened to notice in my zsh autocomplete that there was also a lightdm-plymouth service, so I disabled the plain lightdm and rebooted. Boom, Lightdm started without problems.

I just have one question now, why was the conflicting lightdm-plymouth service suddenly enabled? Thanks

3 Likes

I've no idea regarding your question as I'm not a dev for the distro. All I can state is Garuda offers more desktops now than almost any other distro and there is only a few individuals producing all those versions. Perhaps something slipped through the cracks or in some cases it's not possible to know what the result will be on different hardware. It may simply have been a case of something being overlooked in the rush to get all the desktops ready for release at the same time.

Luckily timeshift came through when it counted.

Thank you for posting your findings.

2 Likes

No problem!

2 Likes

Maybe @yorper know more :slight_smile:

@CheeseEBoi thanks for posting :slight_smile:

3 Likes

Not me, I don’t touch Plymouth, in fact it’s one of the first things I removed on my personal systems :sweat_smile:

May be someone else made a change somewhere? My test system and dev system updated without issue...

3 Likes

Lightdm-plymouth service is enabled by default

Lightdm isnt enabled
Perhaps you enabled it somewhere

2 Likes

Didn’t touch any services for this release. Nothing but trimmed packages and fixed theme.

2 Likes

Well I know you didn't
I was saying to op
But I think I should have mentioned him

3 Likes