Missing spell-checker

Hi folks,

I’m very impressed by and enjoyed Garuda Linux which I’ve installed some time ago. It’s really well-designed system and easy to work with!
One thing bothers me unfortunately:

  • as I am Pole, I noticed there are not present any Polish spell-checker inside Garuda system built-in. Is there any way to fix it? Anybody helps?
    Cheers.

Install LanguageTool (Basic) in your browser via App store and visit the website.

It should say I am Polish

@sunda
Thanks for the reply. :slight_smile:
What I meant was just a system spell-checker (in Garuda itself) what is surprisingly empty by default. Of course I know there plenty of language-addons for the browsers, etc.

“I am a Pole” is a correct expression in the context of nationality. It means that someone is a Pole or a Polish woman. But your suggestion could be right as well. So both I guess.

1 Like

It sounds as if Hunspell is what you want. Pick your flavor. :slight_smile:

https://archlinux.org/packages/?sort=&q=hunspell&maintainer=&flagged=

4 Likes

Thanks for the tip. Hunspell is also interesting for me.

1 Like

I always install, just 'cause the setting looks lonely without it. :wink:

I’m American, speak English, so I install hunspell & hunspell-en_us.

3 Likes

I installed -en_gb, -de and -nl.
-id, which I use quite often, is available here: https://webspellchecker.com/de/supported-languages/

Just use pacseek for the language files :slight_smile:

3 Likes

Hey, thanks. I tested it by installing in terminal (“yay -S hunspell-pl”). But there is still an empty space in sys-settings (as you can see on screenshot here). :frowning:

No matter what I try to set English or Polish, I can see this warning: "no backend found for spell checking". :open_mouth:
I don’t know what to do next…

Also install hunspell

sudo pacman -S hunspell

4 Likes

Yeah! That was it. Thanks a lot, now it works!!! :smiley:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.