Missing Mouse Cursor in Garuda Wayfire

So I am trying to install Garuda Wayfire on my pc however when I select the free drivers in the grub menu and boot into the OS the mouse cursor is not visible. The reasoning behind choosing the free drivers is that if I choose the non-free ones the OS does not boot it just stays at starting Garuda Wayfire. Is there any work arounds to make the mouse cursor appear?

System Specs:

CPU- Intel Core i7 7700

Motherboard: Asus ROG Maximus IX Code

RAM- G.SKILL Ripjaws V Series 16GB DDR4 3200

GPU: Asus GTX 1050ti 4Gb (Nvidia)

and

:slight_smile:

1 Like

So I have looked at that post previously but I am not sure as to how to apply that. Forgive me I am still kind of new to Linux as a whole. Any help is appreciated thanks.

Why don't you ask how to apply this right away?


You can add

export WLR_NO_HARDWARE_CURSORS=1

in ~/. profile

micro ~/.profile
ibus-daemon -d -x
export EDITOR=/usr/bin/micro
export QT_QPA_PLATFORMTHEME="qt5ct"
export GTK2_RC_FILES="$HOME/.gtkrc-2.0"
export PATH=$HOME/.local/bin:$PATH
source ~/.bashrc
export XCURSOR_SIZE=40.32
export GDK_SCALE=1.68
export QT_AUTO_SCREEN_SCALE_FACTOR=0
export QT_SCALE_FACTOR=1.68
export ELM_SCALE=1.68

I suppose I should have my bad :grin:. So in reference to ~/. profile how do I run the command there, sorry if I am not understanding like I said I am a noobie in Linux in certain areas. Just trying to get this figured out so I can install and learn more as I go.

See above your post,
add the line.

Thats my i3 .profile, IDK how it looks in wayfire :slight_smile:

1 Like

I will give this a try, hopefully I can get it from my understanding of it. I am curious as to what would even cause this issue, I read it had something to do with the nouveau driver.

Also is this done within the desktop environment or grub?

"done within the desktop environment"

You put this in your terminal.

micro ~/.profile

enter

Alright I will give this a go then. I'll respond in a bit of my findings.

or

sed -i '$aexport WLR_NO_HARDWARE_CURSORS=1' ~/.profile

but read and test micro too, you need it often :wink:

Does it matter where I put that line in the file?

No
but if you use in terminal

sed -i '$aexport WLR_NO_HARDWARE_CURSORS=1' ~/.profile

it is on last line :slight_smile:

Ok so I have done that and it worked, now do I just reboot and my cursor should appear? I am in a live installation btw.

You're in a live (transient/temporary/impermanent/...) environment so any changes you make will be lost after a reboot. This is by design, intentional, and not something which can be fixed.

Just out of interest, why did you choose the Wayfire edition as your starting point? It's not what I would call a "noobie" choice?

1 Like

Right I'm aware as nothing is permanent in a live installation environment. And as far as why I chose Wayfire I liked the look and functionality of it, I'm coming from Arch linux installation I setup myself with the help of the wiki but I was just looking for a Arch based OS that had what I needed and maybe potentially learn more from it. I figured I'd jump into Wayfire. I know my way around some of linux functionality and commands but other areas not so much.

1 Like

But I'm having a separate issue where the installation process won't start now.

Different issue, different thread. (Also make sure search the forum in case someone has had the same issue.)

1 Like

Read also about the terminal bash/zsh.
A "newbie" that installed Arch without know how from terminal, tz tz tz :smiley:

2 Likes

4 posts were merged into an existing topic: Add missing cursor fix for Wayfire