Missing crucial step for virtualbox installation through garuda assistant

Hi,

After installing virtualbox through garuda assistant, necessary VirtualBox kernel module needs to be loaded beforehand, otherwise vms won't start. Users usually fall into the trap that it's a bios issue related to secure boot and uefi stuff.

Fix(permanent)
Create /etc/modules-load.d/virtualbox.conf
And it should consist

vboxdrv

Would be great to see this happen right after VirtualBox installation by garuda assistant, will remove unnecessary hassle.

Source-

2 Likes
3 Likes

I've never heard that this is necessary - what exactly does this file do?

If a driver needs to be loaded after installation, wouldn't an equivalent just be modprobe vboxdrv ?

2 Likes

Well, Virtualbox seems to require modprobing vboxdrv after every reboot otherwise starting the vm would fail. I also remember that it worked straight away some time ago though :eyes:

Something is very wrong if this is the case... :thinking:

On my system I have:

$ cat /usr/lib/modules-load.d/virtualbox-host-dkms.conf
vboxdrv
vboxnetadp
vboxnetflt

so why is this not present on other systems?

1 Like

Thats very interesting. The file does exist on my installation as well, still Virtualbox wouldn't start right away. :eyes:

λ cat /usr/lib/modules-load.d/virtualbox-host-dkms.conf
File: /usr/lib/modules-load.d/virtualbox-host-dkms.conf
vboxdrv
vboxnetadp
vboxnetflt

Any recommended steps to take for further troubleshooting?

Anything interesting in either of

systemctl status systemd-modules-load
journalctl -u systemd-modules-load

?

What's under /etc/modules-load.d/ ?

1 Like

I'm on the same boat.
Same contents of virtualbox-host-dkms.conf and VirtualBox not working: it starts, but I get I think a kernel panic (Caps lock blinking) when I start a VM.
The issue occurs only with linux-zen 5.12.14.zen1-1. No problems with linux-lts 5.10.47-1.

pacman -Ss virtualbox | grep installed
core/linux-lts 5.10.47-1 [installed]
extra/linux-zen 5.12.14.zen1-1 [installed]
community/virtualbox 6.1.22-3 [installed]
community/virtualbox-ext-vnc 6.1.22-3 [installed]
community/virtualbox-guest-iso 6.1.22-1 [installed]
community/virtualbox-host-dkms 6.1.22-3 [installed]
community/virtualbox-sdk 6.1.22-3 [installed]
chaotic-aur/virtualbox-ext-oracle 6.1.22-1 [installed]
chaotic-aur/virtualbox-meta 2-1 [installed]
systemctl status systemd-modules-load
● systemd-modules-load.service - Load Kernel Modules
Loaded: loaded (/usr/lib/systemd/system/systemd-modules-load.service; static)
Active: active (exited) since Tue 2021-07-06 13:12:14 CEST; 2min 29s ago
Docs: man:systemd-modules-load.service(8)
man:modules-load.d(5)
Process: 226 ExecStart=/usr/lib/systemd/systemd-modules-load (code=exited, status=0/SUCCESS)
Main PID: 226 (code=exited, status=0/SUCCESS)
CPU: 62ms

lug 06 13:12:14 garuda systemd-modules-load[226]: Inserted module 'crypto_user'
lug 06 13:12:14 garuda systemd-modules-load[226]: Inserted module 'uinput'
lug 06 13:12:14 garuda systemd-modules-load[226]: Inserted module 'vboxdrv'
lug 06 13:12:14 garuda systemd-modules-load[226]: Inserted module 'vboxnetadp'
lug 06 13:12:14 garuda systemd-modules-load[226]: Inserted module 'vboxnetflt'
lug 06 13:12:14 garuda systemd[1]: Finished Load Kernel Modules.
Notice: journal has been rotated since unit was started, output may be incomplete.

nothing strange in journalctl -u systemd-modules-load

ls /etc/modules-load.d/
.rw-r--r-- 8 root  5 lug 08:31  virtualbox.conf
1 Like

That's a different issue. :wink:

What's in this file, and which package owns it? (Or is this what was implemented above?)

2 Likes
cat /etc/modules-load.d/virtualbox.conf
File: /etc/modules-load.d/virtualbox.conf
vboxdrv
pacman -Qo virtualbox.conf
error: No package owns virtualbox.conf

I did not create the file, no idea...
In pacman.log I see (same day/time as that file:

[2021-07-06T08:30:21+0200] [ALPM] upgraded virtualbox-meta (1-1 -> 2-1)

In fact:

pacman -Ql virtualbox-meta
virtualbox-meta /etc/
virtualbox-meta /etc/modules-load.d/
virtualbox-meta /etc/modules-load.d/virtualbox.conf
pacman -Qo /etc/modules-load.d/virtualbox.conf
/etc/modules-load.d/virtualbox.conf is owned by virtualbox-meta 2-1

:blush:

1 Like

You may want to forgive me :frowning:
After using the lts kernel and restarting my only VM, the issue does not occur anymore in the zen kernel (where I tried 3 times before).
My fault: it is an old VM unused since quite some time, for sure before the last VBox update.
Sorry again, also for the "hijacking", feel free to delete my posts if misleading v/s the thread/discussion status...

2 Likes

First one shows nothing, just that journal was rotated.
Second one: nothing related, in fact the output was very uninformative. Just lots of those:

-- Boot 890d690477444ea6b7861fbd671e8d2b --
Jul 03 18:49:01 T470-void systemd[1]: systemd-modules-load.service: Deactivated successfully.
Jul 03 18:49:01 T470-void systemd[1]: Stopped Load Kernel Modules.
2 Likes

Hm. So - if the module is being loaded, why doesn't VirtualBox run? :exploding_head:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.