MInecraft: Dungeon Proton problem

Hey. I know this isn't a Garuda specific problem. But I was hoping there would be some hints.

so I have this very spesific to me problem. And I am hoping someone here might have some insight....

I sometimes like to play games. And as such I use Steam. ANd seeing as they no use Proton to make games work, I have been a happy camper for some months. I can right now start subnautica with no problems what so ever through Proton in Steam. Then I bought Minecraft: Dungeons.

This game starts up, shows me the intro, and then after the Loading screen is done the screen goes black and the game crash. Though I have the ingame cursor and the gamesounds for some seconds, and the cursor can be moved.

I've checked the min requrements and I'm above that. I know my laptop has a Intel card alos, BUT the optimus thingy is set to run nvidia by default. I've tried talking to the proton guys, and they sorta kinda had to tell me they have no clue. And the game is set to have NO issues when running through Proton.

All I havent done yet is reinstalling the nvidia drivers. And when I checked to see what pack I had installed I saw some other packs mentioning Vulkan and such.

Are there anything I sould be installing I might not have installed? Or that might be messing me up so I cannot get this to run? And when reinstalling what pack should I be installing to see if it works? And is there something I might need to do post reinstalling the drivers?

1 Like

I don't know your level of linux wisdom, so I will throw out what could be obvious tricks and lets see ...

  1. Have you tried other versions of Proton? You can select those in the Steam Settings, requiring a restart of Steam with each different version.

  2. Have you installed and/or tried Proton-GE? You can find the latest version in the repos using 'proton-ge-custom-bin' which will not only install the latest, but keeps Steam updated as well. Once you install, go into Stream Setting's Proton drop-down and select the Proton-GE version.

1 Like

I have tried Proton Experimental, Proton6.3-7 ( I belive) and the Proton-GE

I made proton write a logfile, and the only thing you could see there was that Vulkan had some issues with my Intel GPU card, but technically that shouldn't be a problem because my rig is set to use my Nvidia card, and is doing so in any other game I play. But I tried renaming the /usr/share/vulkan/ic... something intel.json files to make it so Vulkan wasn't even given the option to use Intel, and it still failed. I tried forcing Proton to use the Nvidia card through some Launch options I was given at the proton github, not that this made any difference. Though I am happy for the people that tipped me of that.

I've tried reinstalling the nvidia drivers ( Just in Case) without that having any effect. And when a friend installed linux to work with me and see if we could find a solution, his game started without a hitch. (and he's still playing it)

And since there is almost noone that has ever had problems running the game I have less than nothing to go on in terms of searches for problem solving

1 Like

Yeah, this game is Platinum but also according to Protondb.com it seems to work on certain Proton versions and not so well on others, which is why I suggested the switching. Alas, that didn't matter.

Also meant to add, did you go into Steam's settings and do a verification on the game files to weed out anything that may be corrupt?

Beyond that, it is probably your laptop/Optimus/Nvida configuration. I run pure Nvidia, don't mess with dual GPUs on desktop or laptops, so I am not much help there. You might want to look through this post though, trying maybe the Bumblebee option.

The Ultimate Guide to Setting Up Nvidia Optimus on Linux

That is a really neat guide. However...

My BIOS has the ability to turn off the NVIDIA GPU, but not the Intel one. And as I write this it hits me that I haven't checked on BIOS update in a while... (like since I bought the damn thing) SO I will be checking that out.

I am running something like prime atm. where I have told the system to use NVIDIA exclusively. and it works fine for all other games.

The bumblebee direction is something I have been contemplating for some days. BUT it says that Vulkan will not work with bumblebee, witch would loose any effect since proton uses Vulkan. Do we know if this has been changed since the guide was written?

The last solution is running 2 sessions of X, and needs bumblebee to function. As in wont work with Vulkan.

I hope I dont come off as negative and less solution oriented. But I have in the past ran straight into guides without haveing all the info beforehand, and broken alot of shit that way, so I merely want to seek info before jumping into something that wont work.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.