Migrating to a new SSD, can't figure it out

Hey everyone!

So, not an issue with Garuda per se, but I can’t really figure out a solution to my problem and thought I’d ask here because I am confused.

Here’s the issue. I have Garuda on my laptop dual booted with Windows 11. That’s on a 1TB NVMe SSD, but I needed more space, so I got a 2TB SSD for the laptop and an external NVMe enclosure so that I can clone everything. I tried to clone the whole thing with Macrium Reflect, but it didn’t correctly detect the BTRFS filesystem and just made partition on the new SSD with the same size as my Garuda installation, but with basically nothing in it (apparently). I’ve now been trying to figure out what the best way to proceed is. I know I’m asking for quite a bit, as I’m also resizing partitions (Both Windows and Garuda) and adding a swap partition that I didn’t have, but I seem to have everything else figured out apart from how I can just clone my Garuda installation to the new drive.

Thanks in advance for any help!

Try clonezilla
Then use gparted to resize the partitions


I suppose you mean booting Clonezilla off of a USB drive, right? Because installing it in the OS doesn’t even recognize the partitions I want to mess with.

Also, can it even clone standalone partitions?


use ventoy on a usb and install all the tools you need to boot into.

Also as this maybe the first time that you may have tried this, please backup any important date before you proceed


Hmmm… I’m kinda scared, tbh. You shouldn’t have said that last part, lol :joy:

I would prefer if there was a solution with GUI from within the OS, but if nothing else comes up, I’ll give Clonezilla a go. How bad could it go? Reason for preferring a GUI is that I get totally OCD with partition tables in terminals and want to avoid messing something up, whereas a visual representation of what I’m trying to do works better for me in my stupid brain.

1 Like

Famous last words. (jokes of course)
Thanks for the chuckle, I needed that.

Also, try not to take yourself down. We’re all different, that’s okay. Doesn’t make you stupid :slight_smile:.


The reason i said the last part , was if you have a backup off your data you can break it so many times learning and not lose anything :smiley:
So each time you break it you learn that did not work :smiley:
Now i will try it this way :smiley:


Good old fashioned dd from the terminal has always gotten drive to drive duplication jobs done for me. Just be sure you change the drive’s UUID to their own unique identifier if you intend to use the old and new drives on the same computer.


If you’re worried, watch a couple videos on it(clonezilla) it’s relatively simple keep the main drive as it is for a couple days so everything seems right then do your resizing. I definitely understand the desire for a gui, but when cloning a drive, you want the least amount of resources possible and not to be logged into the Drive you’re cloning from.

Just to add to the disorienting amount of ways, there’s also btrfs send/receive.
I used it long ago and all I remember is it was a breeze, if I recall correctly no options were necessary, only to get the volume paths right (that, even more so with dd…).
With that, you would first make the target partition and then send the volume into it.


I’ve done about the same as you’re anticipating and I thought Clonezilla was straight-forward and relatively painless.

I mean, look, you run Linux so you’re risk-prone anyway. :wink:


Thank you everyone for your inputs! This forum never ceases to amaze me, I was fully expecting an RTFM type of response, to be honest. Happy to be proven wrong again.

Anyway, I tried partitioning the new SSD beforehand and then cloning each partition with Clonezilla. I cloned the EFI partition first, then the Garuda partition and I decided to check whether it worked. And sure enough, it didn’t. It tries to boot Windows (I had cloned the whole thing with Macrium Reflect before) and fails quite fatally, it can’t even attempt recovery. GRUB is nowhere to be seen, even though I manually added the boot option for it in the BIOS (it is there in the EFI partition of the new disk, but it just won’t work). I’m at a bit of a loss here. Seems like the better option is to clone the whole thing and then try to resize the partitions. Problem with that is that I have the Windows recovery and restore partitions at the end of my drive, so I’ll end up with the partitions in this order : EFI → Windows reserved partition (WTF is even that?) → Windows partition → Garuda Partition → Restore partition → Recovery Partition and then unallocated space. Thing is, I’m going from a 1TB drive to a 2TB one, so I’d like to change the partition sizes for both Windows and Garuda, but I can’t see how that will be possible without messing everything up big time.

PS : Clonezilla is indeed intuitive/easy. Intimidating, don’t get me wrong, but it does work in a rather straightforward manner. Also, it’s just as much GUI as I needed, I just get cold feet when I have to type the commands in myself and risking data loss. It’s a nice tool after all.

1 Like

As you now have a understanding of clonezilla, clone the whole drive at the same time, as all the un,allocated space will be at the end of the drive. You will then be able to use gparted to move partitions into that space then resize as needed


Yeah, looks like that’s the route I’m gonna be taking in the end. For now, I’m trying to do a fresh clone of each individual partition and I will try to repair/reinstall GRUB if it still doesn’t work. Failing that, I will resort to plan B, nuking the whole thing and doing a fresh clone of the whole drive.

That’s too bad, as I had taken the time to make all the partitions nice and neat. I even included a swap partition now that I have space to spare, so that I can get hibernation to work in Linux. Oh well.

1 Like

So, quick update. Cloning the partitions one by one just didn’t want to work. I have no idea why. Anyway, I nuked that config and proceeded to clone the whole thing. That went smoothly and it worked fine. Then I started moving partitions and all is relatively fine too. There were some weird issues, like my fastfetch was failing to load in Garuda and then it wasn’t able to mount my Windows partition for whatever reason, but these are both fixed now. Barring any other unforeseen weirdness, this was it. It was more work than I had hoped for, but hey, I learned a few new things thanks to you guys, so thanks everyone!

I was gonna tell you, “we told you so” then I thought different.

We told you so, but you didn’t trust us. We make it a habit of giving people bad ideas, is that what you’re eluding? :wink:

I didn’t think so. Merry Christmas. :santa:


Well, you did tell me so, but it’s not you that I don’t trust, it’s me. :joy:

Also, bad ideas are sometimes the best ideas. Sometimes, bad ideas are necessary.

Merry Christmas!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.