Midnight commander starting slow

After new installation Garuda midnigt commader starting about 10 - 15 second on my user account. As root startnig fast. I need some advice to resolve that problem.

  Kernel: 6.4.3-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=34c9a381-7609-4d45-b102-b537ede525d0
    rw rootflags=subvol=@ quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
  Desktop: KDE Plasma v: 5.27.6 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2 dm: SDDM
    Distro: Garuda Linux base: Arch Linux
  Type: Desktop Mobo: Gigabyte model: GA-970A-D3 v: x.x serial: <superuser required> BIOS: Award
    v: F13b date: 12/16/2013
  Info: model: AMD FX-8300 bits: 64 type: MT MCP arch: Piledriver level: v2 built: 2012-13
    process: GF 32nm family: 0x15 (21) model-id: 2 stepping: 0 microcode: 0x6000852
  Topology: cpus: 1x cores: 8 smt: enabled cache: L1: 384 KiB desc: d-8x16 KiB; i-4x64 KiB
    L2: 8 MiB desc: 4x2 MiB L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 2484 high: 3800 min/max: 1400/3800 boost: enabled scaling:
    driver: acpi-cpufreq governor: schedutil cores: 1: 2400 2: 1400 3: 2700 4: 2416 5: 3624 6: 2129
    7: 3800 8: 1408 bogomips: 61208
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
  Device-1: NVIDIA GP107 [GeForce GTX 1050] vendor: ASUSTeK driver: nvidia v: 535.54.03
    alternate: nouveau,nvidia_drm non-free: 535.xx+ status: current (as of 2023-07) arch: Pascal
    code: GP10x process: TSMC 16nm built: 2016-21 pcie: gen: 2 speed: 5 GT/s lanes: 16
    bus-ID: 01:00.0 chip-ID: 10de:1c81 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2 compositor: kwin_x11 driver: X:
    loaded: nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1920x2160 s-dpi: 91 s-size: 535x602mm (21.06x23.70") s-diag: 805mm (31.71")
  Monitor-1: DVI-D-0 pos: primary,bottom res: 1920x1080 hz: 60 dpi: 93
    size: 527x296mm (20.75x11.65") diag: 604mm (23.8") modes: N/A
  Monitor-2: HDMI-0 pos: top res: 1920x1080 dpi: 305 size: 160x90mm (6.3x3.54")
    diag: 184mm (7.23") modes: N/A
  API: OpenGL v: 4.6.0 NVIDIA 535.54.03 renderer: NVIDIA GeForce GTX 1050/PCIe/SSE2
    direct-render: Yes
  Device-1: NVIDIA GP107GL High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
    pcie: gen: 2 speed: 5 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:0fb9 class-ID: 0403
  Device-2: C-Media CMI8788 [Oxygen HD Audio] vendor: ASUSTeK Virtuoso 100 driver: snd_virtuoso
    v: kernel bus-ID: 05:07.0 chip-ID: 13f6:8788 class-ID: 0401
  API: ALSA v: k6.4.3-zen1-1-zen status: kernel-api with: aoss type: oss-emulator
    tools: alsactl,alsamixer,amixer
  Server-1: PipeWire v: 0.3.74 status: active with: 1: pipewire-pulse status: active
    2: wireplumber status: active 3: pipewire-alsa type: plugin 4: pw-jack type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Gigabyte driver: r8169
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: de00 bus-ID: 04:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-1: Conwise CW6622 driver: btusb v: 0.8 type: USB rev: 1.1 speed: 12 Mb/s lanes: 1
    mode: 1.1 bus-ID: 1-1:2 chip-ID: 0e5e:6622 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
  Local Storage: total: 940.85 GiB used: 590.59 GiB (62.8%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: SanDisk model: KODAK SSD X100 size: 111.79 GiB block-size:
    physical: 512 B logical: 512 B speed: 6.0 Gb/s tech: SSD serial: <filter> fw-rev: 61I3
    scheme: MBR
  ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: HD642JJ size: 596.17 GiB block-size:
    physical: 512 B logical: 512 B speed: 3.0 Gb/s tech: N/A serial: <filter> fw-rev: 1113
    scheme: MBR
  ID-3: /dev/sdc maj-min: 8:32 vendor: Seagate model: ST3250318AS size: 232.89 GiB block-size:
    physical: 512 B logical: 512 B speed: 3.0 Gb/s tech: HDD rpm: 7200 
serial: <filter> fw-rev: HP35
    scheme: MBR
  ID-1: / raw-size: 43.21 GiB size: 43.21 GiB (100.00%) used: 16.24 GiB (37.6%) fs: btrfs
    dev: /dev/sda2 maj-min: 8:2
  ID-2: /home raw-size: 68.57 GiB size: 66.94 GiB (97.63%) used: 14.8 GiB (22.1%) fs: ext4
    dev: /dev/sda1 maj-min: 8:1
  ID-3: /var/log raw-size: 43.21 GiB size: 43.21 GiB (100.00%) used: 16.24 GiB (37.6%) fs: btrfs
    dev: /dev/sda2 maj-min: 8:2
  ID-4: /var/tmp raw-size: 43.21 GiB size: 43.21 GiB (100.00%) used: 16.24 GiB (37.6%) fs: btrfs
    dev: /dev/sda2 maj-min: 8:2
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.6 GiB used: 369.5 MiB (2.3%) priority: 100 dev: /dev/zram0
  System Temperatures: cpu: 31.5 C mobo: N/A gpu: nvidia temp: 50 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 29%
  Processes: 291 Uptime: 3h 50m wakeups: 0 Memory: total: 16 GiB available: 15.6 GiB
  used: 6.25 GiB (40.1%) Init: systemd v: 253 default: graphical tool: systemctl Compilers:
  gcc: 13.1.1 clang: 15.0.7 Packages: pm: pacman pkgs: 1554 libs: 392 tools: octopi,pamac,paru
  Client: shell wrapper v: 5.1.16-release inxi: 3.3.28
Garuda (2.6.16-1):
  System install date:     2023-07-08
  Last full system update: 2023-07-15
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut nvidia-dkms
  Windows dual boot:       <superuser required>
  Failed units:            

Doesn't garuda dr460nized KDE that you are using already have dolphin as a file manager? Is there a specific reason why you are trying to use GNU midnight commander?

Try launching it from terminal and see if the logs have anything helpful. Or post those logs here and maybe a community member might know something.

Also I just checked and both AUR and arch repos don't have GNU midnight commander in the repos so I suppose you have pulled it's packages using git? If so check the package for updates since it wouldn't have been updating via the package manager since you installed it.

  1. MC - but i like mc and using them above 25 years.
  2. Run mc always on terminal.
  3. Original Garuda repo.

Hmm, that’s an interesting clue. Maybe an issue in your user config somewhere? Test by moving it to a backup.

mv ~/.config/mc ~/.config/mc.bak

Then reopen mc and see if it loads any faster.


I've already tried it. Does not work.

Same here, 10 sec., ask the developer


Hmm, I just installed it to test and it opens in less than one second. Not as fast as Broot, and much uglier, but definitely faster than a second.

Check this article, it has a few suggestions:

My money is on the suggestion to disable the subshell:

Try to disable the built-in mc subshell:

alias mc="mc --nosubshell"

Thanks a lot! :+1:
mc --nosubshell helped me resolve problem.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.