Microsoft Edge not opening

So first of all, I know Edge isn't exactly liked here by all due to Microsoft and not being open source like Firefox, but I am trying to do comparisons and benchmarks etc. The browser used to open fine but now it will show a blurred screen and then crash every time. I tried rebooting, different linux kernels and reinstalling the browser. Below are my system specs followed by the message that appears when executing the browser through my terminal. And there is also an attached screenshot showing the blurred screen. Thanks for any advice.

inxi -Faz
System:    Kernel: 5.14.3-2-cacule-llvm x86_64 bits: 64 compiler: clang v: 12.0.0 
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-cacule-llvm 
root=UUID=d705e742-9d27-4001-909a-c8b33abd69ac rw rootflags=subvol=@ quiet splash 
rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 
resume=UUID=d2c6afb2-b903-4bf2-9889-2eb2819f64fa loglevel=3 
Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM 
Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Laptop System: ASUSTeK product: X510UA v: 1.0 serial: <filter> 
Mobo: ASUSTeK model: X510UA v: 1.0 serial: <filter> UEFI: American Megatrends v: X510UA.312 
date: 04/29/2020 
Battery:   ID-1: BAT0 charge: 6.6 Wh (23.1%) condition: 28.6/42.1 Wh (67.9%) volts: 11.5 min: 11.5 
model: ASUSTeK ASUS Battery type: Li-ion serial: N/A status: Charging cycles: 401 
CPU:       Info: Dual Core model: Intel Core i7-7500U bits: 64 type: MT MCP arch: Amber/Kaby Lake 
note: check family: 6 model-id: 8E (142) stepping: 9 microcode: EA cache: L2: 4 MiB 
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 23220 
Speed: 3477 MHz min/max: 400/3500 MHz Core speeds (MHz): 1: 3477 2: 3475 3: 3493 4: 3478 
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
Type: meltdown mitigation: PTI 
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
Type: spectre_v2 
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
Type: srbds mitigation: Microcode 
Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel HD Graphics 620 vendor: ASUSTeK driver: i915 v: kernel bus-ID: 00:02.0 
chip-ID: 8086:5916 class-ID: 0300 
Device-2: IMC Networks VGA UVC WebCam type: USB driver: uvcvideo bus-ID: 1-6:2 
chip-ID: 13d3:5a07 class-ID: 0e02 serial: <filter> 
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: intel 
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1 
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 143 size: 340x190mm (13.4x7.5") diag: 389mm (15.3") 
OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.2.1 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
alternate: snd_soc_skl bus-ID: 00:1f.3 chip-ID: 8086:9d71 class-ID: 0403 
Sound Server-1: ALSA v: k5.14.3-2-cacule-llvm running: yes 
Sound Server-2: JACK v: 1.9.19 running: no 
Sound Server-3: PulseAudio v: 15.0 running: no 
Sound Server-4: PipeWire v: 0.3.35 running: yes 
Network:   Device-1: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel port: f040 bus-ID: 02:00.0 
chip-ID: 8086:24fd class-ID: 0280 
IF: wlp2s0 state: up mac: <filter> 
Bluetooth: Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 bus-ID: 1-8:3 
chip-ID: 8087:0a2b class-ID: e001 
Report: bt-adapter ID: hci0 rfk-id: 0 state: down bt-service: enabled,running rfk-block: 
hardware: no software: yes address: <filter> 
Drives:    Local Storage: total: 704.24 GiB used: 75.91 GiB (10.8%) 
SMART Message: Unable to run smartctl. Root privileges required. 
ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 EVO 500GB size: 465.76 GiB 
block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 1B6Q 
scheme: GPT 
ID-2: /dev/sdb maj-min: 8:16 vendor: Micron model: 1100 MTFDDAV256TBN size: 238.47 GiB 
block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: A020 
scheme: GPT 
Partition: ID-1: / raw-size: 448.43 GiB size: 448.43 GiB (100.00%) used: 75.91 GiB (16.9%) fs: btrfs 
dev: /dev/sda2 maj-min: 8:2 
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.45%) used: 563 KiB (0.2%) fs: vfat 
dev: /dev/sda1 maj-min: 8:1 
ID-3: /home raw-size: 448.43 GiB size: 448.43 GiB (100.00%) used: 75.91 GiB (16.9%) fs: btrfs 
dev: /dev/sda2 maj-min: 8:2 
ID-4: /var/log raw-size: 448.43 GiB size: 448.43 GiB (100.00%) used: 75.91 GiB (16.9%) 
fs: btrfs dev: /dev/sda2 maj-min: 8:2 
ID-5: /var/tmp raw-size: 448.43 GiB size: 448.43 GiB (100.00%) used: 75.91 GiB (16.9%) 
fs: btrfs dev: /dev/sda2 maj-min: 8:2 
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) 
ID-1: swap-1 type: partition size: 17.07 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda3 
maj-min: 8:3 
ID-2: swap-2 type: zram size: 15.52 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0 
Sensors:   System Temperatures: cpu: 80.0 C mobo: N/A 
Fan Speeds (RPM): cpu: 4700 
Info:      Processes: 242 Uptime: 15m wakeups: 2 Memory: 15.52 GiB used: 3.12 GiB (20.1%) Init: systemd 
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1393 lib: 340 
Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06

Below is the message from executing edge:

microsoft-edge-beta
[56966:56966:0914/234114.304258:ERROR:sandbox_linux.cc(374)] InitializeSandbox() called with multiple threads in process gpu-process.
[0914/234114.964833:ERROR:elf_dynamic_array_reader.h(61)] tag not found
[0914/234114.965625:ERROR:elf_dynamic_array_reader.h(61)] tag not found
[0914/234114.967912:WARNING:minidump_to_upload_parameters.cc(36)] duplicate key guid, discarding value 8755214ff82f4bc0b780ec89244ed0c2
[56967:56981:0914/234118.800894:ERROR:ssl_client_socket_impl.cc(1136)] handshake failed; returned -1, SSL error code 1, net_error -3
fish: Job 1, 'microsoft-edge-beta' terminated by signal SIGTRAP (Trace or breakpoint trap)![Screenshot_Untitled - Personal - Microsoft​ Edge Beta_1|690x375](upload://xYGNFTej7uoEShvQu7CNf1IpuAZ.png)

Can you run ldd on it and make sure you aren't missing any libs?

You are not the first person to report this but it works fine for many of us.

1 Like

Sorry could you tell me what you mean by ldd? First I've heard of that

I mean literally. Type:

ldd /opt/microsoft/msedge-beta/msedge

EDIT: Fixed now. Apparently it is a maze of shell scripts.

1 Like
ldd /opt/microsoft/msedge-beta/msedge
linux-vdso.so.1 (0x00007ffc00fd2000)
libdl.so.2 => /usr/lib/libdl.so.2 (0x000070d5ef071000)
libpthread.so.0 => /usr/lib/libpthread.so.0 (0x000070d5ef050000)
libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0x000070d5eeff6000)
libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0x000070d5eeec1000)
libnss3.so => /usr/lib/libnss3.so (0x000070d5eed85000)
libnssutil3.so => /usr/lib/libnssutil3.so (0x000070d5eed52000)
libsmime3.so => /usr/lib/libsmime3.so (0x000070d5eed26000)
libnspr4.so => /usr/lib/libnspr4.so (0x000070d5eece3000)
libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0x000070d5eecba000)
libatk-bridge-2.0.so.0 => /usr/lib/libatk-bridge-2.0.so.0 (0x000070d5eec84000)
libgio-2.0.so.0 => /usr/lib/libgio-2.0.so.0 (0x000070d5eeac7000)
libcups.so.2 => /usr/lib/libcups.so.2 (0x000070d5eea2a000)
libdbus-1.so.3 => /usr/lib/libdbus-1.so.3 (0x000070d5ee9d3000)
libexpat.so.1 => /usr/lib/libexpat.so.1 (0x000070d5ee9a3000)
libxcb.so.1 => /usr/lib/libxcb.so.1 (0x000070d5ee979000)
libdrm.so.2 => /usr/lib/libdrm.so.2 (0x000070d5ee964000)
libm.so.6 => /usr/lib/libm.so.6 (0x000070d5ee820000)
libX11.so.6 => /usr/lib/libX11.so.6 (0x000070d5ee6d9000)
libXcomposite.so.1 => /usr/lib/libXcomposite.so.1 (0x000070d5ee6d2000)
libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0x000070d5ee6cd000)
libXext.so.6 => /usr/lib/libXext.so.6 (0x000070d5ee6b8000)
libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0x000070d5ee6af000)
libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0x000070d5ee6a2000)
libxkbcommon.so.0 => /usr/lib/libxkbcommon.so.0 (0x000070d5ee659000)
libgbm.so.1 => /usr/lib/libgbm.so.1 (0x000070d5ee647000)
libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0x000070d5ee5f5000)
libcairo.so.2 => /usr/lib/libcairo.so.2 (0x000070d5ee4d6000)
libasound.so.2 => /usr/lib/libasound.so.2 (0x000070d5ee3ee000)
libatspi.so.0 => /usr/lib/libatspi.so.0 (0x000070d5ee3b3000)
libxshmfence.so.1 => /usr/lib/libxshmfence.so.1 (0x000070d5ee3ae000)
libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0x000070d5ee391000)
libc.so.6 => /usr/lib/libc.so.6 (0x000070d5ee1c5000)
/lib64/ld-linux-x86-64.so.2 => /usr/lib64/ld-linux-x86-64.so.2 (0x000070d5fb5dc000)
libffi.so.7 => /usr/lib/libffi.so.7 (0x000070d5ee1b9000)
libpcre.so.1 => /usr/lib/libpcre.so.1 (0x000070d5ee142000)
libplds4.so => /usr/lib/libplds4.so (0x000070d5ee13d000)
libplc4.so => /usr/lib/libplc4.so (0x000070d5ee136000)
libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0x000070d5ee12f000)
libz.so.1 => /usr/lib/libz.so.1 (0x000070d5ee115000)
libmount.so.1 => /usr/lib/libmount.so.1 (0x000070d5ee0b5000)
libresolv.so.2 => /usr/lib/libresolv.so.2 (0x000070d5ee09b000)
libgssapi_krb5.so.2 => /usr/lib/libgssapi_krb5.so.2 (0x000070d5ee046000)
libavahi-common.so.3 => /usr/lib/libavahi-common.so.3 (0x000070d5ee036000)
libavahi-client.so.3 => /usr/lib/libavahi-client.so.3 (0x000070d5ee022000)
libgnutls.so.30 => /usr/lib/libgnutls.so.30 (0x000070d5ede21000)
libsystemd.so.0 => /usr/lib/libsystemd.so.0 (0x000070d5edd5c000)
libXau.so.6 => /usr/lib/libXau.so.6 (0x000070d5edd57000)
libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x000070d5edd4f000)
libXrender.so.1 => /usr/lib/libXrender.so.1 (0x000070d5edd40000)
libwayland-server.so.0 => /usr/lib/libwayland-server.so.0 (0x000070d5edd29000)
libfribidi.so.0 => /usr/lib/libfribidi.so.0 (0x000070d5edd0a000)
libthai.so.0 => /usr/lib/libthai.so.0 (0x000070d5edcff000)
libharfbuzz.so.0 => /usr/lib/libharfbuzz.so.0 (0x000070d5edc29000)
libpng16.so.16 => /usr/lib/libpng16.so.16 (0x000070d5edbf0000)
libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x000070d5edba1000)
libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x000070d5edad7000)
libxcb-render.so.0 => /usr/lib/libxcb-render.so.0 (0x000070d5edac7000)
libxcb-shm.so.0 => /usr/lib/libxcb-shm.so.0 (0x000070d5edac2000)
libpixman-1.so.0 => /usr/lib/libpixman-1.so.0 (0x000070d5eda1a000)
librt.so.1 => /usr/lib/librt.so.1 (0x000070d5eda0d000)
libXi.so.6 => /usr/lib/libXi.so.6 (0x000070d5ed9fa000)
libblkid.so.1 => /usr/lib/libblkid.so.1 (0x000070d5ed9a4000)
libkrb5.so.3 => /usr/lib/libkrb5.so.3 (0x000070d5ed8bd000)
libk5crypto.so.3 => /usr/lib/libk5crypto.so.3 (0x000070d5ed88c000)
libcom_err.so.2 => /usr/lib/libcom_err.so.2 (0x000070d5ed884000)
libkrb5support.so.0 => /usr/lib/libkrb5support.so.0 (0x000070d5ed874000)
libkeyutils.so.1 => /usr/lib/libkeyutils.so.1 (0x000070d5ed86d000)
libp11-kit.so.0 => /usr/lib/libp11-kit.so.0 (0x000070d5ed738000)
libidn2.so.0 => /usr/lib/libidn2.so.0 (0x000070d5ed716000)
libunistring.so.2 => /usr/lib/libunistring.so.2 (0x000070d5ed594000)
libtasn1.so.6 => /usr/lib/libtasn1.so.6 (0x000070d5ed57c000)
libnettle.so.8 => /usr/lib/libnettle.so.8 (0x000070d5ed535000)
libhogweed.so.6 => /usr/lib/libhogweed.so.6 (0x000070d5ed4ec000)
libgmp.so.10 => /usr/lib/libgmp.so.10 (0x000070d5ed44c000)
liblzma.so.5 => /usr/lib/liblzma.so.5 (0x000070d5ed424000)
libzstd.so.1 => /usr/lib/libzstd.so.1 (0x000070d5ed315000)
liblz4.so.1 => /usr/lib/liblz4.so.1 (0x000070d5ed2f0000)
libcap.so.2 => /usr/lib/libcap.so.2 (0x000070d5ed2e5000)
libgcrypt.so.20 => /usr/lib/libgcrypt.so.20 (0x000070d5ed1a9000)
libdatrie.so.1 => /usr/lib/libdatrie.so.1 (0x000070d5ed19f000)
libgraphite2.so.3 => /usr/lib/libgraphite2.so.3 (0x000070d5ed17a000)
libbz2.so.1.0 => /usr/lib/libbz2.so.1.0 (0x000070d5ed165000)
libbrotlidec.so.1 => /usr/lib/libbrotlidec.so.1 (0x000070d5ed157000)
libgpg-error.so.0 => /usr/lib/libgpg-error.so.0 (0x000070d5ed130000)
libbrotlicommon.so.1 => /usr/lib/libbrotlicommon.so.1 (0x000070d5ed10d000)

That looks fine to me.

If it does then I have no clue why edge will not work now. It's just strange

You are running a pretty unique kernel. Try the linux kernel and see if that makes a difference.

I have already tried Linux-Zen which is a well-known and used kernel but I'll give the normal kernel a go too thanks

Well, same problem. Not sure if it's kernel related then

Totally out of the blue thought, try disabling your compositor and logoff before opening the browser. Probably will not make any difference, but it is Edge (so no great loss).

1 Like

Good point, will try thanks. And I know it's edge but it does run really fast. Anyway though, what browser would you recommend? If I can't fix this then I'll change browser and give up with my testing for edge

Firefox all the way.

5 Likes

I believe @tbg meant:

Getting serious, I have no issues with Edge Browser (FWIW, I deplore M$® and M$ Doors® but like @Grimy1928 mentioned, Edge is fastAF) but lately Vivaldi has been crashing a few seconds after launch every time without fail. I initially had the snapshot package so thought maybe if I deleted that one in favor of the stable release it would remedy the situation but no dice. I've gone back and forth a couple of times now with no change in result. I love Vivaldi and while I was still very much like to solve the issue it was a little bit of a blessing in disguise as it lead to using FireDragon. At first, I just thought it would be as a stopgap but after a few days I made it my default browser. There are still some use cases that I find I need a chromium based browser for but fortunately I like this browser so much that I'm not complaining and am strangely grateful.

FireDragon being a security enhanced version of Firefox I figured would be another obvious choice without explicitly saying so.

2 Likes

Just pulling yer chain :stuck_out_tongue_winking_eye:

I knew where your head was

Edit to add:

Not to highjack your thread but I wanted to thank you and @dalto for indirectly solving my Vivaldi woes.

I hadn't run ldd on it, and ultimately nothing looked out of place there but because ldd initially returned "not a dynamic executable," subsequent digging eventually lead me to find that vivaldi.stable.desktop/the application menu were pointing at /usr/bin/vivaldi-stable when in fact it should have been /opt/vivaldi/vivaldi-bin. All is well with Vivaldi and I discovered my new favorite Firefox fork / alternative to Chromium-based browsers ever in FireDragon, so all in all I'm gonna mark it down in the 'W' column

2 Likes