Microphone Issues

Hello Garuda Linux Forum,

I'm currently running into an issue with my microphone. From a fresh install, I realized that my mic was only picking up sound from the left ear correctly, as the right ear seemed muted and incomprehensible. Furthermore, when I tried using my microphone in Discord, people complained that I sounded distant and muted. Discord, from what I know, converts all microphone audio to mono before broadcasting to others on the call, so it must've been using strictly the broken right ear of my microphone. This issue does not seem to be present on my previous installation of Windows 10, so it probably isn't a hardware issue. Does anyone know if this is a common issue, or does this even have to do with Linux itself at all?

I'm using ALSA with PulseAudio.
My microphone is the Samson C01U.

Regards,
Spxctre

I have concluded that it works perfectly fine in Windows (as the microphone is set to record to a single channel), but doesn't work on Linux (because the microphone is forced to record to analog stereo input.) Does anyone know how to configure this setting and change it to record on a single channel?

Sure would be easier to answer if y'all had posted the output inxi -Faz, with ~~~ before and after it for readabilities sake.

What DE are you using?

1 Like
System:    Kernel: 5.13.7-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0  
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=7dab3ae9-2727-428b-abf0-ed13273b52b4  
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM  
Distro: Garuda Linux base: Arch Linux  
Machine:   Type: Desktop System: Dell product: XPS 8910 v: 1.1.5 serial: <filter> Chassis: type: 3  
serial: <filter>  
Mobo: Dell model: 0WPMFG v: A00 serial: <filter> UEFI-[Legacy]: Dell v: 1.1.5 date: 12/13/2017  
Battery:   Device-1: hidpp_battery_0 model: Logitech Wireless Gaming Mouse serial: <filter>  
charge: 55% (should be ignored) rechargeable: yes status: Discharging  
CPU:       Info: Quad Core model: Intel Core i7-6700 bits: 64 type: MT MCP arch: Skylake-S family: 6  
model-id: 5E (94) stepping: 3 microcode: EA cache: L2: 8 MiB  
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 54398  
Speed: 3994 MHz min/max: 800/4000 MHz Core speeds (MHz): 1: 3994 2: 3929 3: 3887 4: 3903  
5: 3904 6: 3853 7: 3972 8: 3902  
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled  
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable  
Type: mds mitigation: Clear CPU buffers; SMT vulnerable  
Type: meltdown mitigation: PTI  
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp  
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization  
Type: spectre_v2  
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling  
Type: srbds mitigation: Microcode  
Type: tsx_async_abort mitigation: Clear CPU buffers; SMT vulnerable  
Graphics:  Device-1: Intel HD Graphics 530 vendor: Dell driver: i915 v: kernel bus-ID: 00:02.0  
chip-ID: 8086:1912 class-ID: 0380  
Device-2: AMD Baffin [Radeon RX 460/560D / Pro 450/455/460/555/555X/560/560X] vendor: Dell  
driver: amdgpu v: kernel bus-ID: 01:00.0 chip-ID: 1002:67ef class-ID: 0300  
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: amdgpu,ati,intel  
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1  
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")  
Monitor-1: HDMI-A-0 res: 1920x1080 hz: 60 dpi: 96 size: 509x286mm (20.0x11.3")  
diag: 584mm (23")  
OpenGL:  
renderer: AMD Radeon RX 460 Graphics (POLARIS11 DRM 3.41.0 5.13.7-zen1-1-zen LLVM 12.0.1)  
v: 4.6 Mesa 21.1.6 direct render: Yes  
Audio:     Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: Dell driver: snd_hda_intel  
v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a170 class-ID: 0403  
Device-2: AMD Baffin HDMI/DP Audio [Radeon RX 550 640SP / RX 560/560X] vendor: Dell  
driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 1002:aae0 class-ID: 0403  
Device-3: Samson C01U condenser microphone type: USB driver: snd-usb-audio bus-ID: 1-12:7  
chip-ID: 17a0:0001 class-ID: 0102  
Sound Server-1: ALSA v: k5.13.7-zen1-1-zen running: yes  
Sound Server-2: JACK v: 1.9.19 running: no  
Sound Server-3: PulseAudio v: 15.0 running: no  
Sound Server-4: PipeWire v: 0.3.32 running: yes  
Network:   Device-1: Intel Wireless 3165 driver: iwlwifi v: kernel port: e000 bus-ID: 03:00.0  
chip-ID: 8086:3165 class-ID: 0280  
IF: wlp3s0 state: down mac: <filter>  
Device-2: Qualcomm Atheros QCA8171 Gigabit Ethernet vendor: Dell driver: alx v: kernel  
port: d000 bus-ID: 04:00.0 chip-ID: 1969:10a1 class-ID: 0200  
IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>  
Bluetooth: Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 bus-ID: 1-8:5  
chip-ID: 8087:0a2a class-ID: e001  
Report: bt-adapter ID: hci0 rfk-id: 0 state: down bt-service: enabled,running rfk-block:  
hardware: no software: yes address: <filter>  
RAID:      Hardware-1: Intel SATA Controller [RAID mode] driver: ahci v: 3.0 port: f060 bus-ID: 00:17.0  
chip-ID: 8086.2822 rev: 31 class-ID: 0104  
Drives:    Local Storage: total: 2.73 TiB used: 26.61 GiB (1.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000DM010-2EP102 size: 931.51 GiB
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200
serial: <filter> rev: CC43 scheme: MBR
ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital model: WD10EZEX-08M2NA0 size: 931.51 GiB
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200
serial: <filter> rev: 1A01 scheme: MBR
ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: Seagate model: USB size: 931.51 GiB block-size:
physical: 4096 B logical: 512 B type: N/A serial: <filter> rev: 0412 scheme: MBR
Partition: ID-1: / raw-size: 600 GiB size: 600 GiB (100.00%) used: 26.61 GiB (4.4%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
ID-2: /home raw-size: 600 GiB size: 600 GiB (100.00%) used: 26.61 GiB (4.4%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
ID-3: /var/log raw-size: 600 GiB size: 600 GiB (100.00%) used: 26.61 GiB (4.4%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
ID-4: /var/tmp raw-size: 600 GiB size: 600 GiB (100.00%) used: 26.61 GiB (4.4%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.53 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 53.0 C mobo: 27.8 C gpu: amdgpu temp: 54.0 C
Fan Speeds (RPM): cpu: 1726 mobo: 604 gpu: amdgpu fan: 1006
Info:      Processes: 305 Uptime: 25m wakeups: 2 Memory: 15.53 GiB used: 2.96 GiB (19.1%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: apt: 0 pacman: 1274
lib: 353 Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06

I have basically concluded that the microphone that I'm using to record is only intended to record in mono, while the Linux operating system is forcing my microphone to record in stereo. Do you know to configure/change this option?

I'm using ALSA with PulseAudio.

I am currently using Garuda Linux KDE Dragonized.

Because audio HW change very frequently, Linux may not always succeed in automatic configuration, setting proper defaults, etc., although it does a good job in most cases.

You can change most settings with a gui app pavucontrol-qt (since you are on KDE), or pavucontrol.

Install one of the above, test it and post feedback.

2 Likes

pavucontrol-qt is installed, I do not see an option to configure my recording device to mono. There is only two options, "Analog Stereo Input" or "Digital Stereo Input". There is no option for a mono setting.

Just to note, the Samson C01U is a USB-condenser microphone.

I have found an article about your HW. Maybe it helps you.

You should try alsamixer to configure.

If you are going to use some pacmd command to fix your issue (bottom of article), do some reading about pacmd usage before you make it worse and get lost... :wink:

6 Likes

Hi, @petsam , thank you for your help!

After researching about how to use pacmd, I've found a workaround that worked for me.

In the case that others stumble across this particular thread with a similar issue, I will document my process.

First, I used pacmd list-sources to list all of my input devices.

I found my microphone's name in the sources, and then used this command to create a remapped source that downmixes the left-channel (working left ear) of my microphone to mono.

pacmd load-module module-remap-source source_name=SamsonTechnologies_Samson_C01U master=alsa_input.usb-Samson_Technologies_Samson_C01U-00.analog-stereo master_channel_map=left channel_map=mono

If you use this command, make sure to rename the source_name to a custom name of your choice, and the master to the name of your microphone source's name in pacmd list-sources.
Set the remapped device as default, and then test it out in OBS Studio or Audacity to make sure that your remapped source works properly. If it did, we can then go to /etc/pulse/default.pa and then apply this on start-up.

load-module module-remap-source source_name=SamsonTechnologies_Samson_C01U master=alsa_input.usb-Samson_Technologies_Samson_C01U-00.analog-stereo master_channel_map=left channel_map=mono

I also included this line to rename my source to something more readable.

'update-source-proplist SamsonTechnologies_Samson_C01U device.description="Samson C01U Condenser Microphone" '

If you decide to use this command, replace SamsonTechnologies_Samson_C01U with the name of your remapped source, and replace the contents of device.description with the desired name.

Again, thank you for your help @petsam !

5 Likes

Congratulation! Perfect work.

We all thank you for the great feedback and contribution to the community!

6 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.