Mic muted/unmuted displaying wrong

I don't really know where this issue stems from, but the mic icon in the top bar, when muted, is actually unmuted. When it says it's unmuted, it's actually muted. Is this an issue for anyone else? It seems to happen across multiple different applications using the microphone.

I searched for the forum for similar issues but can't seem to find any posts about similar issues.

System:
Kernel: 6.0.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=11374ffd-57dd-4850-ae21-7018ba2a4020 rw [email protected]
quiet
cryptdevice=UUID=a3b5cba1-2dfa-428f-8997-3864dc0e7ca3:luks-a3b5cba1-2dfa-428f-8997-3864dc0e7ca3
root=/dev/mapper/luks-a3b5cba1-2dfa-428f-8997-3864dc0e7ca3 quiet splash
rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
ipv6.disable=1 ipv6.disable=0
Desktop: KDE Plasma v: 5.26.1 tk: Qt v: 5.15.6 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: ASUSTeK model: Maximus IV Extreme v: Rev 1.xx
serial: <superuser required> BIOS: American Megatrends v: 3604
date: 04/12/2013
Battery:
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 3
serial: <filter> charge: 55% (should be ignored) rechargeable: yes
status: discharging
CPU:
Info: model: Intel Core i7-2600K bits: 64 type: MT MCP arch: Sandy Bridge
gen: core 2 level: v2 built: 2010-12 process: Intel 32nm family: 6
model-id: 0x2A (42) stepping: 7 microcode: 0x2F
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 8 MiB desc: 1x8 MiB
Speed (MHz): avg: 2551 high: 3425 min/max: 1600/5900 scaling:
driver: intel_cpufreq governor: schedutil cores: 1: 1688 2: 2878 3: 2097
4: 2086 5: 2998 6: 3425 7: 2966 8: 2273 bogomips: 54579
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: mmio_stale_data status: Unknown: No mitigations
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA GM204 [GeForce GTX 980] vendor: ASUSTeK driver: nvidia
v: 520.56.06 alternate: nouveau,nvidia_drm non-free: 515.xx+ status: current
(as of 2022-10) arch: Maxwell code: GMxxx process: TSMC 28nm
built: 2014-19 pcie: gen: 2 speed: 5 GT/s lanes: 16 bus-ID: 01:00.0
chip-ID: 10de:13c0 class-ID: 0300
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.4
compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x1080 s-dpi: 85 s-size: 1147x319mm (45.16x12.56")
s-diag: 1191mm (46.87")
Monitor-1: DVI-I-0 pos: right res: 1280x1024 hz: 60 dpi: 86
size: 376x301mm (14.8x11.85") diag: 482mm (18.96") modes: N/A
Monitor-2: HDMI-0 pos: primary,left res: 2560x1080 dpi: 81
size: 798x334mm (31.42x13.15") diag: 865mm (34.06") modes: N/A
OpenGL: renderer: NVIDIA GeForce GTX 980/PCIe/SSE2 v: 4.6.0 NVIDIA
520.56.06 direct render: Yes
Audio:
Device-1: Intel 6 Series/C200 Series Family High Definition Audio
vendor: ASUSTeK driver: snd_hda_intel v: kernel bus-ID: 1-1.4.1:8
bus-ID: 00:1b.0 chip-ID: 1038:12ad class-ID: 0300 chip-ID: 8086:1c20
class-ID: 0403
Device-2: NVIDIA GM204 High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:0fbb class-ID: 0403
Device-3: SteelSeries ApS Arctis 7 type: USB
driver: hid-generic,snd-usb-audio,usbhid
Device-4: Shure X2u Adapter type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-1.6:7 chip-ID: 14ed:29b6
class-ID: 0300
Sound API: ALSA v: k6.0.2-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
Device-1: Intel 82579V Gigabit Network vendor: ASUSTeK P8P67 Deluxe
driver: e1000e v: kernel port: f040 bus-ID: 00:19.0 chip-ID: 8086:1503
class-ID: 0200
IF: eno1 state: down mac: <filter>
Device-2: Intel 82583V Gigabit Network vendor: ASUSTeK driver: e1000e
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: b000 bus-ID: 0c:00.0
chip-ID: 8086:150c class-ID: 0200
IF: enp12s0 state: down mac: <filter>
Device-3: Realtek RTL88x2bu [AC1200 Techkey] type: USB driver: rtl88x2bu
bus-ID: 2-1.6:4 chip-ID: 0bda:b812 class-ID: 0000 serial: <filter>
IF: wlp0s29u1u6 state: up mac: <filter>
Bluetooth:
Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB
driver: btusb v: 0.8 bus-ID: 1-1.1:3 chip-ID: 0a12:0001 class-ID: fe01
Report: bt-adapter ID: hci0 rfk-id: 0 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Drives:
Local Storage: total: 447.13 GiB used: 42.45 GiB (9.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Intel model: SSDSC2BP480G4
size: 447.13 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 0420 scheme: MBR
Partition:
ID-1: / raw-size: 447.13 GiB size: 447.13 GiB (100.00%) used: 42.45 GiB
(9.5%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-a3b5cba1-2dfa-428f-8997-3864dc0e7ca3
ID-2: /home raw-size: 447.13 GiB size: 447.13 GiB (100.00%) used: 42.45
GiB (9.5%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-a3b5cba1-2dfa-428f-8997-3864dc0e7ca3
ID-3: /var/log raw-size: 447.13 GiB size: 447.13 GiB (100.00%) used: 42.45
GiB (9.5%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-a3b5cba1-2dfa-428f-8997-3864dc0e7ca3
ID-4: /var/tmp raw-size: 447.13 GiB size: 447.13 GiB (100.00%) used: 42.45
GiB (9.5%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-a3b5cba1-2dfa-428f-8997-3864dc0e7ca3
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.32 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 47.0 C mobo: N/A gpu: nvidia temp: 74 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 44%
Info:
Processes: 331 Uptime: 18h 35m wakeups: 51 Memory: 31.32 GiB used: 7.66 GiB
(24.5%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1276 libs: 332
tools: octopi,paru Shell: fish v: 3.5.1 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.22
Garuda (2.6.9-1):
System install date:     2022-10-21
Last full system update: 2022-10-24 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       <superuser required>
Snapshots:               Snapper
Failed units:

I forgot to mention, it's actually displaying two separate mic icons instead of one. Both have identical status.