Meta key to open menu

I just ran into this issue, and wanted to share that I could solve it with this solution

Note: I did rebind the menu to Alt+F1 and Meta+F1 multiple times, tried other shortcuts meanwhile and did also try to use one of the solutions who used to be previously shared here on the forum. The solution in the link is the only one, that worked for me.

Hope this helps somebody


There are a few different solutions there: the meta>win key binding didn't work on the lenovo with estonian keyboard lol - i will try again after reboot before conceding complete failure.

It actually failed for me shortly after, I suspect after then first reboot. So I might have to put this command into the fish config. Annoying

Alternatively, you can link the Meta key to Overview using the following ...

kwriteconfig5 --file ~/.config/kwinrc --group ModifierOnlyShortcuts --key Meta "org.kde.kglobalaccel,/component/kwin,org.kde.kglobalaccel.Component,invokeShortcut,Overview"

then ...

qdbus org.kde.KWin /KWin reconfigure

1 Like

Assuming the first block is to be pasted in one piece, this doesnt work for me.
Neither does the solution from the Stackoverflow anymore.
It`s doomed :smile:


I wonder if you can solve a similar issue? My Thinkpad is from estonia so it has Scandinavian keyboard with "Alt-Gr" key to the right of the space bar that is used primarily to access the "at" symbol (used to tag people in numerous social and message sites) which on the estonian keyboard is under one the 2 key. Normally AltGr+2 gives the "at" symbol, and i noticed in the browser it functions to go from current open page to leftward open page (horizontal scroll through pages). I tried to un-assign any alt keys in the global keyboard settings, but it seems to be gone for good. (I found no settings for hotkeys on brave browser) but the problem is persisting. Maybe it is some kind of virus. Is there a soft keyboard I can load like in debian, to type from the soft keyboard to work around this kind of problem. I never had this problem before and have been using Garuda nearly 4 years now.

Kernel: 6.4.10-hardened1-1-hardened arch: x86_64 bits: 64 compiler: gcc
v: 13.2.1 clocksource: tsc available: hpet,acpi_pm parameters: pti=on
page_alloc.shuffle=1 BOOT_IMAGE=/@/boot/vmlinuz-linux-hardened
root=UUID=321c5cef-bd09-4999-9d16-79b9c9e0a513 rw rootflags=subvol=@
rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=54cfc0b3-0cca-4092-99bd-537dea8573e1 loglevel=3 quiet ibt=off
Desktop: KDE Plasma v: 5.27.7 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Laptop System: LENOVO product: 20CMS06V00 v: ThinkPad X250
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: LENOVO model: 20CMS06V00 v: SDK0E50510 WIN
serial: <superuser required> UEFI: LENOVO v: N10ET54W (1.33 )
date: 09/18/2018
ID-1: BAT0 charge: 16.0 Wh (94.7%) condition: 16.9/23.2 Wh (72.9%)
volts: 11.9 min: 11.1 model: SANYO 45N1773 type: Li-ion serial: <filter>
status: not charging
ID-2: BAT1 charge: 16.7 Wh (94.9%) condition: 17.6/23.2 Wh (75.9%)
volts: 11.5 min: 11.1 model: SANYO 45N1775 type: Li-ion serial: <filter>
status: not charging
Info: model: Intel Core i5-5300U bits: 64 type: MT MCP arch: Broadwell
gen: core 5 level: v3 note: check built: 2015-18 process: Intel 14nm
family: 6 model-id: 0x3D (61) stepping: 4 microcode: 0x2F
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 2204 high: 2272 min/max: 500/2900 scaling:
driver: intel_cpufreq governor: schedutil cores: 1: 2097 2: 2272 3: 2204
4: 2246 bogomips: 18366
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
Vulnerabilities: <filter>
Device-1: Intel HD Graphics 5500 vendor: Lenovo driver: i915 v: kernel
arch: Gen-8 process: Intel 14nm built: 2014-15 ports: active: eDP-1
empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:1616
class-ID: 0300
Device-2: Bison Integrated Camera driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 2-8:5 chip-ID: 5986:0366
class-ID: 0e02
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.2.0
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
s-diag: 414mm (16.31")
Monitor-1: eDP-1 model: LG Display 0x03ed built: 2012 res: 1366x768 hz: 60
dpi: 125 gamma: 1.2 size: 277x156mm (10.91x6.14") diag: 318mm (12.5")
ratio: 16:9 modes: 1366x768
API: OpenGL v: 4.6 Mesa 23.1.6 renderer: Mesa Intel HD Graphics 5500 (BDW
GT2) direct-render: Yes
Device-1: Intel Broadwell-U Audio vendor: Lenovo driver: snd_hda_intel
v: kernel bus-ID: 00:03.0 chip-ID: 8086:160c class-ID: 0403
Device-2: Intel Wildcat Point-LP High Definition Audio vendor: Lenovo
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9ca0
class-ID: 0403
API: ALSA v: k6.4.10-hardened1-1-hardened status: kernel-api with: aoss
type: oss-emulator tools: alsactl,alsamixer,amixer
Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
Server-2: PipeWire v: 0.3.77 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Ethernet I218-LM vendor: Lenovo driver: e1000e v: kernel
port: 3080 bus-ID: 00:19.0 chip-ID: 8086:15a2 class-ID: 0200
IF: enp0s25 state: down mac: <filter>
Device-2: Intel Wireless 7265 driver: iwlwifi v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 8086:095b class-ID: 0280
IF: wlp3s0 state: up mac: <filter>
IF-ID-1: ipv6leakintrf0 state: unknown speed: N/A duplex: N/A
mac: <filter>
IF-ID-2: proton0 state: unknown speed: 10000 Mbps duplex: full mac: N/A
IF-ID-3: pvpnksintrf0 state: unknown speed: N/A duplex: N/A mac: <filter>
IF-ID-4: wwp0s20u4 state: down mac: <filter>
Local Storage: total: 476.94 GiB used: 43.08 GiB (9.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Apacer model: AS350 512GB
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 3PE0 scheme: GPT
ID-1: / raw-size: 467.84 GiB size: 467.84 GiB (100.00%)
used: 43.08 GiB (9.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 467.84 GiB size: 467.84 GiB (100.00%)
used: 43.08 GiB (9.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 467.84 GiB size: 467.84 GiB (100.00%)
used: 43.08 GiB (9.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 467.84 GiB size: 467.84 GiB (100.00%)
used: 43.08 GiB (9.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 7.65 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4 dev: /dev/zram0
ID-2: swap-2 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/sda3 maj-min: 8:3
System Temperatures: cpu: 54.0 C pch: 51.5 C mobo: N/A
Fan Speeds (rpm): fan-1: 4518
Processes: 204 Uptime: 4h 50m wakeups: 3 Memory: total: 8 GiB
available: 7.65 GiB used: 3.58 GiB (46.9%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 15.0.7
Packages: pm: pacman pkgs: 1622 libs: 363 tools: octopi,pamac,paru
Shell: fish v: 3.6.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.29
Garuda (2.6.16-1):
System install date:     2023-02-17
Last full system update: 2023-08-22 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager mkinitcpio
Windows dual boot:       No/Undetected
Failed units:

Try my edited instructions @anon71037787 ...

1 Like

Here's the Brave shortcuts @rahuala ...

KDE Plasma's shortcuts can be adjusted in the settings here ... Keyboard > Layouts > Main Shortcut

1 Like

I actually get the KDE overview now, when I press the meta key :smiley:


Me too and actually that is more useful for me since I am already in the habit of clicking the dragon to open the app launcher. ThANks for that.

I also found this wiki on the keyboards in arch - a bit deep insofar as it presumes an advanced level of familiarity to apply much of what it recommends, but still could use to get advice from the experts in the forum here perhaps.

1 Like

That Brave page has a dialog for reporting issues but the strange thing is how nothing related to 'alt+2' is there anywhere.

From reading the Arch wiki it looks like my right AltGr key got mapped to follow the left regular Alt key (even though my est keyboard is clearly loaded and active), and that is how it lost the function. I.e., they show how to map them together, so I just have to work out how to un-join them. (Presumably to hunt down and delete it? If you can tell me exactly what I need to do in Garuda to unjoin them, I would have more confidence to do it lol :pray:)

From the wiki:

Other examples
To make the Right Alt key same as Left Alt key (for Emacs), use the following line in your keymap. It will include the file /usr/share/kbd/keymaps/i386/include/, check it for details.
include "linux-with-two-alt-keys"

you made a mistake here. You are binding meta key to show app overview not to launch the application launcher. Here is the correct one:

kwriteconfig5 --file ~/.config/kwinrc --group ModifierOnlyShortcuts --key Meta "org.kde.plasmashell,/PlasmaShell,org.kde.PlasmaShell,activateLauncherMenu"


qdbus org.kde.KWin /KWin reconfigure

Doesnt do anything for me. Even after plasmashell --replace

TL;DR :slight_smile:
Only meta key for app launcher work fine here.


in .config/kwinrc
Maybe you must delete key shortcuts in KDE settings.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.