Meta Key (Shortcut Alt + F1) doesn't work

Hey there. I come from using Manjaro KDE as well as Windows and I usually open applications by hitting the Meta key and typing the name. That doesn't work for me on Garuda Linux XFCE. I see that the corresponding action is bound to Alt + F1 which should be work for using the Meta key alone but nothing happens when I hit it. Also some other keybindings I'd expect don't register, like Meta + L for locking of Meta + D to minimize everything. I suspect it might be related to my Keymap (de_CH). Does anybody have any experience with this? Garuda is the first ever distro I tried that had this issue.

Kde and xfce have different features and keybindings.

Idk much about xfce, so @Yorper may help.

2 Likes

and
:slight_smile:

2 Likes

Thanks for your answer @Naman. Interestingly I had the exact same issue with the KDE no matter if Alt + F1 is bound to Latte Dock or the Panel's Application menu widget, so I assume it's not the DE itself causing the issue.

Check if existing apps have this assigned as this might cause issues.

3 Likes

Now that someone else has mentioned it I''ll add that in my Plasma the Alt F1 combo isn't assigning the Meta / Flag key to whichever Application menu being used.

1 Like

Thank you for your response!
I mean it's in a completely fresh install and I haven't configured anything yet so there are no "existing apps". I wonder how it can be, that I'm the only one that has this issue out of the box. I think there might be some underlying issue. In XFCE "Alt + F1" works to open the menu, "Meta" doesn't. In KDE both do nothing. It's really weird.

:point_down:

Sensible thought. Test by setting Standard KBD layout, with English simple layout.

You may also install xorg-xev package and use it to see the actual keys Xorg is listening (read man xev)

2 Likes

This is because I try to make minimal configuration changes to system defaults. I highly encourage people to make their systems their own.

It is very simple to set however, just go into the settings panel and select keyboard. Then from within this section select “application shortcuts”. From there you can set anything you want.

For example if you want the super key to open the whisker menu, you would want to map the super/win key to open xfce4-popup-whiskermenu.

I can add this to the next release if many people are expecting this as a default behaviour.

Hope that helps :+1:

4 Likes

Okay that's weird, it works but it says "Print" is now the assigned key. I can open the whisker menu using Meta in XFCE now. In KDE that wouldn't work though because there, Meta alone cannot be assigned as a shortcut so usually Alt + F1 is used and Meta is handled in a way where it sends ALt + F1, as far as I understand. But for some reason, in Garuda Meta -> Alt + F1 doesn't work.

It is correct that KDE handles Meta/Super/Win key specially, as you described.

2 Likes

I just retried on the KDE Ultimate Live Disk, this time with the default keymap. It still won't open the Application Menu if I map it to Alt + F1 and press the Meta key. Is that maybe some custom configuration?

Guys I found the culprit. To use the Meta key in KDE with Latte Dock installed, you have to add

[ModifierOnlyShortcuts]
Meta=org.kde.lattedock,/Latte,org.kde.LatteDock,activateLauncherMenu

to the kwinrc file. I didn't know this since I've never had latte dock installed before, as I usually prefer the panel style desktop experience.

1 Like

Well done, glad you see you got this solved :smiley: ( now mark it solved :stuck_out_tongue: )

2 Likes

And for us that removed Latte?

Confirm you don't have this setting, since it passes Meta to Latte, I guess.

3 Likes

I'm in kglobalshortcutsrc and fould the below using search in Kate.

[lattedock]
_k_friendly_name=Latte Dock

show latte global settings=Meta+W,Meta+W,Show Latte Global Settings
show latte view=Meta+`,Meta+`,Show Latte Dock/Panel

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.