Maximize window issue

Hi guys
When I maximize certain applications, for example: Firefox, Vim, the maximise, minimise and close buttons disappear.
These three dots at the top right of windows like the software update window are there, in some other programs when they are maximized they disappear.
Screenshot_20201112_090136
Do you know how to help me?
Thanks in advance.

Some more information please :thinking:

1 Like

:wink:

GNOME ?

inxi -Fxxxrza

I am using KDE

Not quite sure because I don't use the KDE version but that sounds like one if these two things for me:

  1. Window buttons Plasma extension
  2. Remove borders on fullscreen Kwin script

Both have the ability to remove borders on fullscreen windows, in fact this might even be working as intended. The Updater (Pamac) still has its window buttons because its a GTK3 native window decoration. (afaik)

1 Like

When is the last time you updated the system? There is a plasma bug affecting buttons. It was reported solved after a recent update.

edit I should also mention only GTK aps were affected which would explain why you are seeing this behavior with only certain applications.

1 Like

in settings -- Latte Dock under Preferences
on Behavior uncheck the box Support borderless maximized windows in different layouts
That have restore it at me even i don use latte dock on kde

1 Like

In settings: General Behavior or Window Behavior?

start latte then right click on the latte settings icon .. then configure latte

I don't have Latte

If you have the window buttons extension running, check for this option.

Otherwise look for "Hide titles" in Kwin scripts.

2 Likes