Maximing firedragon on startup

When I open Firedragon, it does not start in maximized mode, this is irritating and I don't know how to fix it.


Post your terminal/konsole in- and output as text (no pictures) from:


Without it, you will not receive any help from the Garuda team or your topic is likely to be closed without notice.

Before you open a new help request, read relevant sections of the Arch and Garuda wiki.
Thoroughly search your issue and any error messages in the forum and on the web.

Report everything you have already attempted to solve your problem.

You ignored the instructions in the topic template text. How are we supposed to know which DE you are using if you don't tell us? KDE will let you set per-window options, for example, but someone has to ask you what you are running rather than you posting the information already requested...

1 Like

I thought it was about the browser in general, and I'm always a bit weary when it comes to disclosing too much info, but if it can't be solved without this info, then I guess I will have to. Let me think about it. If there's a way to point me to the right link without it, that'd be awesome, but I guess rules are rules.

I don't know how to withdraw the question. I'll just go back to the normal firefox.

I'm not sure why telling us what DE you're running is disclosing too much information, but let me try searching the web for you...

leads to

so that's worth trying.

If it works in Firefox then it's because of this:

FireDragon includes resistFingerprinting by default.


Let's assume you run KDE.
In System Settings, Window Management, then Window Rules, you can set Firedragon to launch maximized, as well as a BUNCH of other rules.

Alternatively, if you have the Menu button within the Window Decorations of every application/window opened (located on the right-end side of the window deco in Garuda), you can set Window Properties/Actions from there. It will bring you to the above Window Rules panel I just mentioned.

These are all standard KDE features unrelated to how Garuda is built. You can set whatever rules you want to whatever window you want in KDE.


I understand that (and I feel the same), but unless something like a government agency or a seriously determined and tech-savvy bad guy is really is after you, there isn't much in the output of garuda-inxi to be wary about, besides perhaps the Machine: v: field which may give a hint about your nationality (or rather, your whereabouts at the time you bought your machine), but then again, you wouldn't log in with a nickname like "Avanti" and give up FireDragon's fingerprinting counter-measures to avoid the annoyance of pressing F11. Your IP whenever you connect to anything online will reveal your ISP and current location anyway, unless using TOR or some VPN (and then, you have to trust the VPN provider, and there are attacks against TOR too).

Now that I think about it, I may well wave my flag like most others do.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.