MASSIVE graphical bug when PC goes to resting mode

Hi guys, I’m new here though I have some experience with garuda already.
So, I needed to reinstall garuda for maintenance reasons. OS is working great, fast, fluid etc. If I have to leave the computer for any reason, it goes into resto mode, right? Well, thats the problem. once I return, I wake the PC up and am greeted with what can only be described as a very scary prank by the OS. screen goes multicolored and is full of graphical defects. white, green, blue and red squares in random patterns. plus it takes super long for the actual log in screen to show up. whe it does, a big square with the same random patters hangs around the mousee cursor. I have no Idea what this is. didnt happen before the system was reinstalled. Only way to fix it is logging out. but, surely enough, if it goes to resting mode… I got pictures. But the site doesnt let me upload them, so here are the links:

heres my inxi, don’t know if its of any help tho.

garuda-inxi
System:
Kernel: 6.9.3-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
clocksource: tsc avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=65159996-96ad-4cc1-9d40-3c11b2fb9795 rw rootflags=subvol=@
quiet loglevel=3 ibt=off
Desktop: KDE Plasma v: 6.0.5 tk: Qt v: N/A info: frameworks v: 6.2.0
wm: kwin_x11 vt: 2 dm: SDDM Distro: Garuda base: Arch Linux
Machine:
Type: Desktop Mobo: ASRock model: A320M-HD serial: <superuser required>
uuid: <superuser required> UEFI: American Megatrends v: P5.40
date: 07/09/2019
CPU:
Info: model: AMD Ryzen 5 2600 bits: 64 type: MT MCP arch: Zen+ gen: 2
level: v3 note: check built: 2018-21 process: GF 12nm family: 0x17 (23)
model-id: 8 stepping: 2 microcode: 0x800820D
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 576 KiB desc: d-6x32 KiB; i-6x64 KiB L2: 3 MiB desc: 6x512 KiB
L3: 16 MiB desc: 2x8 MiB
Speed (MHz): avg: 3314 high: 3400 min/max: 1550/3400 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3400 2: 2454
3: 3400 4: 3400 5: 3400 6: 3400 7: 3325 8: 3400 9: 3400 10: 3400 11: 3400
12: 3400 bogomips: 81585
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Graphics:
Device-1: NVIDIA GP106 [GeForce GTX 1060 3GB] vendor: Gigabyte
driver: nvidia v: 550.78 alternate: nouveau,nvidia_drm non-free: 545.xx+
status: current (as of 2024-04; EOL~2026-12-xx) arch: Pascal code: GP10x
process: TSMC 16nm built: 2016-2021 pcie: gen: 3 speed: 8 GT/s lanes: 8
link-max: lanes: 16 ports: active: none off: HDMI-A-1
empty: DP-1,DVI-D-1,DVI-D-2 bus-ID: 07:00.0 chip-ID: 10de:1c02
class-ID: 0300
Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 24.1.0
compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
alternate: fbdev,nouveau,nv,vesa gpu: nvidia,nvidia-nvswitch
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 81 s-size: 602x343mm (23.70x13.50")
s-diag: 693mm (27.28")
Monitor-1: HDMI-A-1 mapped: HDMI-0 note: disabled model: Philips PHL 272V8
serial: <filter> built: 2020 res: 1920x1080 dpi: 82 gamma: 1.2
size: 598x336mm (23.54x13.23") diag: 686mm (27") ratio: 16:9 modes:
max: 1920x1080 min: 640x480
API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 2
drv: swrast gbm: drv: nvidia surfaceless: drv: nvidia x11: drv: nvidia
inactive: wayland,device-1
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 550.78
glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce GTX 1060
3GB/PCIe/SSE2 memory: 2.93 GiB
API: Vulkan v: 1.3.279 layers: 11 device: 0 type: discrete-gpu name: NVIDIA
GeForce GTX 1060 3GB driver: nvidia v: 550.78 device-ID: 10de:1c02
surfaces: xcb,xlib
Audio:
Device-1: NVIDIA GP106 High Definition Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 8
link-max: lanes: 16 bus-ID: 07:00.1 chip-ID: 10de:10f1 class-ID: 0403
Device-2: AMD Family 17h HD Audio vendor: ASRock driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 09:00.3
chip-ID: 1022:1457 class-ID: 0403
API: ALSA v: k6.9.3-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
vendor: ASRock driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
port: f000 bus-ID: 06:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Info: services: NetworkManager, smbd, systemd-timesyncd
Bluetooth:
Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) driver: btusb
v: 0.8 type: USB rev: 1.1 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-9:3
chip-ID: 0a12:0001 class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.1
lmp-v: 10 status: discoverable: no pairing: no class-ID: 6c0104
Drives:
Local Storage: total: 1.84 TiB used: 1.07 TiB (58.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingbank model: KP230
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: SN12221 temp: 36.9 C
scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: XrayDisk model: 512GB SSD
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 18C1 scheme: GPT
ID-3: /dev/sdb maj-min: 8:16 vendor: Western Digital
model: WD10EARS-00Y5B1 size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 3.0 Gb/s tech: N/A serial: <filter> fw-rev: 0A80
scheme: MBR
Partition:
ID-1: / raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 162.59 GiB (34.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 27.3 MiB (9.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 162.59 GiB (34.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 162.59 GiB (34.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 162.59 GiB (34.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.55 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 12 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 47.4 C mobo: N/A gpu: nvidia temp: 55 C
Fan Speeds (rpm): N/A gpu: nvidia fan: 0%
Info:
Memory: total: 16 GiB available: 15.55 GiB used: 4.83 GiB (31.0%)
Processes: 387 Power: uptime: 7m states: freeze,mem,disk suspend: deep
avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 6.18 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
tool: systemctl
Packages: 1954 pm: pacman pkgs: 1942 libs: 571 tools: octopi,paru
pm: flatpak pkgs: 12 Compilers: clang: 17.0.6 gcc: 14.1.1 Shell: garuda-inxi
default: fish v: 3.7.1 running-in: konsole inxi: 3.3.34
Garuda (2.6.26-1):
System install date:     2024-06-08
Last full system update: 2024-06-09
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       Probably (Run as root to verify)
Failed units: 

Welcome to the community @reavv. :wave:

I pasted in the pictures you linked to make it easier for people to see them. You can add pictures yourself once the forum bumps you to TL1 (it’s usually pretty quick).

I kind of like the second picture–seems like it might make a nice pattern for a sweater or something. :face_with_hand_over_mouth:

Try setting up " Preserve video memory after suspend" as described in this article: NVIDIA/Tips and tricks - ArchWiki

You can add a kernel module parameter by creating a config in etc/modprobe.d/ with an editor like Micro:

sudo micro /etc/modprobe.d/nvidia-preserve-memory.conf

Paste in the options for the kernel module parameter:

options nvidia NVreg_PreserveVideoMemoryAllocations=1

Save and exit out of the file. Then rebuild the initramfs.

sudo dracut-rebuild

Finally, enable the services mentioned in the article.

sudo systemctl enable --now nvidia-suspend.service nvidia-hibernate.service nvidia-resume.service
7 Likes

Yoooo it worked. thanks!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.