Marvell 88W8897 - WIFI not detected

So basically I've used Garuda-Linux for over 4 Months on my Surface Pro 4 and the OS refuses to detect my WIFI-Card. I've tried everything, any other arch based distro does not recognise the card either. I had to use an external usb wifiadapter, until it got stolen. My surface uses Marvell AVASTAR Wireless-AC Network Controller. I couldn't find any drivers for Linux online. For some reason after on ubuntu the wifi works perfectly fine.
Installing headers did not work either. I have spend so much time searching for any info about this issue.
Also I noticed, that when I boot manjaro from an usb the wifi works but when I install it, same issue.

Kernel: 5.17.5-zen1-2-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=e0b216ea-5a1a-429b-8e35-fed023e675e7 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.3 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: Microsoft product: Surface Pro 4
v: 124000000000000000000000D:0B:08F:1C:03P:38 serial: <superuser required>
Chassis: type: 9 serial: <superuser required>
Mobo: Microsoft model: Surface Pro 4 serial: <superuser required>
UEFI: Microsoft v: 109.3748.768 date: 05.04.2021
Battery:
ID-1: BAT1 charge: 35.0 Wh (100.0%) condition: 35.0/38.2 Wh (91.7%)
volts: 8.6 min: 7.5 model: DYN X910528 type: Li-ion serial: <filter>
status: full cycles: 120
CPU:
Info: model: Intel Core i5-6300U bits: 64 type: MT MCP arch: Skylake
family: 6 model-id: 0x4E (78) stepping: 3 microcode: 0xF0
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 2923 high: 2939 min/max: 400/3000 scaling:
driver: intel_pstate governor: powersave cores: 1: 2902 2: 2939 3: 2930
4: 2923 bogomips: 19999
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort mitigation: TSX disabled
Graphics:
Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Microsoft
driver: i915 v: kernel ports: active: eDP-1
empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:1916
class-ID: 0300
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 2736x1824 s-dpi: 96 s-size: 723x482mm (28.46x18.98")
s-diag: 869mm (34.21")
Monitor-1: eDP-1 model: Samsung 0x3853 built: 2015 res: 2736x1824 hz: 60
dpi: 267 gamma: 1.2 size: 260x173mm (10.24x6.81") diag: 312mm (12.3")
ratio: 3:2 modes: 2736x1824
OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) v: 4.6 Mesa 22.0.3
direct render: Yes
Audio:
Device-1: Intel Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Imaging
Unit
driver: ipu3-imgu alternate: ipu3_imgu bus-ID: 00:05.0 chip-ID: 8086:1919
class-ID: 0480
Device-2: Intel CSI-2 Host driver: ipu3-cio2 alternate: ipu3_cio2
bus-ID: 00:14.3 chip-ID: 8086:9d32 class-ID: 0480
Device-3: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel v: kernel
alternate: snd_soc_skl bus-ID: 00:1f.3 chip-ID: 8086:9d70 class-ID: 0403
Sound Server-1: ALSA v: k5.17.5-zen1-2-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.51 running: yes
Network:
Device-1: Marvell 88W8897 [AVASTAR] 802.11ac Wireless driver: mwifiex_pcie
v: 1.0 pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0
chip-ID: 11ab:2b38 class-ID: 0200
Device-2: Microsoft RTL8153 GigE [Surface Ethernet Adapter] type: USB
driver: r8152 bus-ID: 2-2.2:5 chip-ID: 045e:07c6 class-ID: 0000
serial: <filter>
IF: enp0s20f0u2u2 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
Local Storage: total: 252.79 GiB used: 29.03 GiB (11.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
model: MZFLV256HCHP-000MV size: 238.47 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: BXV75M0Q temp: 34.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 type: USB vendor: SanDisk model: USB 3.2Gen1
size: 14.32 GiB block-size: physical: 512 B logical: 512 B type: N/A
serial: <filter> rev: 1.00 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 117.19 GiB size: 117.19 GiB (100.00%)
used: 17.15 GiB (14.6%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 26 MiB (8.7%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 117.19 GiB size: 117.19 GiB (100.00%)
used: 17.15 GiB (14.6%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
ID-4: /var/log raw-size: 117.19 GiB size: 117.19 GiB (100.00%)
used: 17.15 GiB (14.6%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
ID-5: /var/tmp raw-size: 117.19 GiB size: 117.19 GiB (100.00%)
used: 17.15 GiB (14.6%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.68 GiB used: 34 MiB (0.4%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 48.0 C pch: 40.0 C mobo: 0.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 217 Uptime: 36m wakeups: 1 Memory: 7.69 GiB
used: 3.92 GiB (51.0%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 12.1.0 Packages: pacman: 1141 lib: 291 Shell: fish v: 3.4.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.15
Garuda (2.6.2-1):
System install date:     2022-05-11
Last full system update: 2022-05-11
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:            bluetooth-autoconnect.service
type or paste code here

Welcome to the Forums!

In your googling around did you search for this driver

mwifiex_pcie
2 Likes

Maybe check if this firmware helps
https://archlinux.org/packages/core/any/linux-firmware-marvell/
PS:
Source and further info

4 Likes

This driver is nowhere found on the aur, how do I install it?
Thx in advance))

You already have it.

3 Likes

OMG!!!
How did u find this source.
I can't believe it worked, you saved a students life, you can't imagine how miserable my experience was with an external wifi-adapter!
Thanks man!!!

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.